Message ID | 1423400155-28078-1-git-send-email-hofrat@osadl.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Sun, 2015-02-08 at 07:55AM -0500, Nicholas Mc Guire wrote: > return type of wait_for_completion_timeout is unsigned long not int. as > ret is only used for wait_for_completion_timeout anyway the type is simply > changed to unsigned long. > > Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org> Reviewed-by: Sören Brinkmann <soren.brinkmann@xilinx.com> Sören
On Sun, Feb 08, 2015 at 07:55:55AM -0500, Nicholas Mc Guire wrote: > return type of wait_for_completion_timeout is unsigned long not int. as > ret is only used for wait_for_completion_timeout anyway the type is simply > changed to unsigned long. > > Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org> Same as for the axxia driver: Please rename the variable because ret being an int is kind of an idiom. > --- > > Patch was only compile tested with multi_v7_defconfig > (implies CONFIG_I2C_CADENCE=y) > > Patch is against 3.19.0-rc7 (localversion-next is -next-20150204) > > drivers/i2c/busses/i2c-cadence.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c > index 7d7a14c..5fbffe0 100644 > --- a/drivers/i2c/busses/i2c-cadence.c > +++ b/drivers/i2c/busses/i2c-cadence.c > @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap) > static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg, > struct i2c_adapter *adap) > { > - int ret; > + unsigned long ret; > u32 reg; > > id->p_msg = msg; > -- > 1.7.10.4 >
diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c index 7d7a14c..5fbffe0 100644 --- a/drivers/i2c/busses/i2c-cadence.c +++ b/drivers/i2c/busses/i2c-cadence.c @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap) static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg, struct i2c_adapter *adap) { - int ret; + unsigned long ret; u32 reg; id->p_msg = msg;
return type of wait_for_completion_timeout is unsigned long not int. as ret is only used for wait_for_completion_timeout anyway the type is simply changed to unsigned long. Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org> --- Patch was only compile tested with multi_v7_defconfig (implies CONFIG_I2C_CADENCE=y) Patch is against 3.19.0-rc7 (localversion-next is -next-20150204) drivers/i2c/busses/i2c-cadence.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)