diff mbox

ARM: avoid cache flushing in flush_dcache_page()

Message ID 1478514624-30910-1-git-send-email-rabin.vincent@axis.com (mailing list archive)
State New, archived
Headers show

Commit Message

Rabin Vincent Nov. 7, 2016, 10:30 a.m. UTC
From: Rabin Vincent <rabinv@axis.com>

When the data cache is PIPT or VIPT non-aliasing, and cache operations
are broadcast by the hardware, we can always postpone the flush in
flush_dcache_page().  A similar change was done for ARM64 in commit
b5b6c9e9149d ("arm64: Avoid cache flushing in flush_dcache_page()").

Signed-off-by: Rabin Vincent <rabinv@axis.com>
---
 arch/arm/mm/flush.c | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Catalin Marinas Nov. 7, 2016, 11:35 a.m. UTC | #1
On Mon, Nov 07, 2016 at 11:30:24AM +0100, Rabin Vincent wrote:
> diff --git a/arch/arm/mm/flush.c b/arch/arm/mm/flush.c
> index 3cced84..f1e6190 100644
> --- a/arch/arm/mm/flush.c
> +++ b/arch/arm/mm/flush.c
> @@ -327,6 +327,12 @@ void flush_dcache_page(struct page *page)
>  	if (page == ZERO_PAGE(0))
>  		return;
>  
> +	if (!cache_ops_need_broadcast() && cache_is_vipt_nonaliasing()) {
> +		if (test_bit(PG_dcache_clean, &page->flags))
> +			clear_bit(PG_dcache_clean, &page->flags);
> +		return;
> +	}
> +
>  	mapping = page_mapping(page);
>  
>  	if (!cache_ops_need_broadcast() &&

I'm ok with the logic in this patch but is there a way to combine the
two 'if' blocks together, just to keep the function shorter?
Russell King (Oracle) Nov. 7, 2016, 11:48 a.m. UTC | #2
On Mon, Nov 07, 2016 at 11:35:27AM +0000, Catalin Marinas wrote:
> On Mon, Nov 07, 2016 at 11:30:24AM +0100, Rabin Vincent wrote:
> > diff --git a/arch/arm/mm/flush.c b/arch/arm/mm/flush.c
> > index 3cced84..f1e6190 100644
> > --- a/arch/arm/mm/flush.c
> > +++ b/arch/arm/mm/flush.c
> > @@ -327,6 +327,12 @@ void flush_dcache_page(struct page *page)
> >  	if (page == ZERO_PAGE(0))
> >  		return;
> >  
> > +	if (!cache_ops_need_broadcast() && cache_is_vipt_nonaliasing()) {
> > +		if (test_bit(PG_dcache_clean, &page->flags))
> > +			clear_bit(PG_dcache_clean, &page->flags);
> > +		return;
> > +	}
> > +
> >  	mapping = page_mapping(page);
> >  
> >  	if (!cache_ops_need_broadcast() &&
> 
> I'm ok with the logic in this patch but is there a way to combine the
> two 'if' blocks together, just to keep the function shorter?

Probably not without reducing code readability, or moving
page_mapping() before this new if() block (which may introduce
extra code into the path.)

As this path gets used for filesystem read/write, it would be a
good idea to keep it as efficient as possible.
Catalin Marinas Nov. 7, 2016, noon UTC | #3
On Mon, Nov 07, 2016 at 11:48:45AM +0000, Russell King - ARM Linux wrote:
> On Mon, Nov 07, 2016 at 11:35:27AM +0000, Catalin Marinas wrote:
> > On Mon, Nov 07, 2016 at 11:30:24AM +0100, Rabin Vincent wrote:
> > > diff --git a/arch/arm/mm/flush.c b/arch/arm/mm/flush.c
> > > index 3cced84..f1e6190 100644
> > > --- a/arch/arm/mm/flush.c
> > > +++ b/arch/arm/mm/flush.c
> > > @@ -327,6 +327,12 @@ void flush_dcache_page(struct page *page)
> > >  	if (page == ZERO_PAGE(0))
> > >  		return;
> > >  
> > > +	if (!cache_ops_need_broadcast() && cache_is_vipt_nonaliasing()) {
> > > +		if (test_bit(PG_dcache_clean, &page->flags))
> > > +			clear_bit(PG_dcache_clean, &page->flags);
> > > +		return;
> > > +	}
> > > +
> > >  	mapping = page_mapping(page);
> > >  
> > >  	if (!cache_ops_need_broadcast() &&
> > 
> > I'm ok with the logic in this patch but is there a way to combine the
> > two 'if' blocks together, just to keep the function shorter?
> 
> Probably not without reducing code readability, or moving
> page_mapping() before this new if() block (which may introduce
> extra code into the path.)

You are right, we would need 'mapping' in the subsequent checks, so I
don't think the code would be more readable if we are to keep it
efficient. In this case:

Reviewed-by: Catalin Marinas <catalin.marinas@arm.com>
diff mbox

Patch

diff --git a/arch/arm/mm/flush.c b/arch/arm/mm/flush.c
index 3cced84..f1e6190 100644
--- a/arch/arm/mm/flush.c
+++ b/arch/arm/mm/flush.c
@@ -327,6 +327,12 @@  void flush_dcache_page(struct page *page)
 	if (page == ZERO_PAGE(0))
 		return;
 
+	if (!cache_ops_need_broadcast() && cache_is_vipt_nonaliasing()) {
+		if (test_bit(PG_dcache_clean, &page->flags))
+			clear_bit(PG_dcache_clean, &page->flags);
+		return;
+	}
+
 	mapping = page_mapping(page);
 
 	if (!cache_ops_need_broadcast() &&