diff mbox

ARM: shmobile: Genmai SPI over GPIO support

Message ID 20131204212915.24243.27225.sendpatchset@w520 (mailing list archive)
State New, archived
Headers show

Commit Message

Magnus Damm Dec. 4, 2013, 9:29 p.m. UTC
From: Magnus Damm <damm@opensource.se>

Hook up the serial flash memory to bit bang SPI on the Genmai board.

Signed-off-by: Magnus Damm <damm@opensource.se>
---

 Written on to of renesas git tag renesas-devel-v3.13-rc2-20131202 and
 [PATCH 00/04] ARM: shmobile: r7s72100 and Genmai GPIO / PINCTRL support

 arch/arm/boot/dts/r7s72100-genmai-reference.dts |   15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Laurent Pinchart Dec. 4, 2013, 10:54 p.m. UTC | #1
Hi Magnus,

Thank you for the patch.

On Thursday 05 December 2013 06:29:15 Magnus Damm wrote:
> From: Magnus Damm <damm@opensource.se>
> 
> Hook up the serial flash memory to bit bang SPI on the Genmai board.
> 
> Signed-off-by: Magnus Damm <damm@opensource.se>
> ---
> 
>  Written on to of renesas git tag renesas-devel-v3.13-rc2-20131202 and
>  [PATCH 00/04] ARM: shmobile: r7s72100 and Genmai GPIO / PINCTRL support
> 
>  arch/arm/boot/dts/r7s72100-genmai-reference.dts |   15 +++++++++++++++
>  1 file changed, 15 insertions(+)
> 
> --- 0010/arch/arm/boot/dts/r7s72100-genmai-reference.dts
> +++ work/arch/arm/boot/dts/r7s72100-genmai-reference.dts	2013-12-05
> 06:23:57.000000000 +0900 @@ -56,5 +56,20 @@
>  			reg = <0x50>;
>  		};
>  	};
> +	spi0 {
> +		compatible = "spi-gpio";
> +		gpio-sck = <&port9 2 0>;
> +		gpio-mosi = <&port9 4 0>;
> +		gpio-miso = <&port9 5 0>;
> +		cs-gpios = <&port9 3 0>;

What about replacing those 0 with GPIO_ACTIVE_HIGH ?

> +		num-chipselects = <1>;
> +		#address-cells = <1>;
> +		#size-cells = <0>;
> 
> +		s25fl512s: s25fl512s0 {

The node should be called flash@0.

> +			compatible = "s25fl512s";
> +			reg = <0>;
> +			spi-max-frequency = <104000000>;
> +                };
> +        };

Please use tabs for indentation here.

The rest looks fine to me, but I obviously can't review most of the 
information as I don't have access to the board schematics. I'll trust you 
that you have tested the patch :-)

>  };
Sergei Shtylyov Dec. 5, 2013, 12:20 p.m. UTC | #2
Hello.

On 05-12-2013 1:29, Magnus Damm wrote:

> From: Magnus Damm <damm@opensource.se>

> Hook up the serial flash memory to bit bang SPI on the Genmai board.

> Signed-off-by: Magnus Damm <damm@opensource.se>
> ---

>   Written on to of renesas git tag renesas-devel-v3.13-rc2-20131202 and
>   [PATCH 00/04] ARM: shmobile: r7s72100 and Genmai GPIO / PINCTRL support

>   arch/arm/boot/dts/r7s72100-genmai-reference.dts |   15 +++++++++++++++
>   1 file changed, 15 insertions(+)

> --- 0010/arch/arm/boot/dts/r7s72100-genmai-reference.dts
> +++ work/arch/arm/boot/dts/r7s72100-genmai-reference.dts	2013-12-05 06:23:57.000000000 +0900
> @@ -56,5 +56,20 @@
>   			reg = <0x50>;
>   		};
>   	};
> +	spi0 {

    Maybe just "spi"?

> +		compatible = "spi-gpio";
> +		gpio-sck = <&port9 2 0>;
> +		gpio-mosi = <&port9 4 0>;
> +		gpio-miso = <&port9 5 0>;
> +		cs-gpios = <&port9 3 0>;
> +		num-chipselects = <1>;
> +		#address-cells = <1>;
> +		#size-cells = <0>;
>
> +		s25fl512s: s25fl512s0 {

    The node should probably be named "flash", according to ePAPR spec. And 
why you didn't specify "@0"?

> +			compatible = "s25fl512s";
> +			reg = <0>;
> +			spi-max-frequency = <104000000>;
> +                };
> +        };
>   };

WBR, Sergei
diff mbox

Patch

--- 0010/arch/arm/boot/dts/r7s72100-genmai-reference.dts
+++ work/arch/arm/boot/dts/r7s72100-genmai-reference.dts	2013-12-05 06:23:57.000000000 +0900
@@ -56,5 +56,20 @@ 
 			reg = <0x50>;
 		};
 	};
+	spi0 {
+		compatible = "spi-gpio";
+		gpio-sck = <&port9 2 0>;
+		gpio-mosi = <&port9 4 0>;
+		gpio-miso = <&port9 5 0>;
+		cs-gpios = <&port9 3 0>;
+		num-chipselects = <1>;
+		#address-cells = <1>;
+		#size-cells = <0>;
 
+		s25fl512s: s25fl512s0 {
+			compatible = "s25fl512s";
+			reg = <0>;
+			spi-max-frequency = <104000000>;
+                };
+        };
 };