diff mbox

[3/6] spi: spi-s3c64xx: Drop unused enable_datapath() function argument

Message ID 20180416154021.25626-3-s.nawrocki@samsung.com (mailing list archive)
State New, archived
Headers show

Commit Message

The spi pointer argument is not used now so remove it. While at it
s3c64xx_ prefix is added to the function name.

Signed-off-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
---
 drivers/spi/spi-s3c64xx.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

--
2.14.2

Comments

Andi Shyti April 16, 2018, 7:09 p.m. UTC | #1
Hi Sylwester,

On 17.04.2018 00:40, Sylwester Nawrocki wrote:
> The spi pointer argument is not used now so remove it. While at it
> s3c64xx_ prefix is added to the function name.

These for me are two different patches, but in any case it's trivial
so that I don't mind it too much.

> Signed-off-by: Sylwester Nawrocki <s.nawrocki@samsung.com>

Reviewed-by: Andi Shyti <andi@etezian.org>

Thanks,
Andi
Krzysztof Kozlowski April 17, 2018, 6:28 a.m. UTC | #2
On Mon, Apr 16, 2018 at 5:40 PM, Sylwester Nawrocki
<s.nawrocki@samsung.com> wrote:
> The spi pointer argument is not used now so remove it. While at it
> s3c64xx_ prefix is added to the function name.
>
> Signed-off-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
> ---
>  drivers/spi/spi-s3c64xx.c | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)


Reviewed-by: Krzysztof Kozlowski <krzk@kernel.org>

Best regards,
Krzysztof
Hi Andi,

On 04/16/2018 09:09 PM, andi@etezian.org wrote:
> On 17.04.2018 00:40, Sylwester Nawrocki wrote:
>> The spi pointer argument is not used now so remove it. While at it
>> s3c64xx_ prefix is added to the function name.
>
> These for me are two different patches, but in any case it's trivial
> so that I don't mind it too much.

I am going to drop renaming from this patch. There are 2 more functions
(wait_for_pio(), wait_for_dma()) without prefix, should we rename them
too or rather leave all 3 as they are now?
Krzysztof Kozlowski April 17, 2018, 10:51 a.m. UTC | #4
On Tue, Apr 17, 2018 at 12:02 PM, Sylwester Nawrocki
<s.nawrocki@samsung.com> wrote:
> Hi Andi,
>
> On 04/16/2018 09:09 PM, andi@etezian.org wrote:
>> On 17.04.2018 00:40, Sylwester Nawrocki wrote:
>>> The spi pointer argument is not used now so remove it. While at it
>>> s3c64xx_ prefix is added to the function name.
>>
>> These for me are two different patches, but in any case it's trivial
>> so that I don't mind it too much.
>
> I am going to drop renaming from this patch. There are 2 more functions
> (wait_for_pio(), wait_for_dma()) without prefix, should we rename them
> too or rather leave all 3 as they are now?

Indeed it is kind of mixed up - some purely local functions (not even
passed through pointer to some ops) have prefix, some do not. If you
ask me, I would prefer to have the prefix on all of them because:
1. If they appear in call trace (where backtrace pointers are not
telling anything) it is easy to understand their location,
2. having generic name like "wait_for_dma" sounds for me like generic,
Linux-wide macro (but it is not).

However I do not insist on that.

Best regards,
Krzysztof
diff mbox

Patch

diff --git a/drivers/spi/spi-s3c64xx.c b/drivers/spi/spi-s3c64xx.c
index b7333a883442..e90e60bc1ecc 100644
--- a/drivers/spi/spi-s3c64xx.c
+++ b/drivers/spi/spi-s3c64xx.c
@@ -348,9 +348,8 @@  static bool s3c64xx_spi_can_dma(struct spi_master *master,
 	return xfer->len > (FIFO_LVL_MASK(sdd) >> 1) + 1;
 }

-static void enable_datapath(struct s3c64xx_spi_driver_data *sdd,
-				struct spi_device *spi,
-				struct spi_transfer *xfer, int dma_mode)
+static void s3c64xx_enable_datapath(struct s3c64xx_spi_driver_data *sdd,
+				    struct spi_transfer *xfer, int dma_mode)
 {
 	void __iomem *regs = sdd->regs;
 	u32 modecfg, chcfg;
@@ -665,7 +664,7 @@  static int s3c64xx_spi_transfer_one(struct spi_master *master,
 	sdd->state &= ~RXBUSY;
 	sdd->state &= ~TXBUSY;

-	enable_datapath(sdd, spi, xfer, use_dma);
+	s3c64xx_enable_datapath(sdd, xfer, use_dma);

 	/* Start the signals */
 	s3c64xx_spi_set_cs(spi, true);