Message ID | 20190802170300.20662-8-cristian.marussi@arm.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Add arm64/signal initial kselftest support | expand |
On Fri, Aug 02, 2019 at 06:02:56PM +0100, Cristian Marussi wrote: > Added a simple fake_sigreturn testcase which builds a ucontext_t Add > with a badly sized magic0 header and place it onto the stack. I usually call a record with magic number 0 a "terminator record". > Expects a SIGSEGV on test PASS. > > Signed-off-by: Cristian Marussi <cristian.marussi@arm.com> > --- > .../arm64/signal/testcases/.gitignore | 1 + > .../fake_sigreturn_bad_size_for_magic0.c | 57 +++++++++++++++++++ > 2 files changed, 58 insertions(+) > create mode 100644 tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c > > diff --git a/tools/testing/selftests/arm64/signal/testcases/.gitignore b/tools/testing/selftests/arm64/signal/testcases/.gitignore > index 0ea6fdc3765c..cf2a73599818 100644 > --- a/tools/testing/selftests/arm64/signal/testcases/.gitignore > +++ b/tools/testing/selftests/arm64/signal/testcases/.gitignore > @@ -5,3 +5,4 @@ mangle_pstate_invalid_mode_el2 > mangle_pstate_invalid_mode_el3 > mangle_pstate_ssbs_regs > fake_sigreturn_bad_magic > +fake_sigreturn_bad_size_for_magic0 > diff --git a/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c b/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c > new file mode 100644 > index 000000000000..2f53c4740c85 > --- /dev/null > +++ b/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c > @@ -0,0 +1,57 @@ > +/* SPDX-License-Identifier: GPL-2.0 */ > +/* Copyright (C) 2019 ARM Limited */ > + #include <signal.h> ? > +#include <stdio.h> > +#include <ucontext.h> > + > +#include "test_signals_utils.h" > +#include "testcases.h" > + > +struct fake_sigframe sf; > + > +#define MIN_SZ_ALIGN 16 > + > +static int fake_sigreturn_bad_size_for_magic0_run(struct tdescr *td, > + siginfo_t *si, ucontext_t *uc) > +{ > + size_t resv_sz, offset; > + struct _aarch64_ctx *shead = GET_SF_RESV_HEAD(sf), *head; > + > + /* just to fill the ucontext_t with something real */ > + if (!get_current_context(td, &sf.uc)) > + return 1; > + > + resv_sz = GET_SF_RESV_SIZE(sf); > + /* > + * find the terminator, preserving existing headers > + * and verify amount of spare room in __reserved area. > + */ > + head = get_terminator(shead, resv_sz, &offset); > + /* > + * try stripping extra_context header when low on space: > + * we need at least HDR_SZ + 16 space for the bad sized terminator. > + */ > + if (head && resv_sz - offset < HDR_SZ + MIN_SZ_ALIGN) { > + fprintf(stderr, "Low on space:%zd. Discarding extra_context.\n", > + resv_sz - offset); > + head = get_header(shead, EXTRA_MAGIC, resv_sz, &offset); > + } > + /* just give up and timeout if still not enough space */ > + if (head && resv_sz - offset >= HDR_SZ + MIN_SZ_ALIGN) { > + head->magic = 0; > + head->size = MIN_SZ_ALIGN; This is different from the amount of space we tested for (HDR_SZ + MIN_SZ_ALIGN) earlier. I'm not sure it matters which we use, but we should be consistent. I suggest sticking with HDR_SZ, unless there's something I've missed. [...] Cheers ---Dave
On 13/08/2019 17:25, Dave Martin wrote: > On Fri, Aug 02, 2019 at 06:02:56PM +0100, Cristian Marussi wrote: >> Added a simple fake_sigreturn testcase which builds a ucontext_t > > Add Ok > >> with a badly sized magic0 header and place it onto the stack. > > I usually call a record with magic number 0 a "terminator record". > Ok >> Expects a SIGSEGV on test PASS. >> >> Signed-off-by: Cristian Marussi <cristian.marussi@arm.com> >> --- >> .../arm64/signal/testcases/.gitignore | 1 + >> .../fake_sigreturn_bad_size_for_magic0.c | 57 +++++++++++++++++++ >> 2 files changed, 58 insertions(+) >> create mode 100644 tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c >> >> diff --git a/tools/testing/selftests/arm64/signal/testcases/.gitignore b/tools/testing/selftests/arm64/signal/testcases/.gitignore >> index 0ea6fdc3765c..cf2a73599818 100644 >> --- a/tools/testing/selftests/arm64/signal/testcases/.gitignore >> +++ b/tools/testing/selftests/arm64/signal/testcases/.gitignore >> @@ -5,3 +5,4 @@ mangle_pstate_invalid_mode_el2 >> mangle_pstate_invalid_mode_el3 >> mangle_pstate_ssbs_regs >> fake_sigreturn_bad_magic >> +fake_sigreturn_bad_size_for_magic0 >> diff --git a/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c b/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c >> new file mode 100644 >> index 000000000000..2f53c4740c85 >> --- /dev/null >> +++ b/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c >> @@ -0,0 +1,57 @@ >> +/* SPDX-License-Identifier: GPL-2.0 */ >> +/* Copyright (C) 2019 ARM Limited */ >> + > > #include <signal.h> ? > Ok >> +#include <stdio.h> >> +#include <ucontext.h> >> + >> +#include "test_signals_utils.h" >> +#include "testcases.h" >> + >> +struct fake_sigframe sf; >> + >> +#define MIN_SZ_ALIGN 16 >> + >> +static int fake_sigreturn_bad_size_for_magic0_run(struct tdescr *td, >> + siginfo_t *si, ucontext_t *uc) >> +{ >> + size_t resv_sz, offset; >> + struct _aarch64_ctx *shead = GET_SF_RESV_HEAD(sf), *head; >> + >> + /* just to fill the ucontext_t with something real */ >> + if (!get_current_context(td, &sf.uc)) >> + return 1; >> + >> + resv_sz = GET_SF_RESV_SIZE(sf); >> + /* >> + * find the terminator, preserving existing headers >> + * and verify amount of spare room in __reserved area. >> + */ >> + head = get_terminator(shead, resv_sz, &offset); >> + /* >> + * try stripping extra_context header when low on space: >> + * we need at least HDR_SZ + 16 space for the bad sized terminator. >> + */ >> + if (head && resv_sz - offset < HDR_SZ + MIN_SZ_ALIGN) { >> + fprintf(stderr, "Low on space:%zd. Discarding extra_context.\n", >> + resv_sz - offset); >> + head = get_header(shead, EXTRA_MAGIC, resv_sz, &offset); >> + } >> + /* just give up and timeout if still not enough space */ >> + if (head && resv_sz - offset >= HDR_SZ + MIN_SZ_ALIGN) { >> + head->magic = 0; >> + head->size = MIN_SZ_ALIGN; > > This is different from the amount of space we tested for > (HDR_SZ + MIN_SZ_ALIGN) earlier. > > I'm not sure it matters which we use, but we should be consistent. > > I suggest sticking with HDR_SZ, unless there's something I've missed. > I'll stick to HDR_SZ in this case and use the new helper from 06/11 (get_starting_head) > [...] > > Cheers > ---Dave > Cheers Cristian
diff --git a/tools/testing/selftests/arm64/signal/testcases/.gitignore b/tools/testing/selftests/arm64/signal/testcases/.gitignore index 0ea6fdc3765c..cf2a73599818 100644 --- a/tools/testing/selftests/arm64/signal/testcases/.gitignore +++ b/tools/testing/selftests/arm64/signal/testcases/.gitignore @@ -5,3 +5,4 @@ mangle_pstate_invalid_mode_el2 mangle_pstate_invalid_mode_el3 mangle_pstate_ssbs_regs fake_sigreturn_bad_magic +fake_sigreturn_bad_size_for_magic0 diff --git a/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c b/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c new file mode 100644 index 000000000000..2f53c4740c85 --- /dev/null +++ b/tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c @@ -0,0 +1,57 @@ +/* SPDX-License-Identifier: GPL-2.0 */ +/* Copyright (C) 2019 ARM Limited */ + +#include <stdio.h> +#include <ucontext.h> + +#include "test_signals_utils.h" +#include "testcases.h" + +struct fake_sigframe sf; + +#define MIN_SZ_ALIGN 16 + +static int fake_sigreturn_bad_size_for_magic0_run(struct tdescr *td, + siginfo_t *si, ucontext_t *uc) +{ + size_t resv_sz, offset; + struct _aarch64_ctx *shead = GET_SF_RESV_HEAD(sf), *head; + + /* just to fill the ucontext_t with something real */ + if (!get_current_context(td, &sf.uc)) + return 1; + + resv_sz = GET_SF_RESV_SIZE(sf); + /* + * find the terminator, preserving existing headers + * and verify amount of spare room in __reserved area. + */ + head = get_terminator(shead, resv_sz, &offset); + /* + * try stripping extra_context header when low on space: + * we need at least HDR_SZ + 16 space for the bad sized terminator. + */ + if (head && resv_sz - offset < HDR_SZ + MIN_SZ_ALIGN) { + fprintf(stderr, "Low on space:%zd. Discarding extra_context.\n", + resv_sz - offset); + head = get_header(shead, EXTRA_MAGIC, resv_sz, &offset); + } + /* just give up and timeout if still not enough space */ + if (head && resv_sz - offset >= HDR_SZ + MIN_SZ_ALIGN) { + head->magic = 0; + head->size = MIN_SZ_ALIGN; + + ASSERT_BAD_CONTEXT(&sf.uc); + fake_sigreturn(&sf, sizeof(sf), 16); + } + + return 1; +} + +struct tdescr tde = { + .name = "FAKE_SIGRETURN_BAD_SIZE_FOR_MAGIC0", + .descr = "Triggers a fake sigreturn with a sigframe including a bad non-zero size magic0", + .sig_ok = SIGSEGV, + .timeout = 3, + .run = fake_sigreturn_bad_size_for_magic0_run, +};
Added a simple fake_sigreturn testcase which builds a ucontext_t with a badly sized magic0 header and place it onto the stack. Expects a SIGSEGV on test PASS. Signed-off-by: Cristian Marussi <cristian.marussi@arm.com> --- .../arm64/signal/testcases/.gitignore | 1 + .../fake_sigreturn_bad_size_for_magic0.c | 57 +++++++++++++++++++ 2 files changed, 58 insertions(+) create mode 100644 tools/testing/selftests/arm64/signal/testcases/fake_sigreturn_bad_size_for_magic0.c