diff mbox series

[v3,4/5] iommu: intel: Use generic_iommu_put_resv_regions()

Message ID 20191218134205.1271740-5-thierry.reding@gmail.com (mailing list archive)
State Mainlined
Commit 0ecdebb7dad586f15c3a5a98bb0cf431ca2fc1da
Headers show
Series iommu: Implement generic_iommu_put_resv_regions() | expand

Commit Message

Thierry Reding Dec. 18, 2019, 1:42 p.m. UTC
From: Thierry Reding <treding@nvidia.com>

Use the new standard function instead of open-coding it.

Cc: David Woodhouse <dwmw2@infradead.org>
Signed-off-by: Thierry Reding <treding@nvidia.com>
---
 drivers/iommu/intel-iommu.c | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)

Comments

Baolu Lu Dec. 19, 2019, 1:53 a.m. UTC | #1
Please tweak the title to

"iommu/vt-d: Use generic_iommu_put_resv_regions()"

then,

Acked-by: Lu Baolu <baolu.lu@linux.intel.com>

Best regards,
baolu

On 12/18/19 9:42 PM, Thierry Reding wrote:
> From: Thierry Reding <treding@nvidia.com>
> 
> Use the new standard function instead of open-coding it.
> 
> Cc: David Woodhouse <dwmw2@infradead.org>
> Signed-off-by: Thierry Reding <treding@nvidia.com>
> ---
>   drivers/iommu/intel-iommu.c | 11 +----------
>   1 file changed, 1 insertion(+), 10 deletions(-)
> 
> diff --git a/drivers/iommu/intel-iommu.c b/drivers/iommu/intel-iommu.c
> index 42966611a192..a6d5b7cf9183 100644
> --- a/drivers/iommu/intel-iommu.c
> +++ b/drivers/iommu/intel-iommu.c
> @@ -5744,15 +5744,6 @@ static void intel_iommu_get_resv_regions(struct device *device,
>   	list_add_tail(&reg->list, head);
>   }
>   
> -static void intel_iommu_put_resv_regions(struct device *dev,
> -					 struct list_head *head)
> -{
> -	struct iommu_resv_region *entry, *next;
> -
> -	list_for_each_entry_safe(entry, next, head, list)
> -		kfree(entry);
> -}
> -
>   int intel_iommu_enable_pasid(struct intel_iommu *iommu, struct device *dev)
>   {
>   	struct device_domain_info *info;
> @@ -5987,7 +5978,7 @@ const struct iommu_ops intel_iommu_ops = {
>   	.add_device		= intel_iommu_add_device,
>   	.remove_device		= intel_iommu_remove_device,
>   	.get_resv_regions	= intel_iommu_get_resv_regions,
> -	.put_resv_regions	= intel_iommu_put_resv_regions,
> +	.put_resv_regions	= generic_iommu_put_resv_regions,
>   	.apply_resv_region	= intel_iommu_apply_resv_region,
>   	.device_group		= pci_device_group,
>   	.dev_has_feat		= intel_iommu_dev_has_feat,
>
Thierry Reding Dec. 19, 2019, 12:47 p.m. UTC | #2
On Thu, Dec 19, 2019 at 09:53:22AM +0800, Lu Baolu wrote:
> Please tweak the title to
> 
> "iommu/vt-d: Use generic_iommu_put_resv_regions()"
> 
> then,
> 
> Acked-by: Lu Baolu <baolu.lu@linux.intel.com>
> 
> Best regards,
> baolu

Joerg, do you want me to resend with this change or is it more efficient
if you fix up the subject while applying?

Thierry

> On 12/18/19 9:42 PM, Thierry Reding wrote:
> > From: Thierry Reding <treding@nvidia.com>
> > 
> > Use the new standard function instead of open-coding it.
> > 
> > Cc: David Woodhouse <dwmw2@infradead.org>
> > Signed-off-by: Thierry Reding <treding@nvidia.com>
> > ---
> >   drivers/iommu/intel-iommu.c | 11 +----------
> >   1 file changed, 1 insertion(+), 10 deletions(-)
> > 
> > diff --git a/drivers/iommu/intel-iommu.c b/drivers/iommu/intel-iommu.c
> > index 42966611a192..a6d5b7cf9183 100644
> > --- a/drivers/iommu/intel-iommu.c
> > +++ b/drivers/iommu/intel-iommu.c
> > @@ -5744,15 +5744,6 @@ static void intel_iommu_get_resv_regions(struct device *device,
> >   	list_add_tail(&reg->list, head);
> >   }
> > -static void intel_iommu_put_resv_regions(struct device *dev,
> > -					 struct list_head *head)
> > -{
> > -	struct iommu_resv_region *entry, *next;
> > -
> > -	list_for_each_entry_safe(entry, next, head, list)
> > -		kfree(entry);
> > -}
> > -
> >   int intel_iommu_enable_pasid(struct intel_iommu *iommu, struct device *dev)
> >   {
> >   	struct device_domain_info *info;
> > @@ -5987,7 +5978,7 @@ const struct iommu_ops intel_iommu_ops = {
> >   	.add_device		= intel_iommu_add_device,
> >   	.remove_device		= intel_iommu_remove_device,
> >   	.get_resv_regions	= intel_iommu_get_resv_regions,
> > -	.put_resv_regions	= intel_iommu_put_resv_regions,
> > +	.put_resv_regions	= generic_iommu_put_resv_regions,
> >   	.apply_resv_region	= intel_iommu_apply_resv_region,
> >   	.device_group		= pci_device_group,
> >   	.dev_has_feat		= intel_iommu_dev_has_feat,
> >
Joerg Roedel Dec. 19, 2019, 3:35 p.m. UTC | #3
On Thu, Dec 19, 2019 at 01:47:47PM +0100, Thierry Reding wrote:
> On Thu, Dec 19, 2019 at 09:53:22AM +0800, Lu Baolu wrote:
> > Please tweak the title to
> > 
> > "iommu/vt-d: Use generic_iommu_put_resv_regions()"
> > 
> > then,
> > 
> > Acked-by: Lu Baolu <baolu.lu@linux.intel.com>
> > 
> > Best regards,
> > baolu
> 
> Joerg, do you want me to resend with this change or is it more efficient
> if you fix up the subject while applying?

No need to re-send, I'll fix it up in this patch and in the others too.


	Joerg
diff mbox series

Patch

diff --git a/drivers/iommu/intel-iommu.c b/drivers/iommu/intel-iommu.c
index 42966611a192..a6d5b7cf9183 100644
--- a/drivers/iommu/intel-iommu.c
+++ b/drivers/iommu/intel-iommu.c
@@ -5744,15 +5744,6 @@  static void intel_iommu_get_resv_regions(struct device *device,
 	list_add_tail(&reg->list, head);
 }
 
-static void intel_iommu_put_resv_regions(struct device *dev,
-					 struct list_head *head)
-{
-	struct iommu_resv_region *entry, *next;
-
-	list_for_each_entry_safe(entry, next, head, list)
-		kfree(entry);
-}
-
 int intel_iommu_enable_pasid(struct intel_iommu *iommu, struct device *dev)
 {
 	struct device_domain_info *info;
@@ -5987,7 +5978,7 @@  const struct iommu_ops intel_iommu_ops = {
 	.add_device		= intel_iommu_add_device,
 	.remove_device		= intel_iommu_remove_device,
 	.get_resv_regions	= intel_iommu_get_resv_regions,
-	.put_resv_regions	= intel_iommu_put_resv_regions,
+	.put_resv_regions	= generic_iommu_put_resv_regions,
 	.apply_resv_region	= intel_iommu_apply_resv_region,
 	.device_group		= pci_device_group,
 	.dev_has_feat		= intel_iommu_dev_has_feat,