Message ID | 20200616230923.GA24937@embeddedor (mailing list archive) |
---|---|
State | Mainlined |
Commit | 2f7a9bda42f74e1169fcd9ef55c8ade989ef8bba |
Headers | show |
Series | [next] irqchip: Use struct_size() helper in devm_kzalloc() | expand |
On Tue, 16 Jun 2020 18:09:23 -0500, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes. > > This code was detected with the help of Coccinelle and, audited and > fixed manually. Applied to irq/irqchip-5.9: [1/1] irqchip/imx-intmux: Use struct_size() helper in devm_kzalloc() commit: 2f7a9bda42f74e1169fcd9ef55c8ade989ef8bba Thanks, M.
diff --git a/drivers/irqchip/irq-imx-intmux.c b/drivers/irqchip/irq-imx-intmux.c index c27577c81126..54d8bb4fc5a1 100644 --- a/drivers/irqchip/irq-imx-intmux.c +++ b/drivers/irqchip/irq-imx-intmux.c @@ -210,8 +210,7 @@ static int imx_intmux_probe(struct platform_device *pdev) return -EINVAL; } - data = devm_kzalloc(&pdev->dev, sizeof(*data) + - channum * sizeof(data->irqchip_data[0]), GFP_KERNEL); + data = devm_kzalloc(&pdev->dev, struct_size(data, irqchip_data, channum), GFP_KERNEL); if (!data) return -ENOMEM;
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes. This code was detected with the help of Coccinelle and, audited and fixed manually. Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org> --- drivers/irqchip/irq-imx-intmux.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)