diff mbox series

[2/7] arm64: dts: ti: k3-am65*: Use generic clock for serdes clock name

Message ID 20200901223059.14801-3-nm@ti.com (mailing list archive)
State New, archived
Headers show
Series arm64: dts: ti: k3-*: Squash up node_name_chars_strict warnings | expand

Commit Message

Nishanth Menon Sept. 1, 2020, 10:30 p.m. UTC
Use clock@ naming for nodes following standard conventions of device
tree (section 2.2.2 Generic Names recommendation in [1]).

[1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3

Suggested-by: Suman Anna <s-anna@ti.com>
Signed-off-by: Nishanth Menon <nm@ti.com>
---
 arch/arm64/boot/dts/ti/k3-am65-main.dtsi | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Suman Anna Sept. 2, 2020, 5:45 p.m. UTC | #1
On 9/1/20 5:30 PM, Nishanth Menon wrote:
> Use clock@ naming for nodes following standard conventions of device
> tree (section 2.2.2 Generic Names recommendation in [1]).
> 
> [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3
> 
> Suggested-by: Suman Anna <s-anna@ti.com>
> Signed-off-by: Nishanth Menon <nm@ti.com>

Acked-by: Suman Anna <s-anna@ti.com>

> ---
>  arch/arm64/boot/dts/ti/k3-am65-main.dtsi | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/arm64/boot/dts/ti/k3-am65-main.dtsi b/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
> index 336d09d6fec7..03e28fc256de 100644
> --- a/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
> +++ b/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
> @@ -327,12 +327,12 @@
>  			reg = <0x00000210 0x4>;
>  		};
>  
> -		serdes0_clk: serdes_clk@4080 {
> +		serdes0_clk: clock@4080 {
>  			compatible = "syscon";
>  			reg = <0x00004080 0x4>;
>  		};
>  
> -		serdes1_clk: serdes_clk@4090 {
> +		serdes1_clk: clock@4090 {
>  			compatible = "syscon";
>  			reg = <0x00004090 0x4>;
>  		};
> 

Btw, there is also ehrpwm_tbclk alongside these nodes which is currently defined
as a syscon, but is actually a clock.

regards
Suman
Nishanth Menon Sept. 2, 2020, 6:21 p.m. UTC | #2
On 12:45-20200902, Suman Anna wrote:
> On 9/1/20 5:30 PM, Nishanth Menon wrote:
> > Use clock@ naming for nodes following standard conventions of device
> > tree (section 2.2.2 Generic Names recommendation in [1]).
> > 
> > [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3
> > 
> > Suggested-by: Suman Anna <s-anna@ti.com>
> > Signed-off-by: Nishanth Menon <nm@ti.com>
> 
> Acked-by: Suman Anna <s-anna@ti.com>
> 
> > ---
> >  arch/arm64/boot/dts/ti/k3-am65-main.dtsi | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/arch/arm64/boot/dts/ti/k3-am65-main.dtsi b/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
> > index 336d09d6fec7..03e28fc256de 100644
> > --- a/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
> > +++ b/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
> > @@ -327,12 +327,12 @@
> >  			reg = <0x00000210 0x4>;
> >  		};
> >  
> > -		serdes0_clk: serdes_clk@4080 {
> > +		serdes0_clk: clock@4080 {
> >  			compatible = "syscon";
> >  			reg = <0x00004080 0x4>;
> >  		};
> >  
> > -		serdes1_clk: serdes_clk@4090 {
> > +		serdes1_clk: clock@4090 {
> >  			compatible = "syscon";
> >  			reg = <0x00004090 0x4>;
> >  		};
> > 
> 
> Btw, there is also ehrpwm_tbclk alongside these nodes which is currently defined
> as a syscon, but is actually a clock.

aah, good catch.. I can fix that in the follow on V2.
diff mbox series

Patch

diff --git a/arch/arm64/boot/dts/ti/k3-am65-main.dtsi b/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
index 336d09d6fec7..03e28fc256de 100644
--- a/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
+++ b/arch/arm64/boot/dts/ti/k3-am65-main.dtsi
@@ -327,12 +327,12 @@ 
 			reg = <0x00000210 0x4>;
 		};
 
-		serdes0_clk: serdes_clk@4080 {
+		serdes0_clk: clock@4080 {
 			compatible = "syscon";
 			reg = <0x00004080 0x4>;
 		};
 
-		serdes1_clk: serdes_clk@4090 {
+		serdes1_clk: clock@4090 {
 			compatible = "syscon";
 			reg = <0x00004090 0x4>;
 		};