diff mbox series

[6/7] arm64: dts: ti: k3-*: Use generic adc for node names

Message ID 20200901223059.14801-7-nm@ti.com (mailing list archive)
State New, archived
Headers show
Series arm64: dts: ti: k3-*: Squash up node_name_chars_strict warnings | expand

Commit Message

Nishanth Menon Sept. 1, 2020, 10:30 p.m. UTC
Use adc@ naming for nodes following standard conventions of device
tree (section 2.2.2 Generic Names recommendation in [1]).

[1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3

Suggested-by: Suman Anna <s-anna@ti.com>
Signed-off-by: Nishanth Menon <nm@ti.com>
---
 arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi         | 4 ++--
 arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Suman Anna Sept. 2, 2020, 4:51 p.m. UTC | #1
On 9/1/20 5:30 PM, Nishanth Menon wrote:
> Use adc@ naming for nodes following standard conventions of device
> tree (section 2.2.2 Generic Names recommendation in [1]).
> 
> [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3
> 
> Suggested-by: Suman Anna <s-anna@ti.com>
> Signed-off-by: Nishanth Menon <nm@ti.com>
> ---
>  arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi         | 4 ++--
>  arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> index 51ca4b4d4c21..6dfec68ac865 100644
> --- a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> +++ b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> @@ -80,7 +80,7 @@
>  		#size-cells = <0>;
>  	};
>  
> -	tscadc0: tscadc@40200000 {
> +	tscadc0: adc@40200000 {

OK with these changes, since these seem to be only have the adc child nodes.
This node is essentially a parent node for touchscreen and adc child nodes. The
driver is currently looking for "tsc" on touchscreen child nodes, but none of
the K3 SoCs have them atm.

regards
Suman

>  		compatible = "ti,am654-tscadc", "ti,am3359-tscadc";
>  		reg = <0x0 0x40200000 0x0 0x1000>;
>  		interrupts = <GIC_SPI 580 IRQ_TYPE_LEVEL_HIGH>;
> @@ -98,7 +98,7 @@
>  		};
>  	};
>  
> -	tscadc1: tscadc@40210000 {
> +	tscadc1: adc@40210000 {
>  		compatible = "ti,am654-tscadc", "ti,am3359-tscadc";
>  		reg = <0x0 0x40210000 0x0 0x1000>;
>  		interrupts = <GIC_SPI 581 IRQ_TYPE_LEVEL_HIGH>;
> diff --git a/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi b/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi
> index 9ad0266598ad..81801f519a61 100644
> --- a/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi
> +++ b/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi
> @@ -211,7 +211,7 @@
>  		};
>  	};
>  
> -	tscadc0: tscadc@40200000 {
> +	tscadc0: adc@40200000 {
>  		compatible = "ti,am3359-tscadc";
>  		reg = <0x0 0x40200000 0x0 0x1000>;
>  		interrupts = <GIC_SPI 860 IRQ_TYPE_LEVEL_HIGH>;
> @@ -230,7 +230,7 @@
>  		};
>  	};
>  
> -	tscadc1: tscadc@40210000 {
> +	tscadc1: adc@40210000 {
>  		compatible = "ti,am3359-tscadc";
>  		reg = <0x0 0x40210000 0x0 0x1000>;
>  		interrupts = <GIC_SPI 861 IRQ_TYPE_LEVEL_HIGH>;
>
Nishanth Menon Sept. 2, 2020, 6:18 p.m. UTC | #2
On 11:51-20200902, Suman Anna wrote:
> On 9/1/20 5:30 PM, Nishanth Menon wrote:
> > Use adc@ naming for nodes following standard conventions of device
> > tree (section 2.2.2 Generic Names recommendation in [1]).
> > 
> > [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3
> > 
> > Suggested-by: Suman Anna <s-anna@ti.com>
> > Signed-off-by: Nishanth Menon <nm@ti.com>
> > ---
> >  arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi         | 4 ++--
> >  arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi | 4 ++--
> >  2 files changed, 4 insertions(+), 4 deletions(-)
> > 
> > diff --git a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> > index 51ca4b4d4c21..6dfec68ac865 100644
> > --- a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> > +++ b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> > @@ -80,7 +80,7 @@
> >  		#size-cells = <0>;
> >  	};
> >  
> > -	tscadc0: tscadc@40200000 {
> > +	tscadc0: adc@40200000 {
> 
> OK with these changes, since these seem to be only have the adc child nodes.
> This node is essentially a parent node for touchscreen and adc child nodes. The
> driver is currently looking for "tsc" on touchscreen child nodes, but none of
> the K3 SoCs have them atm.
> 


Vignesh: are you ok with this, care to comment?
Vignesh Raghavendra Sept. 3, 2020, 5:25 a.m. UTC | #3
Hi Nishanth,

On 9/2/20 11:48 PM, Nishanth Menon wrote:
> On 11:51-20200902, Suman Anna wrote:
>> On 9/1/20 5:30 PM, Nishanth Menon wrote:
>>> Use adc@ naming for nodes following standard conventions of device
>>> tree (section 2.2.2 Generic Names recommendation in [1]).
>>>
>>> [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3
>>>
>>> Suggested-by: Suman Anna <s-anna@ti.com>
>>> Signed-off-by: Nishanth Menon <nm@ti.com>
>>> ---
>>>  arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi         | 4 ++--
>>>  arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi | 4 ++--
>>>  2 files changed, 4 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
>>> index 51ca4b4d4c21..6dfec68ac865 100644
>>> --- a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
>>> +++ b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
>>> @@ -80,7 +80,7 @@
>>>  		#size-cells = <0>;
>>>  	};
>>>  
>>> -	tscadc0: tscadc@40200000 {
>>> +	tscadc0: adc@40200000 {
>>
>> OK with these changes, since these seem to be only have the adc child nodes.
>> This node is essentially a parent node for touchscreen and adc child nodes. The
>> driver is currently looking for "tsc" on touchscreen child nodes, but none of
>> the K3 SoCs have them atm.
>>
> 
> 
> Vignesh: are you ok with this, care to comment?
> 

On K3 SoCs, ADC IP is reuse from AM335x but just lacks resistive
touchscreen interfaces. So, existing AM335x ADC driver is being reused
for K3 devices as well. Unfortunately, ADC driver cannot be used as
standalone and is dependent on MFD parent to be present...
Above node represents the MFD parent and ADC itself is the child node
(see arch/arm64/boot/dts/ti/k3-am654-base-board.dts). So, I recommend
that we keep this node's name as tscadc in order to avoid having same
name for parent and child node which will be quite confusing.

Regards
Vignesh
Nishanth Menon Sept. 3, 2020, 11:23 a.m. UTC | #4
On 10:55-20200903, Vignesh Raghavendra wrote:
> Hi Nishanth,
> 
> On 9/2/20 11:48 PM, Nishanth Menon wrote:
> > On 11:51-20200902, Suman Anna wrote:
> >> On 9/1/20 5:30 PM, Nishanth Menon wrote:
> >>> Use adc@ naming for nodes following standard conventions of device
> >>> tree (section 2.2.2 Generic Names recommendation in [1]).
> >>>
> >>> [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3
> >>>
> >>> Suggested-by: Suman Anna <s-anna@ti.com>
> >>> Signed-off-by: Nishanth Menon <nm@ti.com>
> >>> ---
> >>>  arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi         | 4 ++--
> >>>  arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi | 4 ++--
> >>>  2 files changed, 4 insertions(+), 4 deletions(-)
> >>>
> >>> diff --git a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> >>> index 51ca4b4d4c21..6dfec68ac865 100644
> >>> --- a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> >>> +++ b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
> >>> @@ -80,7 +80,7 @@
> >>>  		#size-cells = <0>;
> >>>  	};
> >>>  
> >>> -	tscadc0: tscadc@40200000 {
> >>> +	tscadc0: adc@40200000 {
> >>
> >> OK with these changes, since these seem to be only have the adc child nodes.
> >> This node is essentially a parent node for touchscreen and adc child nodes. The
> >> driver is currently looking for "tsc" on touchscreen child nodes, but none of
> >> the K3 SoCs have them atm.
> >>
> > 
> > 
> > Vignesh: are you ok with this, care to comment?
> > 
> 
> On K3 SoCs, ADC IP is reuse from AM335x but just lacks resistive
> touchscreen interfaces. So, existing AM335x ADC driver is being reused
> for K3 devices as well. Unfortunately, ADC driver cannot be used as
> standalone and is dependent on MFD parent to be present...
> Above node represents the MFD parent and ADC itself is the child node
> (see arch/arm64/boot/dts/ti/k3-am654-base-board.dts). So, I recommend
> that we keep this node's name as tscadc in order to avoid having same
> name for parent and child node which will be quite confusing.


Thanks for your feedback. I will drop this patch.
diff mbox series

Patch

diff --git a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
index 51ca4b4d4c21..6dfec68ac865 100644
--- a/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
+++ b/arch/arm64/boot/dts/ti/k3-am65-mcu.dtsi
@@ -80,7 +80,7 @@ 
 		#size-cells = <0>;
 	};
 
-	tscadc0: tscadc@40200000 {
+	tscadc0: adc@40200000 {
 		compatible = "ti,am654-tscadc", "ti,am3359-tscadc";
 		reg = <0x0 0x40200000 0x0 0x1000>;
 		interrupts = <GIC_SPI 580 IRQ_TYPE_LEVEL_HIGH>;
@@ -98,7 +98,7 @@ 
 		};
 	};
 
-	tscadc1: tscadc@40210000 {
+	tscadc1: adc@40210000 {
 		compatible = "ti,am654-tscadc", "ti,am3359-tscadc";
 		reg = <0x0 0x40210000 0x0 0x1000>;
 		interrupts = <GIC_SPI 581 IRQ_TYPE_LEVEL_HIGH>;
diff --git a/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi b/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi
index 9ad0266598ad..81801f519a61 100644
--- a/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi
+++ b/arch/arm64/boot/dts/ti/k3-j721e-mcu-wakeup.dtsi
@@ -211,7 +211,7 @@ 
 		};
 	};
 
-	tscadc0: tscadc@40200000 {
+	tscadc0: adc@40200000 {
 		compatible = "ti,am3359-tscadc";
 		reg = <0x0 0x40200000 0x0 0x1000>;
 		interrupts = <GIC_SPI 860 IRQ_TYPE_LEVEL_HIGH>;
@@ -230,7 +230,7 @@ 
 		};
 	};
 
-	tscadc1: tscadc@40210000 {
+	tscadc1: adc@40210000 {
 		compatible = "ti,am3359-tscadc";
 		reg = <0x0 0x40210000 0x0 0x1000>;
 		interrupts = <GIC_SPI 861 IRQ_TYPE_LEVEL_HIGH>;