Message ID | 20210528014749.24068-1-yuehaibing@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [-next] perf: qcom: use DEVICE_ATTR_RO macro | expand |
On Fri, 28 May 2021 09:47:49 +0800, YueHaibing wrote: > Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(), > which makes the code a bit shorter and easier to read. Applied to will (for-next/perf), thanks! [1/1] perf: qcom: use DEVICE_ATTR_RO macro https://git.kernel.org/will/c/ccbe14ce8828 Cheers,
diff --git a/drivers/perf/qcom_l3_pmu.c b/drivers/perf/qcom_l3_pmu.c index bba078077c93..081273543c6b 100644 --- a/drivers/perf/qcom_l3_pmu.c +++ b/drivers/perf/qcom_l3_pmu.c @@ -670,15 +670,15 @@ static const struct attribute_group qcom_l3_cache_pmu_events_group = { /* cpumask */ -static ssize_t qcom_l3_cache_pmu_cpumask_show(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t cpumask_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct l3cache_pmu *l3pmu = to_l3cache_pmu(dev_get_drvdata(dev)); return cpumap_print_to_pagebuf(true, buf, &l3pmu->cpumask); } -static DEVICE_ATTR(cpumask, 0444, qcom_l3_cache_pmu_cpumask_show, NULL); +static DEVICE_ATTR_RO(cpumask); static struct attribute *qcom_l3_cache_pmu_cpumask_attrs[] = { &dev_attr_cpumask.attr,
Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read. Signed-off-by: YueHaibing <yuehaibing@huawei.com> --- drivers/perf/qcom_l3_pmu.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)