Message ID | 20210528014940.4184-1-yuehaibing@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | perf: xgene_pmu: use DEVICE_ATTR_RO macro | expand |
On Fri, 28 May 2021 09:49:40 +0800, YueHaibing wrote: > Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(), > which makes the code a bit shorter and easier to read. Applied to will (for-next/perf), thanks! [1/1] perf: xgene_pmu: use DEVICE_ATTR_RO macro https://git.kernel.org/will/c/21ad02e6b4c8 Cheers,
diff --git a/drivers/perf/xgene_pmu.c b/drivers/perf/xgene_pmu.c index ffe3bdeec845..62d942534a6b 100644 --- a/drivers/perf/xgene_pmu.c +++ b/drivers/perf/xgene_pmu.c @@ -604,15 +604,15 @@ static const struct attribute_group mc_pmu_v3_events_attr_group = { /* * sysfs cpumask attributes */ -static ssize_t xgene_pmu_cpumask_show(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t cpumask_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct xgene_pmu_dev *pmu_dev = to_pmu_dev(dev_get_drvdata(dev)); return cpumap_print_to_pagebuf(true, buf, &pmu_dev->parent->cpu); } -static DEVICE_ATTR(cpumask, S_IRUGO, xgene_pmu_cpumask_show, NULL); +static DEVICE_ATTR_RO(cpumask); static struct attribute *xgene_pmu_cpumask_attrs[] = { &dev_attr_cpumask.attr,
Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read. Signed-off-by: YueHaibing <yuehaibing@huawei.com> --- drivers/perf/xgene_pmu.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)