Message ID | 20210602114339.11223-2-thunder.leizhen@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mfd: use DEVICE_ATTR_* macro to simplify code | expand |
On Wed, Jun 02, 2021 at 07:43:31PM +0800, Zhen Lei wrote: > Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes > the code a bit shorter and easier to read. > > Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> > --- Acked-by: Charles Keepax <ckeepax@opensource.cirrus.com> Thanks, Charles
On Wed, 02 Jun 2021, Zhen Lei wrote: > Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes > the code a bit shorter and easier to read. > > Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> > --- > drivers/mfd/wm831x-otp.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) Applied, thanks.
diff --git a/drivers/mfd/wm831x-otp.c b/drivers/mfd/wm831x-otp.c index afe59d52dd74d55..25f5d9fe33a18e2 100644 --- a/drivers/mfd/wm831x-otp.c +++ b/drivers/mfd/wm831x-otp.c @@ -38,8 +38,8 @@ static int wm831x_unique_id_read(struct wm831x *wm831x, char *id) return 0; } -static ssize_t wm831x_unique_id_show(struct device *dev, - struct device_attribute *attr, char *buf) +static ssize_t unique_id_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct wm831x *wm831x = dev_get_drvdata(dev); int rval; @@ -52,7 +52,7 @@ static ssize_t wm831x_unique_id_show(struct device *dev, return sprintf(buf, "%*phN\n", WM831X_UNIQUE_ID_LEN, id); } -static DEVICE_ATTR(unique_id, 0444, wm831x_unique_id_show, NULL); +static DEVICE_ATTR_RO(unique_id); int wm831x_otp_init(struct wm831x *wm831x) {
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> --- drivers/mfd/wm831x-otp.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)