Message ID | 20210602114339.11223-8-thunder.leizhen@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mfd: use DEVICE_ATTR_* macro to simplify code | expand |
On Wed, 02 Jun 2021, Zhen Lei wrote: > Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes > the code a bit shorter and easier to read. > > Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> > --- > drivers/mfd/janz-cmodio.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) Applied, thanks.
diff --git a/drivers/mfd/janz-cmodio.c b/drivers/mfd/janz-cmodio.c index 3df4e9a2998f490..70eba4ce496faa3 100644 --- a/drivers/mfd/janz-cmodio.c +++ b/drivers/mfd/janz-cmodio.c @@ -149,15 +149,15 @@ static int cmodio_probe_submodules(struct cmodio_device *priv) * SYSFS Attributes */ -static ssize_t mbus_show(struct device *dev, struct device_attribute *attr, - char *buf) +static ssize_t modulbus_number_show(struct device *dev, + struct device_attribute *attr, char *buf) { struct cmodio_device *priv = dev_get_drvdata(dev); return snprintf(buf, PAGE_SIZE, "%x\n", priv->hex); } -static DEVICE_ATTR(modulbus_number, S_IRUGO, mbus_show, NULL); +static DEVICE_ATTR_RO(modulbus_number); static struct attribute *cmodio_sysfs_attrs[] = { &dev_attr_modulbus_number.attr,
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> --- drivers/mfd/janz-cmodio.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)