Message ID | 20220227135214.145599-7-krzysztof.kozlowski@canonical.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Fix broken usage of driver_override (and kfree of static memory) | expand |
On 2/27/22 14:52, Krzysztof Kozlowski wrote: > Use a helper for seting driver_override to reduce amount of duplicated > code. Make the driver_override field const char, because it is not > modified by the core and it matches other subsystems. s/seting/setting/ Also could you please change the title to start with "s390/cio:" instead of "s390 : cio" Otherwise, Acked-by: Vineeth Vijayan <vneethv@linux.ibm.com> > Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@canonical.com> > --- > drivers/s390/cio/cio.h | 7 ++++++- > drivers/s390/cio/css.c | 28 ++++------------------------ > 2 files changed, 10 insertions(+), 25 deletions(-) > > diff --git a/drivers/s390/cio/cio.h b/drivers/s390/cio/cio.h > index 1cb9daf9c645..e110c10613e8 100644 > --- a/drivers/s390/cio/cio.h > +++ b/drivers/s390/cio/cio.h > @@ -103,7 +103,12 @@ struct subchannel { > struct work_struct todo_work; > struct schib_config config; > u64 dma_mask; > - char *driver_override; /* Driver name to force a match */ > + /* > + * Driver name to force a match. > + * Do not set directly, because core frees it. > + * Use driver_set_override() to set or clear it. > + */ As Bjorn Helgaas mentioned, please wrap this comment. > + const char *driver_override; > } __attribute__ ((aligned(8))); > > DECLARE_PER_CPU_ALIGNED(struct irb, cio_irb); > diff --git a/drivers/s390/cio/css.c b/drivers/s390/cio/css.c > index fa8293335077..913b6ddd040b 100644 > --- a/drivers/s390/cio/css.c > +++ b/drivers/s390/cio/css.c > @@ -338,31 +338,11 @@ static ssize_t driver_override_store(struct device *dev, > const char *buf, size_t count) > { > struct subchannel *sch = to_subchannel(dev); > - char *driver_override, *old, *cp; > - > - /* We need to keep extra room for a newline */ > - if (count >= (PAGE_SIZE - 1)) > - return -EINVAL; > - > - driver_override = kstrndup(buf, count, GFP_KERNEL); > - if (!driver_override) > - return -ENOMEM; > - > - cp = strchr(driver_override, '\n'); > - if (cp) > - *cp = '\0'; > - > - device_lock(dev); > - old = sch->driver_override; > - if (strlen(driver_override)) { > - sch->driver_override = driver_override; > - } else { > - kfree(driver_override); > - sch->driver_override = NULL; > - } > - device_unlock(dev); > + int ret; > > - kfree(old); > + ret = driver_set_override(dev, &sch->driver_override, buf, count); > + if (ret) > + return ret; > > return count; > }
On 01/03/2022 17:01, Vineeth Vijayan wrote: > > On 2/27/22 14:52, Krzysztof Kozlowski wrote: >> Use a helper for seting driver_override to reduce amount of duplicated >> code. Make the driver_override field const char, because it is not >> modified by the core and it matches other subsystems. > s/seting/setting/ > > Also could you please change the title to start with "s390/cio:" > instead of "s390 : cio" > Sure, thanks for review! Best regards, Krzysztof
diff --git a/drivers/s390/cio/cio.h b/drivers/s390/cio/cio.h index 1cb9daf9c645..e110c10613e8 100644 --- a/drivers/s390/cio/cio.h +++ b/drivers/s390/cio/cio.h @@ -103,7 +103,12 @@ struct subchannel { struct work_struct todo_work; struct schib_config config; u64 dma_mask; - char *driver_override; /* Driver name to force a match */ + /* + * Driver name to force a match. + * Do not set directly, because core frees it. + * Use driver_set_override() to set or clear it. + */ + const char *driver_override; } __attribute__ ((aligned(8))); DECLARE_PER_CPU_ALIGNED(struct irb, cio_irb); diff --git a/drivers/s390/cio/css.c b/drivers/s390/cio/css.c index fa8293335077..913b6ddd040b 100644 --- a/drivers/s390/cio/css.c +++ b/drivers/s390/cio/css.c @@ -338,31 +338,11 @@ static ssize_t driver_override_store(struct device *dev, const char *buf, size_t count) { struct subchannel *sch = to_subchannel(dev); - char *driver_override, *old, *cp; - - /* We need to keep extra room for a newline */ - if (count >= (PAGE_SIZE - 1)) - return -EINVAL; - - driver_override = kstrndup(buf, count, GFP_KERNEL); - if (!driver_override) - return -ENOMEM; - - cp = strchr(driver_override, '\n'); - if (cp) - *cp = '\0'; - - device_lock(dev); - old = sch->driver_override; - if (strlen(driver_override)) { - sch->driver_override = driver_override; - } else { - kfree(driver_override); - sch->driver_override = NULL; - } - device_unlock(dev); + int ret; - kfree(old); + ret = driver_set_override(dev, &sch->driver_override, buf, count); + if (ret) + return ret; return count; }
Use a helper for seting driver_override to reduce amount of duplicated code. Make the driver_override field const char, because it is not modified by the core and it matches other subsystems. Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@canonical.com> --- drivers/s390/cio/cio.h | 7 ++++++- drivers/s390/cio/css.c | 28 ++++------------------------ 2 files changed, 10 insertions(+), 25 deletions(-)