diff mbox series

arm64: mm: fix VA-range sanity check

Message ID 20230615102628.1052103-1-mark.rutland@arm.com (mailing list archive)
State New, archived
Headers show
Series arm64: mm: fix VA-range sanity check | expand

Commit Message

Mark Rutland June 15, 2023, 10:26 a.m. UTC
Both create_mapping_noalloc() and update_mapping_prot() sanity-check the
their 'virt' parameter, but the check itself doesn't make much sense.
The condition used today appears to be a historical accident.

The sanity-check condition:

	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
		[ ... warning here ... ]
		return;
	}

... can only be true for the KASAN shadow region or the module region,
and there's no reason to exclude these specifically for creating and
updateing mappings.

When arm64 support was first upstreamed in commit:

  c1cc1552616d0f35 ("arm64: MMU initialisation")

... the condition was:

	if (virt < VMALLOC_START) {
		[ ... warning here ... ]
		return;
	}

At the time, VMALLOC_START was the lowest kernel address, and this was
checking whether 'virt' would be translated via TTBR1.

Subsequently in commit:

  14c127c957c1c607 ("arm64: mm: Flip kernel VA space")

... the condition was changed to:

	if ((virt >= VA_START) && (virt < VMALLOC_START)) {
		[ ... warning here ... ]
		return;
	}

This appear to have been a thinko. The commit moved the linear map to
the bottom of the kernel address space, with VMALLOC_START being at the
halfway point. The old condition would warn for changes to the linear
map below this, and at the time VA_START was the end of the linear map.

Subsequently we cleaned up the naming of VA_START in commit:

  77ad4ce69321abbe ("arm64: memory: rename VA_START to PAGE_END")

... keeping the erroneous condition as:

	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
		[ ... warning here ... ]
		return;
	}

Correct the condition to check against the start of the TTBR1 address
space, which is currently PAGE_OFFSET. This simplifies the logic, and
more clearly matches the "outside kernel range" message in the warning.

Signed-off-by: Mark Rutland <mark.rutland@arm.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>
Cc: Russell King <linux@armlinux.org.uk>
Cc: Steve Capper <steve.capper@arm.com>
Cc: Will Deacon <will@kernel.org>
---
 arch/arm64/mm/mmu.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Russell King (Oracle) June 15, 2023, 11:23 a.m. UTC | #1
On Thu, Jun 15, 2023 at 11:26:28AM +0100, Mark Rutland wrote:
> Both create_mapping_noalloc() and update_mapping_prot() sanity-check the
> their 'virt' parameter, but the check itself doesn't make much sense.
> The condition used today appears to be a historical accident.
> 
> The sanity-check condition:
> 
> 	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
> 		[ ... warning here ... ]
> 		return;
> 	}
> 
> ... can only be true for the KASAN shadow region or the module region,
> and there's no reason to exclude these specifically for creating and
> updateing mappings.
> 
> When arm64 support was first upstreamed in commit:
> 
>   c1cc1552616d0f35 ("arm64: MMU initialisation")
> 
> ... the condition was:
> 
> 	if (virt < VMALLOC_START) {
> 		[ ... warning here ... ]
> 		return;
> 	}
> 
> At the time, VMALLOC_START was the lowest kernel address, and this was
> checking whether 'virt' would be translated via TTBR1.
> 
> Subsequently in commit:
> 
>   14c127c957c1c607 ("arm64: mm: Flip kernel VA space")
> 
> ... the condition was changed to:
> 
> 	if ((virt >= VA_START) && (virt < VMALLOC_START)) {
> 		[ ... warning here ... ]
> 		return;
> 	}
> 
> This appear to have been a thinko. The commit moved the linear map to
> the bottom of the kernel address space, with VMALLOC_START being at the
> halfway point. The old condition would warn for changes to the linear
> map below this, and at the time VA_START was the end of the linear map.
> 
> Subsequently we cleaned up the naming of VA_START in commit:
> 
>   77ad4ce69321abbe ("arm64: memory: rename VA_START to PAGE_END")
> 
> ... keeping the erroneous condition as:
> 
> 	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
> 		[ ... warning here ... ]
> 		return;
> 	}
> 
> Correct the condition to check against the start of the TTBR1 address
> space, which is currently PAGE_OFFSET. This simplifies the logic, and
> more clearly matches the "outside kernel range" message in the warning.
> 
> Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> Cc: Catalin Marinas <catalin.marinas@arm.com>
> Cc: Russell King <linux@armlinux.org.uk>
> Cc: Steve Capper <steve.capper@arm.com>
> Cc: Will Deacon <will@kernel.org>

This simplifies the second of the kernel text replication patches!

Reviewed-by: Russell King (Oracle) <rmk+kernel@armlinux.org.uk>

Thanks!
Catalin Marinas June 15, 2023, 5:11 p.m. UTC | #2
On Thu, 15 Jun 2023 11:26:28 +0100, Mark Rutland wrote:
> Both create_mapping_noalloc() and update_mapping_prot() sanity-check the
> their 'virt' parameter, but the check itself doesn't make much sense.
> The condition used today appears to be a historical accident.
> 
> The sanity-check condition:
> 
> 	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
> 		[ ... warning here ... ]
> 		return;
> 	}
> 
> [...]

Applied to arm64 (for-next/misc), thanks!

[1/1] arm64: mm: fix VA-range sanity check
      https://git.kernel.org/arm64/c/ab9b4008092c
diff mbox series

Patch

diff --git a/arch/arm64/mm/mmu.c b/arch/arm64/mm/mmu.c
index 4829abe017e92..95d360805f8ae 100644
--- a/arch/arm64/mm/mmu.c
+++ b/arch/arm64/mm/mmu.c
@@ -451,7 +451,7 @@  static phys_addr_t pgd_pgtable_alloc(int shift)
 void __init create_mapping_noalloc(phys_addr_t phys, unsigned long virt,
 				   phys_addr_t size, pgprot_t prot)
 {
-	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
+	if (virt < PAGE_OFFSET) {
 		pr_warn("BUG: not creating mapping for %pa at 0x%016lx - outside kernel range\n",
 			&phys, virt);
 		return;
@@ -478,7 +478,7 @@  void __init create_pgd_mapping(struct mm_struct *mm, phys_addr_t phys,
 static void update_mapping_prot(phys_addr_t phys, unsigned long virt,
 				phys_addr_t size, pgprot_t prot)
 {
-	if ((virt >= PAGE_END) && (virt < VMALLOC_START)) {
+	if (virt < PAGE_OFFSET) {
 		pr_warn("BUG: not updating mapping for %pa at 0x%016lx - outside kernel range\n",
 			&phys, virt);
 		return;