diff mbox series

[v2] mips: dts: ralink: mt7621: add cell count properties to usb

Message ID 20240307223756.31643-1-justin.swartz@risingedge.co.za (mailing list archive)
State New, archived
Headers show
Series [v2] mips: dts: ralink: mt7621: add cell count properties to usb | expand

Commit Message

Justin Swartz March 7, 2024, 10:37 p.m. UTC
Add default #address-cells and #size-cells properties to the
usb node, which should be suitable for hubs and devices without
explicitly declared interface nodes, as:

  "#address-cells":
    description: should be 1 for hub nodes with device nodes,
      should be 2 for device nodes with interface nodes.
    enum: [1, 2]

  "#size-cells":
    const: 0

-- Documentation/devicetree/bindings/usb/usb-device.yaml

This version of the patch places the properties according to
the order recommended by:

   Documentation/devicetree/bindings/dts-coding-style.rst

Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
---
 arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Sergio Paracuellos March 8, 2024, 9:32 a.m. UTC | #1
On Thu, Mar 7, 2024 at 11:39 PM Justin Swartz
<justin.swartz@risingedge.co.za> wrote:
>
> Add default #address-cells and #size-cells properties to the
> usb node, which should be suitable for hubs and devices without
> explicitly declared interface nodes, as:
>
>   "#address-cells":
>     description: should be 1 for hub nodes with device nodes,
>       should be 2 for device nodes with interface nodes.
>     enum: [1, 2]
>
>   "#size-cells":
>     const: 0
>
> -- Documentation/devicetree/bindings/usb/usb-device.yaml
>
> This version of the patch places the properties according to
> the order recommended by:
>
>    Documentation/devicetree/bindings/dts-coding-style.rst

Drop these three lines, this explanation would be after --- line as
information about the changes from v1.

>
> Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
> ---
>  arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

With the three lines removal addressed:
Acked-by: Sergio Paracuellos <sergio.paracuellos@gmail.com>

Best regards,
    Sergio Paracuellos
Justin Swartz March 8, 2024, 1:21 p.m. UTC | #2
On 2024-03-08 14:01, Arınç ÜNAL wrote:
> On 8.03.2024 01:37, Justin Swartz wrote:
>> Add default #address-cells and #size-cells properties to the
>> usb node, which should be suitable for hubs and devices without
>> explicitly declared interface nodes, as:
>> 
>>    "#address-cells":
>>      description: should be 1 for hub nodes with device nodes,
>>        should be 2 for device nodes with interface nodes.
>>      enum: [1, 2]
>> 
>>    "#size-cells":
>>      const: 0
>> 
>> -- Documentation/devicetree/bindings/usb/usb-device.yaml
>> 
>> This version of the patch places the properties according to
>> the order recommended by:
>> 
>>     Documentation/devicetree/bindings/dts-coding-style.rst
>> 
>> Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
>> ---
>>   arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>> 
>> diff --git a/arch/mips/boot/dts/ralink/mt7621.dtsi 
>> b/arch/mips/boot/dts/ralink/mt7621.dtsi
>> index 5a89f0b8c..7532e17dd 100644
>> --- a/arch/mips/boot/dts/ralink/mt7621.dtsi
>> +++ b/arch/mips/boot/dts/ralink/mt7621.dtsi
>> @@ -289,10 +289,10 @@ usb: usb@1e1c0000 {
>>   		reg = <0x1e1c0000 0x1000
>>   		       0x1e1d0700 0x0100>;
>>   		reg-names = "mac", "ippc";
>> -
>> +		#address-cells = <1>;
>> +		#size-cells = <0>;
>>   		clocks = <&sysc MT7621_CLK_XTAL>;
>>   		clock-names = "sys_ck";
>> -
> 
> Please keep the empty lines. It's easier to read. I don't see anything 
> on
> the Devicetree Sources (DTS) Coding Style that would restrict this.

The reason I removed them was due to the SoC DTSI example shown in [1]
lacking empty lines between properties, but then using them instead as
visual separation between properties and child nodes, or at least that's
how I understood it when I looked at it.

Personally, I prefer the look of the SoC DTSI example - but I don't mind
recreating the patch set with the empty lines between the properties 
left
entact.

As there is a mix of property spacing and ordering styles in mt7621.dtsi
already - what is the consensus on what a node in this file should look
like?

I also don't mind following that pattern and cleaning up the whole dtsi
according to that if it'll save us all time and energy in future.

Regards
Justin

[1] https://docs.kernel.org/devicetree/bindings/dts-coding-style.html
Justin Swartz March 8, 2024, 1:57 p.m. UTC | #3
On 2024-03-08 15:48, Arınç ÜNAL wrote:
> On 8.03.2024 16:21, Justin Swartz wrote:
>> 
>> On 2024-03-08 14:01, Arınç ÜNAL wrote:
>>> On 8.03.2024 01:37, Justin Swartz wrote:
>>>> Add default #address-cells and #size-cells properties to the
>>>> usb node, which should be suitable for hubs and devices without
>>>> explicitly declared interface nodes, as:
>>>> 
>>>>    "#address-cells":
>>>>      description: should be 1 for hub nodes with device nodes,
>>>>        should be 2 for device nodes with interface nodes.
>>>>      enum: [1, 2]
>>>> 
>>>>    "#size-cells":
>>>>      const: 0
>>>> 
>>>> -- Documentation/devicetree/bindings/usb/usb-device.yaml
>>>> 
>>>> This version of the patch places the properties according to
>>>> the order recommended by:
>>>> 
>>>>     Documentation/devicetree/bindings/dts-coding-style.rst
>>>> 
>>>> Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
>>>> ---
>>>>   arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++--
>>>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>>> 
>>>> diff --git a/arch/mips/boot/dts/ralink/mt7621.dtsi 
>>>> b/arch/mips/boot/dts/ralink/mt7621.dtsi
>>>> index 5a89f0b8c..7532e17dd 100644
>>>> --- a/arch/mips/boot/dts/ralink/mt7621.dtsi
>>>> +++ b/arch/mips/boot/dts/ralink/mt7621.dtsi
>>>> @@ -289,10 +289,10 @@ usb: usb@1e1c0000 {
>>>>           reg = <0x1e1c0000 0x1000
>>>>                  0x1e1d0700 0x0100>;
>>>>           reg-names = "mac", "ippc";
>>>> -
>>>> +        #address-cells = <1>;
>>>> +        #size-cells = <0>;
>>>>           clocks = <&sysc MT7621_CLK_XTAL>;
>>>>           clock-names = "sys_ck";
>>>> -
>>> 
>>> Please keep the empty lines. It's easier to read. I don't see 
>>> anything on
>>> the Devicetree Sources (DTS) Coding Style that would restrict this.
>> 
>> The reason I removed them was due to the SoC DTSI example shown in [1]
>> lacking empty lines between properties, but then using them instead as
>> visual separation between properties and child nodes, or at least 
>> that's
>> how I understood it when I looked at it.
>> 
>> Personally, I prefer the look of the SoC DTSI example - but I don't 
>> mind
>> recreating the patch set with the empty lines between the properties 
>> left
>> entact.
>> 
>> As there is a mix of property spacing and ordering styles in 
>> mt7621.dtsi
>> already - what is the consensus on what a node in this file should 
>> look
>> like?
> 
> There's no precise spacing style I maintain here. I simply group 
> together
> properties that describe a single attribute, and separate those that
> describe different attributes.

I'll recreate v3 accordingly.


>> I also don't mind following that pattern and cleaning up the whole 
>> dtsi
>> according to that if it'll save us all time and energy in future.
> 
> If you'd like to improve the ordering style of the MT7621 device tree
> sources accordingly with
> Documentation/devicetree/bindings/dts-coding-style.rst, I'd be happy to
> review those patches.

Thanks, I'll make an attempt at this sometime soon.


Regards
Justin
diff mbox series

Patch

diff --git a/arch/mips/boot/dts/ralink/mt7621.dtsi b/arch/mips/boot/dts/ralink/mt7621.dtsi
index 5a89f0b8c..7532e17dd 100644
--- a/arch/mips/boot/dts/ralink/mt7621.dtsi
+++ b/arch/mips/boot/dts/ralink/mt7621.dtsi
@@ -289,10 +289,10 @@  usb: usb@1e1c0000 {
 		reg = <0x1e1c0000 0x1000
 		       0x1e1d0700 0x0100>;
 		reg-names = "mac", "ippc";
-
+		#address-cells = <1>;
+		#size-cells = <0>;
 		clocks = <&sysc MT7621_CLK_XTAL>;
 		clock-names = "sys_ck";
-
 		interrupt-parent = <&gic>;
 		interrupts = <GIC_SHARED 22 IRQ_TYPE_LEVEL_HIGH>;
 	};