Message ID | 20240323231309.415425-2-martin.blumenstingl@googlemail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | iio: adc: meson: a few improvements | expand |
Hello Martin Thanks for the patch Should the tag Fixes: 90c6241860bf ("iio: adc: meson: init voltage control bits") be added? On 3/24/24 02:13, Martin Blumenstingl wrote: > The field should be called "vref_voltage", without a typo in the word > voltage. No functional changes intended. > > Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> > --- > drivers/iio/adc/meson_saradc.c | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/drivers/iio/adc/meson_saradc.c b/drivers/iio/adc/meson_saradc.c > index 13b473d8c6c7..2615d74534df 100644 > --- a/drivers/iio/adc/meson_saradc.c > +++ b/drivers/iio/adc/meson_saradc.c > @@ -327,7 +327,7 @@ struct meson_sar_adc_param { > u8 vref_select; > u8 cmv_select; > u8 adc_eoc; > - enum meson_sar_adc_vref_sel vref_volatge; > + enum meson_sar_adc_vref_sel vref_voltage; > }; > > struct meson_sar_adc_data { > @@ -1001,7 +1001,7 @@ static int meson_sar_adc_init(struct iio_dev *indio_dev) > } > > regval = FIELD_PREP(MESON_SAR_ADC_REG11_VREF_VOLTAGE, > - priv->param->vref_volatge); > + priv->param->vref_voltage); > regmap_update_bits(priv->regmap, MESON_SAR_ADC_REG11, > MESON_SAR_ADC_REG11_VREF_VOLTAGE, regval); > > @@ -1225,7 +1225,7 @@ static const struct meson_sar_adc_param meson_sar_adc_gxbb_param = { > .regmap_config = &meson_sar_adc_regmap_config_gxbb, > .resolution = 10, > .has_reg11 = true, > - .vref_volatge = 1, > + .vref_voltage = 1, > .cmv_select = 1, > }; > > @@ -1237,7 +1237,7 @@ static const struct meson_sar_adc_param meson_sar_adc_gxl_param = { > .resolution = 12, > .disable_ring_counter = 1, > .has_reg11 = true, > - .vref_volatge = 1, > + .vref_voltage = 1, > .cmv_select = 1, > }; > > @@ -1249,7 +1249,7 @@ static const struct meson_sar_adc_param meson_sar_adc_axg_param = { > .resolution = 12, > .disable_ring_counter = 1, > .has_reg11 = true, > - .vref_volatge = 1, > + .vref_voltage = 1, > .has_vref_select = true, > .vref_select = VREF_VDDA, > .cmv_select = 1,
Hi George, On Tue, Mar 26, 2024 at 12:45 AM George Stark <gnstark@salutedevices.com> wrote: > > Hello Martin > > Thanks for the patch you're welcome > Should the tag > Fixes: 90c6241860bf ("iio: adc: meson: init voltage control bits") > be added? My understanding is that "Fixes" is for actual bugfixes. There's no harm done by a type that's only visible in the driver source (it's not exposed to DT, userspace or elsewhere). Best regards, Martin
diff --git a/drivers/iio/adc/meson_saradc.c b/drivers/iio/adc/meson_saradc.c index 13b473d8c6c7..2615d74534df 100644 --- a/drivers/iio/adc/meson_saradc.c +++ b/drivers/iio/adc/meson_saradc.c @@ -327,7 +327,7 @@ struct meson_sar_adc_param { u8 vref_select; u8 cmv_select; u8 adc_eoc; - enum meson_sar_adc_vref_sel vref_volatge; + enum meson_sar_adc_vref_sel vref_voltage; }; struct meson_sar_adc_data { @@ -1001,7 +1001,7 @@ static int meson_sar_adc_init(struct iio_dev *indio_dev) } regval = FIELD_PREP(MESON_SAR_ADC_REG11_VREF_VOLTAGE, - priv->param->vref_volatge); + priv->param->vref_voltage); regmap_update_bits(priv->regmap, MESON_SAR_ADC_REG11, MESON_SAR_ADC_REG11_VREF_VOLTAGE, regval); @@ -1225,7 +1225,7 @@ static const struct meson_sar_adc_param meson_sar_adc_gxbb_param = { .regmap_config = &meson_sar_adc_regmap_config_gxbb, .resolution = 10, .has_reg11 = true, - .vref_volatge = 1, + .vref_voltage = 1, .cmv_select = 1, }; @@ -1237,7 +1237,7 @@ static const struct meson_sar_adc_param meson_sar_adc_gxl_param = { .resolution = 12, .disable_ring_counter = 1, .has_reg11 = true, - .vref_volatge = 1, + .vref_voltage = 1, .cmv_select = 1, }; @@ -1249,7 +1249,7 @@ static const struct meson_sar_adc_param meson_sar_adc_axg_param = { .resolution = 12, .disable_ring_counter = 1, .has_reg11 = true, - .vref_volatge = 1, + .vref_voltage = 1, .has_vref_select = true, .vref_select = VREF_VDDA, .cmv_select = 1,
The field should be called "vref_voltage", without a typo in the word voltage. No functional changes intended. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> --- drivers/iio/adc/meson_saradc.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-)