diff mbox series

[2/3] dt-bindings: Add power-domain header for RK3576 SoCs

Message ID 20240802151647.294307-3-detlev.casanova@collabora.com (mailing list archive)
State New, archived
Headers show
Series Add power-controller support for rk3576 | expand

Commit Message

Detlev Casanova Aug. 2, 2024, 3:14 p.m. UTC
From: Finley Xiao <finley.xiao@rock-chips.com>

Define power domain IDs as described in the TRM.

Signed-off-by: Finley Xiao <finley.xiao@rock-chips.com>
[reword]
Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
---
 include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 include/dt-bindings/power/rk3576-power.h

Comments

Krzysztof Kozlowski Aug. 4, 2024, 9:56 a.m. UTC | #1
On 02/08/2024 17:14, Detlev Casanova wrote:
> From: Finley Xiao <finley.xiao@rock-chips.com>
> 
> Define power domain IDs as described in the TRM.

Please use subject prefixes matching the subsystem. You can get them for
example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
your patch is touching. For bindings, the preferred subjects are
explained here:
https://www.kernel.org/doc/html/latest/devicetree/bindings/submitting-patches.html#i-for-patch-submitters

> 
> Signed-off-by: Finley Xiao <finley.xiao@rock-chips.com>
> [reword]
> Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
> ---
>  include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>  create mode 100644 include/dt-bindings/power/rk3576-power.h

This is part of bindings.

> 
> diff --git a/include/dt-bindings/power/rk3576-power.h b/include/dt-bindings/power/rk3576-power.h

Missing vendor prefix. This should be named after compatible.

> new file mode 100644
> index 0000000000000..cb33a32c1aed9
> --- /dev/null
> +++ b/include/dt-bindings/power/rk3576-power.h
> @@ -0,0 +1,30 @@
> +/* SPDX-License-Identifier: (GPL-2.0+ OR MIT) */

Weird license.

Best regards,
Krzysztof
Detlev Casanova Aug. 6, 2024, 4:34 p.m. UTC | #2
On Sunday, 4 August 2024 05:56:39 EDT Krzysztof Kozlowski wrote:
> On 02/08/2024 17:14, Detlev Casanova wrote:
> > From: Finley Xiao <finley.xiao@rock-chips.com>
> > 
> > Define power domain IDs as described in the TRM.
> 
> Please use subject prefixes matching the subsystem. You can get them for
> example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
> your patch is touching. For bindings, the preferred subjects are
> explained here:
> https://www.kernel.org/doc/html/latest/devicetree/bindings/submitting-patche
> s.html#i-for-patch-submitters
> > Signed-off-by: Finley Xiao <finley.xiao@rock-chips.com>
> > [reword]
> > Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
> > ---
> > 
> >  include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
> >  1 file changed, 30 insertions(+)
> >  create mode 100644 include/dt-bindings/power/rk3576-power.h
> 
> This is part of bindings.
> 
> > diff --git a/include/dt-bindings/power/rk3576-power.h
> > b/include/dt-bindings/power/rk3576-power.h
> Missing vendor prefix. This should be named after compatible.

Looks like all other rockchip power bindings use the include/dt-bindings/
power/rkXXXX.h format. Should I keep that way ?

> > new file mode 100644
> > index 0000000000000..cb33a32c1aed9
> > --- /dev/null
> > +++ b/include/dt-bindings/power/rk3576-power.h
> > @@ -0,0 +1,30 @@
> > +/* SPDX-License-Identifier: (GPL-2.0+ OR MIT) */
> 
> Weird license.
> 
> Best regards,
> Krzysztof
Heiko Stübner Aug. 8, 2024, 7:54 a.m. UTC | #3
Hi Detlev,

Am Dienstag, 6. August 2024, 18:34:41 CEST schrieb Detlev Casanova:
> On Sunday, 4 August 2024 05:56:39 EDT Krzysztof Kozlowski wrote:
> > On 02/08/2024 17:14, Detlev Casanova wrote:
> > > From: Finley Xiao <finley.xiao@rock-chips.com>
> > > 
> > > Define power domain IDs as described in the TRM.
> > 
> > Please use subject prefixes matching the subsystem. You can get them for
> > example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
> > your patch is touching. For bindings, the preferred subjects are
> > explained here:
> > https://www.kernel.org/doc/html/latest/devicetree/bindings/submitting-patche
> > s.html#i-for-patch-submitters
> > > Signed-off-by: Finley Xiao <finley.xiao@rock-chips.com>
> > > [reword]
> > > Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
> > > ---
> > > 
> > >  include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
> > >  1 file changed, 30 insertions(+)
> > >  create mode 100644 include/dt-bindings/power/rk3576-power.h
> > 
> > This is part of bindings.
> > 
> > > diff --git a/include/dt-bindings/power/rk3576-power.h
> > > b/include/dt-bindings/power/rk3576-power.h
> > Missing vendor prefix. This should be named after compatible.
> 
> Looks like all other rockchip power bindings use the include/dt-bindings/
> power/rkXXXX.h format. Should I keep that way ?

there is also rockchip,rv1126-power.h , so please follow Krzysztof's
suggestion. Older header namings need to stay the same of course
but that shouldn't keep us from updating naming schemes to better
work in new additions.
Dragan Simic Aug. 8, 2024, 4:43 p.m. UTC | #4
Hello Heiko,

On 2024-08-08 09:54, Heiko Stübner wrote:
> Am Dienstag, 6. August 2024, 18:34:41 CEST schrieb Detlev Casanova:
>> On Sunday, 4 August 2024 05:56:39 EDT Krzysztof Kozlowski wrote:
>> > On 02/08/2024 17:14, Detlev Casanova wrote:
>> > > From: Finley Xiao <finley.xiao@rock-chips.com>
>> > >
>> > > Define power domain IDs as described in the TRM.
>> >
>> > Please use subject prefixes matching the subsystem. You can get them for
>> > example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
>> > your patch is touching. For bindings, the preferred subjects are
>> > explained here:
>> > https://www.kernel.org/doc/html/latest/devicetree/bindings/submitting-patche
>> > s.html#i-for-patch-submitters
>> > > Signed-off-by: Finley Xiao <finley.xiao@rock-chips.com>
>> > > [reword]
>> > > Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
>> > > ---
>> > >
>> > >  include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
>> > >  1 file changed, 30 insertions(+)
>> > >  create mode 100644 include/dt-bindings/power/rk3576-power.h
>> >
>> > This is part of bindings.
>> >
>> > > diff --git a/include/dt-bindings/power/rk3576-power.h
>> > > b/include/dt-bindings/power/rk3576-power.h
>> > Missing vendor prefix. This should be named after compatible.
>> 
>> Looks like all other rockchip power bindings use the 
>> include/dt-bindings/
>> power/rkXXXX.h format. Should I keep that way ?
> 
> there is also rockchip,rv1126-power.h , so please follow Krzysztof's
> suggestion. Older header namings need to stay the same of course
> but that shouldn't keep us from updating naming schemes to better
> work in new additions.

Actually, why don't we rename the old headers to follow the new naming 
rules?
Is there something preventing us from doing that, which I'm missing?
Heiko Stübner Aug. 8, 2024, 4:46 p.m. UTC | #5
Am Donnerstag, 8. August 2024, 18:43:42 CEST schrieb Dragan Simic:
> Hello Heiko,
> 
> On 2024-08-08 09:54, Heiko Stübner wrote:
> > Am Dienstag, 6. August 2024, 18:34:41 CEST schrieb Detlev Casanova:
> >> On Sunday, 4 August 2024 05:56:39 EDT Krzysztof Kozlowski wrote:
> >> > On 02/08/2024 17:14, Detlev Casanova wrote:
> >> > > From: Finley Xiao <finley.xiao@rock-chips.com>
> >> > >
> >> > > Define power domain IDs as described in the TRM.
> >> >
> >> > Please use subject prefixes matching the subsystem. You can get them for
> >> > example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
> >> > your patch is touching. For bindings, the preferred subjects are
> >> > explained here:
> >> > https://www.kernel.org/doc/html/latest/devicetree/bindings/submitting-patche
> >> > s.html#i-for-patch-submitters
> >> > > Signed-off-by: Finley Xiao <finley.xiao@rock-chips.com>
> >> > > [reword]
> >> > > Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
> >> > > ---
> >> > >
> >> > >  include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
> >> > >  1 file changed, 30 insertions(+)
> >> > >  create mode 100644 include/dt-bindings/power/rk3576-power.h
> >> >
> >> > This is part of bindings.
> >> >
> >> > > diff --git a/include/dt-bindings/power/rk3576-power.h
> >> > > b/include/dt-bindings/power/rk3576-power.h
> >> > Missing vendor prefix. This should be named after compatible.
> >> 
> >> Looks like all other rockchip power bindings use the 
> >> include/dt-bindings/
> >> power/rkXXXX.h format. Should I keep that way ?
> > 
> > there is also rockchip,rv1126-power.h , so please follow Krzysztof's
> > suggestion. Older header namings need to stay the same of course
> > but that shouldn't keep us from updating naming schemes to better
> > work in new additions.
> 
> Actually, why don't we rename the old headers to follow the new naming 
> rules?
> Is there something preventing us from doing that, which I'm missing?

yes, the headers are _part_ of the actual devicetree-binding.
So you have out of tree users in the BSDs or whereever else.
diff mbox series

Patch

diff --git a/include/dt-bindings/power/rk3576-power.h b/include/dt-bindings/power/rk3576-power.h
new file mode 100644
index 0000000000000..cb33a32c1aed9
--- /dev/null
+++ b/include/dt-bindings/power/rk3576-power.h
@@ -0,0 +1,30 @@ 
+/* SPDX-License-Identifier: (GPL-2.0+ OR MIT) */
+#ifndef __DT_BINDINGS_POWER_RK3576_POWER_H__
+#define __DT_BINDINGS_POWER_RK3576_POWER_H__
+
+/* VD_NPU */
+#define RK3576_PD_NPU		0
+#define RK3576_PD_NPUTOP	1
+#define RK3576_PD_NPU0		2
+#define RK3576_PD_NPU1		3
+
+/* VD_GPU */
+#define RK3576_PD_GPU		4
+
+/* VD_LOGIC */
+#define RK3576_PD_NVM		5
+#define RK3576_PD_SDGMAC	6
+#define RK3576_PD_USB		7
+#define RK3576_PD_PHP		8
+#define RK3576_PD_SUBPHP	9
+#define RK3576_PD_AUDIO		10
+#define RK3576_PD_VEPU0		11
+#define RK3576_PD_VEPU1		12
+#define RK3576_PD_VPU		13
+#define RK3576_PD_VDEC		14
+#define RK3576_PD_VI		15
+#define RK3576_PD_VO0		16
+#define RK3576_PD_VO1		17
+#define RK3576_PD_VOP		18
+
+#endif