Message ID | 20250328170232003DGEGnXtJuqky8ri8DWMFQ@zte.com.cn (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | phy/allwinner: phy-sun50i-usb3: Use dev_err_probe() | expand |
On 28/03/2025 10:02, shao.mingyin@zte.com.cn wrote: > From: Zhang Enpei <zhang.enpei@zte.com.cn> > > Replace the open-code with dev_err_probe() to simplify the code. > > Signed-off-by: Zhang Enpei <zhang.enpei@zte.com.cn> > Signed-off-by: Shao Mingyin <shao.mingyin@zte.com.cn> Why are you sending patch-by-patch? Organize your work for the same subsystem into one patchset so we see entire picture at once, not spread onto 10 separate threads. Best regards, Krzysztof
diff --git a/drivers/phy/allwinner/phy-sun50i-usb3.c b/drivers/phy/allwinner/phy-sun50i-usb3.c index 363f9a0df503..b03faffc160d 100644 --- a/drivers/phy/allwinner/phy-sun50i-usb3.c +++ b/drivers/phy/allwinner/phy-sun50i-usb3.c @@ -141,11 +141,9 @@ static int sun50i_usb3_phy_probe(struct platform_device *pdev) return -ENOMEM; phy->clk = devm_clk_get(dev, NULL); - if (IS_ERR(phy->clk)) { - if (PTR_ERR(phy->clk) != -EPROBE_DEFER) - dev_err(dev, "failed to get phy clock\n"); - return PTR_ERR(phy->clk); - } + if (IS_ERR(phy->clk)) + return dev_err_probe(dev, PTR_ERR(phy->clk), + "failed to get phy clock\n"); phy->reset = devm_reset_control_get(dev, NULL); if (IS_ERR(phy->reset)) {