diff mbox series

soc: qcom: Rename ice to qcom-ice to avoid module name conflict

Message ID 20230510074404.3520340-1-abel.vesa@linaro.org (mailing list archive)
State Changes Requested
Headers show
Series soc: qcom: Rename ice to qcom-ice to avoid module name conflict | expand

Commit Message

Abel Vesa May 10, 2023, 7:44 a.m. UTC
The following error was reported when building x86_64 allmodconfig:

error: the following would cause module name conflict:
  drivers/soc/qcom/ice.ko
  drivers/net/ethernet/intel/ice/ice.ko

Seems the 'ice' module name is already used by some Intel ethernet
driver, so lets rename the Qualcomm Inline Crypto Engine (ICE) from
'ice' to 'qcom-ice' to avoid any kind of errors/confusions.

Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
Fixes: 2afbf43a4aec ("soc: qcom: Make the Qualcomm UFS/SDCC ICE a dedicated driver")
Signed-off-by: Abel Vesa <abel.vesa@linaro.org>
---

The build failure was reported here:
https://lore.kernel.org/all/20230510111833.17810885@canb.auug.org.au/

 drivers/soc/qcom/Makefile              | 2 +-
 drivers/soc/qcom/{ice.c => qcom-ice.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/soc/qcom/{ice.c => qcom-ice.c} (100%)

Comments

Manivannan Sadhasivam May 10, 2023, 8:25 a.m. UTC | #1
On Wed, May 10, 2023 at 10:44:04AM +0300, Abel Vesa wrote:
> The following error was reported when building x86_64 allmodconfig:
> 
> error: the following would cause module name conflict:
>   drivers/soc/qcom/ice.ko
>   drivers/net/ethernet/intel/ice/ice.ko
> 
> Seems the 'ice' module name is already used by some Intel ethernet
> driver, so lets rename the Qualcomm Inline Crypto Engine (ICE) from
> 'ice' to 'qcom-ice' to avoid any kind of errors/confusions.
> 
> Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
> Fixes: 2afbf43a4aec ("soc: qcom: Make the Qualcomm UFS/SDCC ICE a dedicated driver")
> Signed-off-by: Abel Vesa <abel.vesa@linaro.org>
> ---
> 
> The build failure was reported here:
> https://lore.kernel.org/all/20230510111833.17810885@canb.auug.org.au/
> 
>  drivers/soc/qcom/Makefile              | 2 +-
>  drivers/soc/qcom/{ice.c => qcom-ice.c} | 0
>  2 files changed, 1 insertion(+), 1 deletion(-)
>  rename drivers/soc/qcom/{ice.c => qcom-ice.c} (100%)
> 

You can just rename the module name to "qcom-ice" and still keep the driver name
as "ice" as it is already under "qcom" subdirectory.

We do it for other drivers as well.

- Mani

> diff --git a/drivers/soc/qcom/Makefile b/drivers/soc/qcom/Makefile
> index 0f43a88b4894..30219c164cb0 100644
> --- a/drivers/soc/qcom/Makefile
> +++ b/drivers/soc/qcom/Makefile
> @@ -32,4 +32,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
>  obj-$(CONFIG_QCOM_RPMPD) += rpmpd.o
>  obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=	kryo-l2-accessors.o
>  obj-$(CONFIG_QCOM_ICC_BWMON)	+= icc-bwmon.o
> -obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= ice.o
> +obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= qcom-ice.o
> diff --git a/drivers/soc/qcom/ice.c b/drivers/soc/qcom/qcom-ice.c
> similarity index 100%
> rename from drivers/soc/qcom/ice.c
> rename to drivers/soc/qcom/qcom-ice.c
> -- 
> 2.34.1
>
Abel Vesa May 12, 2023, 11:53 a.m. UTC | #2
On 23-05-10 13:55:55, Manivannan Sadhasivam wrote:
> On Wed, May 10, 2023 at 10:44:04AM +0300, Abel Vesa wrote:
> > The following error was reported when building x86_64 allmodconfig:
> > 
> > error: the following would cause module name conflict:
> >   drivers/soc/qcom/ice.ko
> >   drivers/net/ethernet/intel/ice/ice.ko
> > 
> > Seems the 'ice' module name is already used by some Intel ethernet
> > driver, so lets rename the Qualcomm Inline Crypto Engine (ICE) from
> > 'ice' to 'qcom-ice' to avoid any kind of errors/confusions.
> > 
> > Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
> > Fixes: 2afbf43a4aec ("soc: qcom: Make the Qualcomm UFS/SDCC ICE a dedicated driver")
> > Signed-off-by: Abel Vesa <abel.vesa@linaro.org>
> > ---
> > 
> > The build failure was reported here:
> > https://lore.kernel.org/all/20230510111833.17810885@canb.auug.org.au/
> > 
> >  drivers/soc/qcom/Makefile              | 2 +-
> >  drivers/soc/qcom/{ice.c => qcom-ice.c} | 0
> >  2 files changed, 1 insertion(+), 1 deletion(-)
> >  rename drivers/soc/qcom/{ice.c => qcom-ice.c} (100%)
> > 
> 
> You can just rename the module name to "qcom-ice" and still keep the driver name
> as "ice" as it is already under "qcom" subdirectory.
> 
> We do it for other drivers as well.

Yes, but in this case, it is not worth keeping the file name as is.

I'll send another version of this patch with the filename as qcom_ice.c
in order to be inline with the other ones.

> 
> - Mani
> 
> > diff --git a/drivers/soc/qcom/Makefile b/drivers/soc/qcom/Makefile
> > index 0f43a88b4894..30219c164cb0 100644
> > --- a/drivers/soc/qcom/Makefile
> > +++ b/drivers/soc/qcom/Makefile
> > @@ -32,4 +32,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
> >  obj-$(CONFIG_QCOM_RPMPD) += rpmpd.o
> >  obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=	kryo-l2-accessors.o
> >  obj-$(CONFIG_QCOM_ICC_BWMON)	+= icc-bwmon.o
> > -obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= ice.o
> > +obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= qcom-ice.o
> > diff --git a/drivers/soc/qcom/ice.c b/drivers/soc/qcom/qcom-ice.c
> > similarity index 100%
> > rename from drivers/soc/qcom/ice.c
> > rename to drivers/soc/qcom/qcom-ice.c
> > -- 
> > 2.34.1
> > 
> 
> -- 
> மணிவண்ணன் சதாசிவம்
Manivannan Sadhasivam May 12, 2023, 12:42 p.m. UTC | #3
On Fri, May 12, 2023 at 02:53:26PM +0300, Abel Vesa wrote:
> On 23-05-10 13:55:55, Manivannan Sadhasivam wrote:
> > On Wed, May 10, 2023 at 10:44:04AM +0300, Abel Vesa wrote:
> > > The following error was reported when building x86_64 allmodconfig:
> > > 
> > > error: the following would cause module name conflict:
> > >   drivers/soc/qcom/ice.ko
> > >   drivers/net/ethernet/intel/ice/ice.ko
> > > 
> > > Seems the 'ice' module name is already used by some Intel ethernet
> > > driver, so lets rename the Qualcomm Inline Crypto Engine (ICE) from
> > > 'ice' to 'qcom-ice' to avoid any kind of errors/confusions.
> > > 
> > > Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
> > > Fixes: 2afbf43a4aec ("soc: qcom: Make the Qualcomm UFS/SDCC ICE a dedicated driver")
> > > Signed-off-by: Abel Vesa <abel.vesa@linaro.org>
> > > ---
> > > 
> > > The build failure was reported here:
> > > https://lore.kernel.org/all/20230510111833.17810885@canb.auug.org.au/
> > > 
> > >  drivers/soc/qcom/Makefile              | 2 +-
> > >  drivers/soc/qcom/{ice.c => qcom-ice.c} | 0
> > >  2 files changed, 1 insertion(+), 1 deletion(-)
> > >  rename drivers/soc/qcom/{ice.c => qcom-ice.c} (100%)
> > > 
> > 
> > You can just rename the module name to "qcom-ice" and still keep the driver name
> > as "ice" as it is already under "qcom" subdirectory.
> > 
> > We do it for other drivers as well.
> 
> Yes, but in this case, it is not worth keeping the file name as is.
> 

Since you already have "qcom" as the parent directory name, I don't know how
adding "qcom" prefix for the drivers in child directory helps. It is required
for the module name but not for the driver name.

If you look at current qcom soc drivers, then most of them are without prefix
but _some_ are with prefix. And the later ones doesn't make sense to me,

But I'll leave it to Bjorn to take the call.

- Mani

> I'll send another version of this patch with the filename as qcom_ice.c
> in order to be inline with the other ones.
> 
> > 
> > - Mani
> > 
> > > diff --git a/drivers/soc/qcom/Makefile b/drivers/soc/qcom/Makefile
> > > index 0f43a88b4894..30219c164cb0 100644
> > > --- a/drivers/soc/qcom/Makefile
> > > +++ b/drivers/soc/qcom/Makefile
> > > @@ -32,4 +32,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
> > >  obj-$(CONFIG_QCOM_RPMPD) += rpmpd.o
> > >  obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=	kryo-l2-accessors.o
> > >  obj-$(CONFIG_QCOM_ICC_BWMON)	+= icc-bwmon.o
> > > -obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= ice.o
> > > +obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= qcom-ice.o
> > > diff --git a/drivers/soc/qcom/ice.c b/drivers/soc/qcom/qcom-ice.c
> > > similarity index 100%
> > > rename from drivers/soc/qcom/ice.c
> > > rename to drivers/soc/qcom/qcom-ice.c
> > > -- 
> > > 2.34.1
> > > 
> > 
> > -- 
> > மணிவண்ணன் சதாசிவம்
diff mbox series

Patch

diff --git a/drivers/soc/qcom/Makefile b/drivers/soc/qcom/Makefile
index 0f43a88b4894..30219c164cb0 100644
--- a/drivers/soc/qcom/Makefile
+++ b/drivers/soc/qcom/Makefile
@@ -32,4 +32,4 @@  obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
 obj-$(CONFIG_QCOM_RPMPD) += rpmpd.o
 obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=	kryo-l2-accessors.o
 obj-$(CONFIG_QCOM_ICC_BWMON)	+= icc-bwmon.o
-obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= ice.o
+obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)	+= qcom-ice.o
diff --git a/drivers/soc/qcom/ice.c b/drivers/soc/qcom/qcom-ice.c
similarity index 100%
rename from drivers/soc/qcom/ice.c
rename to drivers/soc/qcom/qcom-ice.c