mbox series

[PATCHv2,0/3] block: protect debugfs attributes using elavtor_lock

Message ID 20250313115235.3707600-1-nilay@linux.ibm.com (mailing list archive)
Headers show
Series block: protect debugfs attributes using elavtor_lock | expand

Message

Nilay Shroff March 13, 2025, 11:51 a.m. UTC
Hi,

This patchset contains total three patches.
The first patch helps protect debugfs attributes using q->elevator_lock
instead of q->sysfs_lock.
The second patch in the series removes the goto labels from the read
methods of debugfs attributes that improves code readability and reducing
complexity.
The third patch in the series protects debugfs attribute method hctx_
busy_show using q->elevator_lock.

Please note that this patchset was unit tested against blktests and quick
xfstests with lockdep enabled.
---
Changes from v1:
    - Split patch into smaller patches for bisectability. (hch)
    - Remove goto lable and return immediately upon failing to acquire
      the mutex lock. (Damien, hch)
    - Original patch in v1 is splitted into three patches
Link to v1: https://lore.kernel.org/all/20250312102903.3584358-1-nilay@linux.ibm.com/
---
Nilay Shroff (3):
  block: protect debugfs attrs using elevator_lock instead of sysfs_lock
  block: Remove unnecessary goto labels in debugfs attribute read
    methods
  block: protect debugfs attribute method hctx_busy_show

 block/blk-mq-debugfs.c | 41 +++++++++++++++++++++--------------------
 include/linux/blkdev.h |  6 +++---
 2 files changed, 24 insertions(+), 23 deletions(-)

Comments

Jens Axboe March 13, 2025, 1:24 p.m. UTC | #1
On Thu, 13 Mar 2025 17:21:49 +0530, Nilay Shroff wrote:
> This patchset contains total three patches.
> The first patch helps protect debugfs attributes using q->elevator_lock
> instead of q->sysfs_lock.
> The second patch in the series removes the goto labels from the read
> methods of debugfs attributes that improves code readability and reducing
> complexity.
> The third patch in the series protects debugfs attribute method hctx_
> busy_show using q->elevator_lock.
> 
> [...]

Applied, thanks!

[1/3] block: protect debugfs attrs using elevator_lock instead of sysfs_lock
      commit: a3996d11f3ab743e6cc4e3529ce9459c2cd27139
[2/3] block: Remove unnecessary goto labels in debugfs attribute read methods
      commit: 78800f5997d8ae0f20d4aced66a524f0f2fc4c7f
[3/3] block: protect debugfs attribute method hctx_busy_show
      commit: 0e94ed33681424a6dce65c62837e08e4c7aa09ac

Best regards,