Message ID | 20250324-ptr-as-ptr-v6-6-49d1b7fd4290@gmail.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | rust: reduce `as` casts, enable related lints | expand |
On Mon Mar 24, 2025 at 11:01 PM CET, Tamir Duberstein wrote: > Before Rust 1.29.0, Clippy introduced the `cast_lossless` lint [1]: > >> Rust’s `as` keyword will perform many kinds of conversions, including >> silently lossy conversions. Conversion functions such as `i32::from` >> will only perform lossless conversions. Using the conversion functions >> prevents conversions from becoming silently lossy if the input types >> ever change, and makes it clear for people reading the code that the >> conversion is lossless. > > While this doesn't eliminate unchecked `as` conversions, it makes such > conversions easier to scrutinize. It also has the slight benefit of > removing a degree of freedom on which to bikeshed. Thus apply the > changes and enable the lint -- no functional change intended. > > Link: https://rust-lang.github.io/rust-clippy/master/index.html#cast_lossless [1] > Suggested-by: Benno Lossin <benno.lossin@proton.me> > Link: https://lore.kernel.org/all/D8ORTXSUTKGL.1KOJAGBM8F8TN@proton.me/ > Signed-off-by: Tamir Duberstein <tamird@gmail.com> One nit below, but you may add: Reviewed-by: Benno Lossin <benno.lossin@proton.me> > --- > Makefile | 1 + > drivers/gpu/drm/drm_panic_qr.rs | 10 +++++----- > rust/bindings/lib.rs | 2 +- > rust/kernel/net/phy.rs | 4 ++-- > 4 files changed, 9 insertions(+), 8 deletions(-) > diff --git a/rust/bindings/lib.rs b/rust/bindings/lib.rs > index 0486a32ed314..591e4ca9bc54 100644 > --- a/rust/bindings/lib.rs > +++ b/rust/bindings/lib.rs > @@ -25,7 +25,7 @@ > )] > > #[allow(dead_code)] > -#[allow(clippy::ptr_as_ptr)] > +#[allow(clippy::cast_lossless, clippy::ptr_as_ptr)] Not sure if we instead want this in a separate attribute, ultimately it doesn't really matter, but why should `undocumented_unsafe_blocks` be special? --- Cheers, Benno > #[allow(clippy::undocumented_unsafe_blocks)] > mod bindings_raw { > // Manual definition for blocklisted types.
On Tue, Mar 25, 2025 at 6:40 AM Benno Lossin <benno.lossin@proton.me> wrote: > > On Mon Mar 24, 2025 at 11:01 PM CET, Tamir Duberstein wrote: > > Before Rust 1.29.0, Clippy introduced the `cast_lossless` lint [1]: > > > >> Rust’s `as` keyword will perform many kinds of conversions, including > >> silently lossy conversions. Conversion functions such as `i32::from` > >> will only perform lossless conversions. Using the conversion functions > >> prevents conversions from becoming silently lossy if the input types > >> ever change, and makes it clear for people reading the code that the > >> conversion is lossless. > > > > While this doesn't eliminate unchecked `as` conversions, it makes such > > conversions easier to scrutinize. It also has the slight benefit of > > removing a degree of freedom on which to bikeshed. Thus apply the > > changes and enable the lint -- no functional change intended. > > > > Link: https://rust-lang.github.io/rust-clippy/master/index.html#cast_lossless [1] > > Suggested-by: Benno Lossin <benno.lossin@proton.me> > > Link: https://lore.kernel.org/all/D8ORTXSUTKGL.1KOJAGBM8F8TN@proton.me/ > > Signed-off-by: Tamir Duberstein <tamird@gmail.com> > > One nit below, but you may add: > > Reviewed-by: Benno Lossin <benno.lossin@proton.me> Thanks! > > > --- > > Makefile | 1 + > > drivers/gpu/drm/drm_panic_qr.rs | 10 +++++----- > > rust/bindings/lib.rs | 2 +- > > rust/kernel/net/phy.rs | 4 ++-- > > 4 files changed, 9 insertions(+), 8 deletions(-) > > > diff --git a/rust/bindings/lib.rs b/rust/bindings/lib.rs > > index 0486a32ed314..591e4ca9bc54 100644 > > --- a/rust/bindings/lib.rs > > +++ b/rust/bindings/lib.rs > > @@ -25,7 +25,7 @@ > > )] > > > > #[allow(dead_code)] > > -#[allow(clippy::ptr_as_ptr)] > > +#[allow(clippy::cast_lossless, clippy::ptr_as_ptr)] > > Not sure if we instead want this in a separate attribute, ultimately it > doesn't really matter, but why should `undocumented_unsafe_blocks` be > special? No reason. Moved it to a separate line. I won't respin just for this - hopefully Miguel doesn't mind fixing when he takes it, if there's not a v7 by then. Tamir
diff --git a/Makefile b/Makefile index 2af40bfed9ce..2e9eca8b7671 100644 --- a/Makefile +++ b/Makefile @@ -479,6 +479,7 @@ export rust_common_flags := --edition=2021 \ -Wclippy::all \ -Wclippy::as_ptr_cast_mut \ -Wclippy::as_underscore \ + -Wclippy::cast_lossless \ -Wclippy::ignored_unit_patterns \ -Wclippy::mut_mut \ -Wclippy::needless_bitwise_bool \ diff --git a/drivers/gpu/drm/drm_panic_qr.rs b/drivers/gpu/drm/drm_panic_qr.rs index ecd87e8ffe05..01337ce896df 100644 --- a/drivers/gpu/drm/drm_panic_qr.rs +++ b/drivers/gpu/drm/drm_panic_qr.rs @@ -305,15 +305,15 @@ fn get_next_13b(data: &[u8], offset: usize) -> Option<(u16, usize)> { // `b` is 20 at max (`bit_off` <= 7 and `size` <= 13). let b = (bit_off + size) as u16; - let first_byte = (data[byte_off] << bit_off >> bit_off) as u16; + let first_byte = u16::from(data[byte_off] << bit_off >> bit_off); let number = match b { 0..=8 => first_byte >> (8 - b), - 9..=16 => (first_byte << (b - 8)) + (data[byte_off + 1] >> (16 - b)) as u16, + 9..=16 => (first_byte << (b - 8)) + u16::from(data[byte_off + 1] >> (16 - b)), _ => { (first_byte << (b - 8)) - + ((data[byte_off + 1] as u16) << (b - 16)) - + (data[byte_off + 2] >> (24 - b)) as u16 + + u16::from(data[byte_off + 1] << (b - 16)) + + u16::from(data[byte_off + 2] >> (24 - b)) } }; Some((number, size)) @@ -414,7 +414,7 @@ fn next(&mut self) -> Option<Self::Item> { match self.segment { Segment::Binary(data) => { if self.offset < data.len() { - let byte = data[self.offset] as u16; + let byte = data[self.offset].into(); self.offset += 1; Some((byte, 8)) } else { diff --git a/rust/bindings/lib.rs b/rust/bindings/lib.rs index 0486a32ed314..591e4ca9bc54 100644 --- a/rust/bindings/lib.rs +++ b/rust/bindings/lib.rs @@ -25,7 +25,7 @@ )] #[allow(dead_code)] -#[allow(clippy::ptr_as_ptr)] +#[allow(clippy::cast_lossless, clippy::ptr_as_ptr)] #[allow(clippy::undocumented_unsafe_blocks)] mod bindings_raw { // Manual definition for blocklisted types. diff --git a/rust/kernel/net/phy.rs b/rust/kernel/net/phy.rs index a59469c785e3..abc58b4d1bf4 100644 --- a/rust/kernel/net/phy.rs +++ b/rust/kernel/net/phy.rs @@ -142,7 +142,7 @@ pub fn is_autoneg_enabled(&self) -> bool { // SAFETY: The struct invariant ensures that we may access // this field without additional synchronization. let bit_field = unsafe { &(*self.0.get())._bitfield_1 }; - bit_field.get(13, 1) == bindings::AUTONEG_ENABLE as u64 + bit_field.get(13, 1) == bindings::AUTONEG_ENABLE.into() } /// Gets the current auto-negotiation state. @@ -426,7 +426,7 @@ impl<T: Driver> Adapter<T> { // where we hold `phy_device->lock`, so the accessors on // `Device` are okay to call. let dev = unsafe { Device::from_raw(phydev) }; - T::match_phy_device(dev) as i32 + T::match_phy_device(dev).into() } /// # Safety