mbox series

[0/7] More misc fixes

Message ID 20190103085005.32053-1-nborisov@suse.com (mailing list archive)
Headers show
Series More misc fixes | expand

Message

Nikolay Borisov Jan. 3, 2019, 8:49 a.m. UTC
Here is an assortment of fixes, mainly around the async (compressed) cow path. 
Just removes some redundant arguments/local variables, makes shrink_delalloc a
bit more readable by simplifying variable usage and giving more appropriate names. 
Also documents the ->inode null check in async_cow_submit and cleans up open-coded
usage of DIV_ROUND_UP. No functional changes to any of the patches. 

Nikolay Borisov (7):
  btrfs: Remove inode argument from async_cow_submit
  btrfs: Remove isize local variable in compress_file_range
  btrfs: Use ihold instead of igrab in cow_file_range_async
  btrfs: Remove WARN_ON in btrfs_alloc_delalloc_work
  btrfs: Document logic in async_cow_submit
  btrfs: Replace open-coded maths with DIV_ROUND_UP
  btrfs: Refactor shrink_delalloc

 fs/btrfs/extent-tree.c | 33 ++++++++++++++++++++++-----------
 fs/btrfs/extent_io.c   |  7 +++----
 fs/btrfs/inode.c       | 27 +++++++++++++++------------
 3 files changed, 40 insertions(+), 27 deletions(-)

Comments

David Sterba Jan. 7, 2019, 5:59 p.m. UTC | #1
On Thu, Jan 03, 2019 at 10:49:58AM +0200, Nikolay Borisov wrote:
> Here is an assortment of fixes, mainly around the async (compressed) cow path. 
> Just removes some redundant arguments/local variables, makes shrink_delalloc a
> bit more readable by simplifying variable usage and giving more appropriate names. 
> Also documents the ->inode null check in async_cow_submit and cleans up open-coded
> usage of DIV_ROUND_UP. No functional changes to any of the patches. 
> 
> Nikolay Borisov (7):
>   btrfs: Remove inode argument from async_cow_submit
>   btrfs: Remove isize local variable in compress_file_range
>   btrfs: Use ihold instead of igrab in cow_file_range_async
>   btrfs: Remove WARN_ON in btrfs_alloc_delalloc_work
>   btrfs: Document logic in async_cow_submit
>   btrfs: Replace open-coded maths with DIV_ROUND_UP
>   btrfs: Refactor shrink_delalloc

All but 6/7 applied, the one still needs to be clarified.