mbox series

[v4,0/7] Compress path cleanups

Message ID 20190312152030.31987-1-nborisov@suse.com (mailing list archive)
Headers show
Series Compress path cleanups | expand

Message

Nikolay Borisov March 12, 2019, 3:20 p.m. UTC
Here is the v4 of the compress path cleanups, this version  incorporates 
feeback from v3, namely: 

* Use struct_size when calculating the size of the struct to allocated in 
cow_file_range_async

* Reinstated the comment about ihold in cow_file_range_async

* Renamed "struct async_chunk *" variables from async_cow to async_chunk

* Gave patch 1 a more explicit title. 

* added RB tags from Johanness to patch 3 and 4

Nikolay Borisov (7):
  btrfs: Preallocate chunks in cow_file_range_async
  btrfs: Rename async_cow to async_chunk
  btrfs: Remove fs_info from struct async_chunk
  btrfs: Make compress_file_range take only struct async_chunk
  btrfs: Replace clear_extent_bit with unlock_extent
  btrfs: Set iotree only once in submit_compressed_extents
  btrfs: Factor out common extent locking code in
    submit_compressed_extents

 fs/btrfs/inode.c | 177 ++++++++++++++++++++++++++---------------------
 1 file changed, 100 insertions(+), 77 deletions(-)

Comments

David Sterba March 13, 2019, 3:36 p.m. UTC | #1
On Tue, Mar 12, 2019 at 05:20:23PM +0200, Nikolay Borisov wrote:
> Here is the v4 of the compress path cleanups, this version  incorporates 
> feeback from v3, namely: 
> 
> * Use struct_size when calculating the size of the struct to allocated in 
> cow_file_range_async
> 
> * Reinstated the comment about ihold in cow_file_range_async
> 
> * Renamed "struct async_chunk *" variables from async_cow to async_chunk
> 
> * Gave patch 1 a more explicit title. 
> 
> * added RB tags from Johanness to patch 3 and 4
> 
> Nikolay Borisov (7):
>   btrfs: Preallocate chunks in cow_file_range_async
>   btrfs: Rename async_cow to async_chunk
>   btrfs: Remove fs_info from struct async_chunk
>   btrfs: Make compress_file_range take only struct async_chunk
>   btrfs: Replace clear_extent_bit with unlock_extent
>   btrfs: Set iotree only once in submit_compressed_extents
>   btrfs: Factor out common extent locking code in
>     submit_compressed_extents

Overall looks good, I'll add it to misc-5.2 after some testing, thanks.