mbox series

[v3,0/14] btrfs: Introduce macro to iterate over slots

Message ID 20220302164829.17524-1-gniebler@suse.com (mailing list archive)
Headers show
Series btrfs: Introduce macro to iterate over slots | expand

Message

Gabriel Niebler March 2, 2022, 4:48 p.m. UTC
There is a common pattern when searching for a key in btrfs:

* Call btrfs_search_slot to find the slot for the key
* Enter an endless loop:
	* If the found slot is larger than the no. of items in the current leaf,
	  check the next leaf
	* If it's still not found in the next leaf, terminate the loop
	* Otherwise do something with the found key
	* Increment the current slot and continue

To reduce code duplication, we can replace this code pattern with an iterator
macro, similar to the existing for_each_X macros found elsewhere in the kernel.
This also makes the code easier to understand for newcomers by putting a name
to the encapsulated functionality.

This patchset survived a complete fstest run.

Changes from v2:
 * Rename btrfs_valid_slot to btrfs_get_next_valid_item (Nikolay)
 * Fix comment formatting (David)
 * Remove redundant parentheses and indentation in loop condition (David)
 * Remove redundant iter_ret var and reuse ret instead (Nikolay)
 * Make termination condition more consistent in btrfs_unlink_all_paths
   (Nikolay)
 * Improved patch organisation by splitting into one patch per function (David)
 * Improve doc comment for btrfs_get_next_valid_item (Gabriel)
 * Remove `out` label and assoc. gotos from id_create_dir (Gabriel)
 * Initialise `ret` in process_all_refs and process_all_new_xattrs (Gabriel)
 * Remove unneeded btrfs_item_key_to_cpu call from loop body in
   btrfs_read_chunk_tree (Gabriel)

Changes from v1:
 * Separate xattr changes from the macro introducing code (Johannes)

Changes from RFC:
 * Add documentation to btrfs_for_each_slot macro and btrfs_valid_slot function
   (David)
 * Add documentation about the ret variable used as a macro argument (David)
 * Match function argument from prototype and implementation (David)
 * Changed ({ }) block to only () in btrfs_for_each_slot macro (David)
 * Add more patches to show the code being reduced by using this approach
   (Nikolay)

Marcos Paulo de Souza (14):
  btrfs: Introduce btrfs_for_each_slot iterator macro
  btrfs: Use btrfs_for_each_slot in find_first_block_group
  btrfs: Use btrfs_for_each_slot in mark_block_group_to_copy
  btrfs: Use btrfs_for_each_slot in btrfs_search_dir_index_item
  btrfs: Use btrfs_for_each_slot in btrfs_real_readdir
  btrfs: Use btrfs_for_each_slot in did_create_dir
  btrfs: Use btrfs_for_each_slot in can_rmdir
  btrfs: Use btrfs_for_each_slot in is_ancestor
  btrfs: Use btrfs_for_each_slot in process_all_refs
  btrfs: Use btrfs_for_each_slot in process_all_new_xattrs
  btrfs: Use btrfs_for_each_slot in process_all_extents
  btrfs: Use btrfs_for_each_slot in btrfs_unlink_all_paths
  btrfs: Use btrfs_for_each_slot in btrfs_read_chunk_tree
  btrfs: Use btrfs_for_each_slot in btrfs_listxattr

 fs/btrfs/block-group.c |  26 +-----
 fs/btrfs/ctree.c       |  33 +++++++
 fs/btrfs/ctree.h       |  24 ++++++
 fs/btrfs/dev-replace.c |  41 ++-------
 fs/btrfs/dir-item.c    |  31 ++-----
 fs/btrfs/inode.c       |  35 +++-----
 fs/btrfs/send.c        | 229 ++++++++++++++-----------------------------------
 fs/btrfs/volumes.c     |  26 ++----
 fs/btrfs/xattr.c       |  41 +++------
 9 files changed, 168 insertions(+), 318 deletions(-)

Comments

David Sterba March 8, 2022, 2:27 p.m. UTC | #1
On Wed, Mar 02, 2022 at 05:48:15PM +0100, Gabriel Niebler wrote:
> There is a common pattern when searching for a key in btrfs:
> 
> * Call btrfs_search_slot to find the slot for the key
> * Enter an endless loop:
> 	* If the found slot is larger than the no. of items in the current leaf,
> 	  check the next leaf
> 	* If it's still not found in the next leaf, terminate the loop
> 	* Otherwise do something with the found key
> 	* Increment the current slot and continue
> 
> To reduce code duplication, we can replace this code pattern with an iterator
> macro, similar to the existing for_each_X macros found elsewhere in the kernel.
> This also makes the code easier to understand for newcomers by putting a name
> to the encapsulated functionality.
> 
> This patchset survived a complete fstest run.
> 
> Changes from v2:
>  * Rename btrfs_valid_slot to btrfs_get_next_valid_item (Nikolay)
>  * Fix comment formatting (David)
>  * Remove redundant parentheses and indentation in loop condition (David)
>  * Remove redundant iter_ret var and reuse ret instead (Nikolay)
>  * Make termination condition more consistent in btrfs_unlink_all_paths
>    (Nikolay)
>  * Improved patch organisation by splitting into one patch per function (David)
>  * Improve doc comment for btrfs_get_next_valid_item (Gabriel)
>  * Remove `out` label and assoc. gotos from id_create_dir (Gabriel)
>  * Initialise `ret` in process_all_refs and process_all_new_xattrs (Gabriel)
>  * Remove unneeded btrfs_item_key_to_cpu call from loop body in
>    btrfs_read_chunk_tree (Gabriel)

I still see some of the style issues not addressed in your version, I'll
point them out in the first example I find but it needs to be fixed in
all of them. Otherwise it looks good. As we're near the code freeze for
5.17 I'm not sure I could put it there so it's 5.18 at the latest.