mbox series

[0/3] btrfs: random code cleanup

Message ID 20250309075820.30999-1-sunk67188@gmail.com (mailing list archive)
Headers show
Series btrfs: random code cleanup | expand

Message

Sun YangKai March 9, 2025, 7:57 a.m. UTC
These patches are not intented to change any behavior of current code.
Just trying to make the codes easier to read, and, maybe, perform better.
I'm working on btrfs_search_forward(), trying to improve it and fix some
misbehaviors. And I'll send some patches that will change the behavior of
the code later.

I'm new to the maillist, trying to read the implements, and improve it from
my perspective.
If you have any feedback or questions, please let me know :)

Sun YangKai (3):
  btrfs: improve readability in search_ioctl()
  btrfs: remove unnecessary 'found_key' local variable in
    btrfs_search_forward()
  btrfs: avoid redundant slot assignment in btrfs_search_forward()

 fs/btrfs/ctree.c | 12 +++++-------
 fs/btrfs/ioctl.c | 15 +++++++--------
 2 files changed, 12 insertions(+), 15 deletions(-)