mbox series

[v2,0/3] btrfs: random code cleanup

Message ID 20250311081317.13860-1-sunk67188@gmail.com (mailing list archive)
Headers show
Series btrfs: random code cleanup | expand

Message

Sun YangKai March 11, 2025, 8:13 a.m. UTC
These patches are not intended to change any behavior of current code.
Just trying to make the codes easier to read, and, maybe, perform better.
I'm working on btrfs_search_forward(), trying to improve it and fix some
misbehaviors. And I'll send some patches that will change the behavior of
the code later.

I'm new to the maillist, trying to read the implements, and improve it from
my perspective.
If you have any feedback or questions, please let me know :)

--
Changelog
v2:
- Improve the commit messages advised by David Sterba
- Fix some code style issues advised by David Sterba

Sun YangKai (3):
  btrfs: simplify the return value handling in search_ioctl()
  btrfs: remove the unnecessary local variable in btrfs_search_forward()
  btrfs: avoid redundant slot assignment in btrfs_search_forward()

 fs/btrfs/ctree.c | 15 ++++++---------
 fs/btrfs/ioctl.c | 15 +++++++--------
 2 files changed, 13 insertions(+), 17 deletions(-)

Comments

David Sterba March 11, 2025, 7:07 p.m. UTC | #1
On Tue, Mar 11, 2025 at 04:13:11PM +0800, Sun YangKai wrote:
> These patches are not intended to change any behavior of current code.
> Just trying to make the codes easier to read, and, maybe, perform better.
> I'm working on btrfs_search_forward(), trying to improve it and fix some
> misbehaviors. And I'll send some patches that will change the behavior of
> the code later.
> 
> I'm new to the maillist, trying to read the implements, and improve it from
> my perspective.
> If you have any feedback or questions, please let me know :)
> 
> --
> Changelog
> v2:
> - Improve the commit messages advised by David Sterba
> - Fix some code style issues advised by David Sterba

Added to for-next with some minor tweaks, thanks.