mbox series

[0/8] btrfs: remove a couple BUG_ON()s and cleanups

Message ID cover.1688137155.git.fdmanana@suse.com (mailing list archive)
Headers show
Series btrfs: remove a couple BUG_ON()s and cleanups | expand

Message

Filipe Manana June 30, 2023, 3:03 p.m. UTC
From: Filipe Manana <fdmanana@suse.com>

The first patch removes  a couple unnecessary BUG_ON()'s, since all
callers are able to properly deal with errors, which are triggered by
syzbot with error injection (-ENOMEM). The rest are just some followup
cleanups. More details in the changelogs.

Filipe Manana (8):
  btrfs: remove BUG_ON()'s in add_new_free_space()
  btrfs: update documentation for add_new_free_space()
  btrfs: rename add_new_free_space() to btrfs_add_new_free_space()
  btrfs: make btrfs_destroy_marked_extents() return void
  btrfs: make btrfs_destroy_pinned_extent() return void
  btrfs: make find_first_extent_bit() return a boolean
  btrfs: open code trivial btrfs_add_excluded_extent()
  btrfs: move btrfs_free_excluded_extents() into block-group.c

 fs/btrfs/block-group.c      | 91 +++++++++++++++++++++++++------------
 fs/btrfs/block-group.h      |  4 +-
 fs/btrfs/dev-replace.c      |  6 +--
 fs/btrfs/disk-io.c          | 31 ++++---------
 fs/btrfs/extent-io-tree.c   | 14 +++---
 fs/btrfs/extent-io-tree.h   |  6 +--
 fs/btrfs/extent-tree.c      | 26 +----------
 fs/btrfs/extent-tree.h      |  3 --
 fs/btrfs/free-space-cache.c |  7 ++-
 fs/btrfs/free-space-tree.c  | 27 ++++++++---
 fs/btrfs/relocation.c       | 10 ++--
 fs/btrfs/transaction.c      |  8 ++--
 fs/btrfs/volumes.c          |  6 +--
 13 files changed, 124 insertions(+), 115 deletions(-)

Comments

David Sterba July 12, 2023, 4:04 p.m. UTC | #1
On Fri, Jun 30, 2023 at 04:03:43PM +0100, fdmanana@kernel.org wrote:
> From: Filipe Manana <fdmanana@suse.com>
> 
> The first patch removes  a couple unnecessary BUG_ON()'s, since all
> callers are able to properly deal with errors, which are triggered by
> syzbot with error injection (-ENOMEM). The rest are just some followup
> cleanups. More details in the changelogs.
> 
> Filipe Manana (8):
>   btrfs: remove BUG_ON()'s in add_new_free_space()
>   btrfs: update documentation for add_new_free_space()
>   btrfs: rename add_new_free_space() to btrfs_add_new_free_space()
>   btrfs: make btrfs_destroy_marked_extents() return void
>   btrfs: make btrfs_destroy_pinned_extent() return void
>   btrfs: make find_first_extent_bit() return a boolean
>   btrfs: open code trivial btrfs_add_excluded_extent()
>   btrfs: move btrfs_free_excluded_extents() into block-group.c

Nice cleanups, added to misc-next, thanks.