mbox series

[v2,0/2] btrfs: cleanup on the extra_gfp parameters

Message ID cover.1719548446.git.wqu@suse.com (mailing list archive)
Headers show
Series btrfs: cleanup on the extra_gfp parameters | expand

Message

Qu Wenruo June 28, 2024, 4:21 a.m. UTC
[CHANGELOG]
v2:
- Instead of a one line wrapper, just rename @extra_gfp to @nofail

The @extra_gfp parameters for page/folio array allocation is only for
extent buffer allocation to pass __GFP_NOFAIL.
Furthermore there is no usage of btrfs_alloc_folio_array() for the extra
gfp flags.

This patchset removes the parameter for btrfs_alloc_folio_array() first,
then rename @extra_gfp to @nofail for btrfs_alloc_page_array().

Qu Wenruo (2):
  btrfs: remove the extra_gfp parameter from btrfs_alloc_folio_array()
  btrfs: rename the extra_gfp parameter of btrfs_alloc_page_array()

 fs/btrfs/compression.c |  2 +-
 fs/btrfs/extent_io.c   | 28 +++++++++++++---------------
 fs/btrfs/extent_io.h   |  5 ++---
 fs/btrfs/inode.c       |  2 +-
 fs/btrfs/raid56.c      |  6 +++---
 fs/btrfs/scrub.c       |  2 +-
 6 files changed, 21 insertions(+), 24 deletions(-)