mbox series

[0/3] btrfs: btrfs_buffered_write() cleanups

Message ID cover.1731297381.git.wqu@suse.com (mailing list archive)
Headers show
Series btrfs: btrfs_buffered_write() cleanups | expand

Message

Qu Wenruo Nov. 11, 2024, 3:59 a.m. UTC
This series is to cleanup btrfs_buffered_write() so that it's more
aligned to generic_perform_write(), and makes later migration much
easier.

All those changes are inside btrfs, and the last 2 should improve the
readablity, and prepare for the migration (since everything is now done
inside the loop).

Qu Wenruo (3):
  btrfs: make buffered write to respect fatal signals
  btrfs: cleanup the variables inside btrfs_buffered_write()
  btrfs: remove the out-of-loop cleanup from btrfs_buffered_write()

 fs/btrfs/file.c | 90 ++++++++++++++++++++++++++-----------------------
 1 file changed, 47 insertions(+), 43 deletions(-)

Comments

Qu Wenruo Nov. 12, 2024, 5:38 a.m. UTC | #1
在 2024/11/11 14:29, Qu Wenruo 写道:
> This series is to cleanup btrfs_buffered_write() so that it's more
> aligned to generic_perform_write(), and makes later migration much
> easier.

AlThe generic_perform_write() is kinda deprecated and we should go iomap 
anyway, so there will be no such migration.

But the improvement on the readability should still be worthy, thus the 
patches are still good.

Thanks,
Qu
> 
> All those changes are inside btrfs, and the last 2 should improve the
> readablity, and prepare for the migration (since everything is now done
> inside the loop).
> 
> Qu Wenruo (3):
>    btrfs: make buffered write to respect fatal signals
>    btrfs: cleanup the variables inside btrfs_buffered_write()
>    btrfs: remove the out-of-loop cleanup from btrfs_buffered_write()
> 
>   fs/btrfs/file.c | 90 ++++++++++++++++++++++++++-----------------------
>   1 file changed, 47 insertions(+), 43 deletions(-)
>