mbox series

[0/6] btrfs: rename exported functions from extent_map.h

Message ID cover.1744130413.git.fdmanana@suse.com (mailing list archive)
Headers show
Series btrfs: rename exported functions from extent_map.h | expand

Message

Filipe Manana April 8, 2025, 5:32 p.m. UTC
From: Filipe Manana <fdmanana@suse.com>

Many of the exported functions from extent_map.h don't have a 'btrfs_'
prefix, but some have, making it inconsistent and also against the coding
style conventions. I've added myself some of them recently, to get and set
compression on an extent map, and ended up not adding the prefix since the
other functions in the file didn't have the prefix, just to make things
consistent. So rename the ones without the prefix to have it.

I've split this into more reasonably sized patches to avoid having a huge
patch and make things easier to review.

Filipe Manana (6):
  btrfs: rename exported extent map compression functions
  btrfs: rename extent map functions to get block start, end and check if in tree
  btrfs: rename functions to allocate and free extent maps
  btrfs: rename remaining exported extent map functions
  btrfs: rename __lookup_extent_mapping() to remove double underscore prefix
  btrfs: rename __tree_search() to remove double underscore prefix

 fs/btrfs/compression.c            |  18 ++--
 fs/btrfs/defrag.c                 |  22 ++--
 fs/btrfs/direct-io.c              |  26 ++---
 fs/btrfs/disk-io.c                |   2 +-
 fs/btrfs/extent_io.c              |  45 +++++----
 fs/btrfs/extent_map.c             | 163 +++++++++++++++---------------
 fs/btrfs/extent_map.h             |  47 ++++-----
 fs/btrfs/file-item.c              |   4 +-
 fs/btrfs/file.c                   |  30 +++---
 fs/btrfs/inode.c                  |  80 +++++++--------
 fs/btrfs/relocation.c             |   4 +-
 fs/btrfs/super.c                  |   4 +-
 fs/btrfs/tests/extent-map-tests.c | 102 +++++++++----------
 fs/btrfs/tests/inode-tests.c      |  79 ++++++++-------
 fs/btrfs/tree-log.c               |  16 +--
 fs/btrfs/zoned.c                  |  10 +-
 16 files changed, 327 insertions(+), 325 deletions(-)

Comments

David Sterba April 8, 2025, 10:23 p.m. UTC | #1
On Tue, Apr 08, 2025 at 06:32:53PM +0100, fdmanana@kernel.org wrote:
> From: Filipe Manana <fdmanana@suse.com>
> 
> Many of the exported functions from extent_map.h don't have a 'btrfs_'
> prefix, but some have, making it inconsistent and also against the coding
> style conventions. I've added myself some of them recently, to get and set
> compression on an extent map, and ended up not adding the prefix since the
> other functions in the file didn't have the prefix, just to make things
> consistent. So rename the ones without the prefix to have it.
> 
> I've split this into more reasonably sized patches to avoid having a huge
> patch and make things easier to review.
> 
> Filipe Manana (6):
>   btrfs: rename exported extent map compression functions
>   btrfs: rename extent map functions to get block start, end and check if in tree
>   btrfs: rename functions to allocate and free extent maps
>   btrfs: rename remaining exported extent map functions
>   btrfs: rename __lookup_extent_mapping() to remove double underscore prefix
>   btrfs: rename __tree_search() to remove double underscore prefix

Reviewed-by: David Sterba <dsterba@suse.com>