diff mbox series

[1/2] btrfs: make btrfs_block_rsv_full() check more boolean when starting transaction

Message ID 01834d0e8f0143d09a29ec0541e9ccff63249e1c.1680185833.git.fdmanana@suse.com (mailing list archive)
State New, archived
Headers show
Series btrfs: some trivial updates for delayed ref space reservation | expand

Commit Message

Filipe Manana March 30, 2023, 2:39 p.m. UTC
From: Filipe Manana <fdmanana@suse.com>

When starting a transaction we are comparing the result of a call to
btrfs_block_rsv_full() with 0, but the function returns a boolean. While
in practice it is not incorrect, as 0 is equivalent to false, it makes it
a bit odd and less readable. So update the check to not compare against 0
and instead use the logical not (!) operator.

Signed-off-by: Filipe Manana <fdmanana@suse.com>
---
 fs/btrfs/transaction.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/fs/btrfs/transaction.c b/fs/btrfs/transaction.c
index c57d4408e7f1..a54a5c5a5db3 100644
--- a/fs/btrfs/transaction.c
+++ b/fs/btrfs/transaction.c
@@ -607,7 +607,7 @@  start_transaction(struct btrfs_root *root, unsigned int num_items,
 		 */
 		num_bytes = btrfs_calc_insert_metadata_size(fs_info, num_items);
 		if (flush == BTRFS_RESERVE_FLUSH_ALL &&
-		    btrfs_block_rsv_full(delayed_refs_rsv) == 0) {
+		    !btrfs_block_rsv_full(delayed_refs_rsv)) {
 			delayed_refs_bytes = num_bytes;
 			num_bytes <<= 1;
 		}