diff mbox series

[1/2] Install uncompressed man pages

Message ID 20180806205432.11009-1-floppym@gentoo.org (mailing list archive)
State New, archived
Headers show
Series [1/2] Install uncompressed man pages | expand

Commit Message

Mike Gilbert Aug. 6, 2018, 8:54 p.m. UTC
Build systems do not typically compress man pages when installing them.
This is generally left to distro packaging mechanisms, which may end up
recompressing them using a different compressor.
---
 Documentation/Makefile.in | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Comments

David Sterba Aug. 7, 2018, 2:09 p.m. UTC | #1
On Mon, Aug 06, 2018 at 04:54:31PM -0400, Mike Gilbert wrote:
> Build systems do not typically compress man pages when installing them.
> This is generally left to distro packaging mechanisms, which may end up
> recompressing them using a different compressor.

Makes sense. I've tested this on openSUSE and there's a post-build step
that indeed recompresses the manual pages. It does not work for me here
with the uncompressed pages yet for some reason, also the symlinked
pages would need to be reworked to the manual page links, but that can
be fixed.

I'll queue this patch for a major release, expecting that some breakage
might happen. Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
David Sterba Sept. 11, 2018, 3:39 p.m. UTC | #2
On Tue, Aug 07, 2018 at 04:09:57PM +0200, David Sterba wrote:
> On Mon, Aug 06, 2018 at 04:54:31PM -0400, Mike Gilbert wrote:
> > Build systems do not typically compress man pages when installing them.
> > This is generally left to distro packaging mechanisms, which may end up
> > recompressing them using a different compressor.
> 
> Makes sense. I've tested this on openSUSE and there's a post-build step
> that indeed recompresses the manual pages. It does not work for me here
> with the uncompressed pages yet for some reason, also the symlinked
> pages would need to be reworked to the manual page links, but that can
> be fixed.
> 
> I'll queue this patch for a major release, expecting that some breakage
> might happen. Thanks.

FYI, the patches are now in devel. Expected release is in 4.18.
diff mbox series

Patch

diff --git a/Documentation/Makefile.in b/Documentation/Makefile.in
index 184647c4..c4c843cb 100644
--- a/Documentation/Makefile.in
+++ b/Documentation/Makefile.in
@@ -37,9 +37,9 @@  MAN3_TXT += btrfs-ioctl.asciidoc
 MAN_TXT = $(MAN3_TXT) $(MAN8_TXT) $(MAN5_TXT)
 MAN_XML = $(patsubst %.asciidoc,%.xml,$(MAN_TXT))
 MAN_HTML = $(patsubst %.asciidoc,%.html,$(MAN_TXT))
-GZ_MAN3 = $(patsubst %.asciidoc,%.3.gz,$(MAN3_TXT))
-GZ_MAN5 = $(patsubst %.asciidoc,%.5.gz,$(MAN5_TXT))
-GZ_MAN8 = $(patsubst %.asciidoc,%.8.gz,$(MAN8_TXT))
+MAN3 = $(patsubst %.asciidoc,%.3,$(MAN3_TXT))
+MAN5 = $(patsubst %.asciidoc,%.5,$(MAN5_TXT))
+MAN8 = $(patsubst %.asciidoc,%.8,$(MAN8_TXT))
 
 mandir ?= $(prefix)/share/man
 man3dir = $(mandir)/man3
@@ -86,9 +86,9 @@  endif
 
 all: man
 man: man3 man5 man8
-man3: $(GZ_MAN3)
-man5: $(GZ_MAN5)
-man8: $(GZ_MAN8)
+man3: $(MAN3)
+man5: $(MAN5)
+man8: $(MAN8)
 html: $(MAN_HTML)
 
 install: install-man
@@ -96,15 +96,15 @@  install: install-man
 install-man: man
 	$(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
 	$(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
-	$(INSTALL) -m 644 $(GZ_MAN5) $(DESTDIR)$(man5dir)
+	$(INSTALL) -m 644 $(MAN5) $(DESTDIR)$(man5dir)
 	# the source file name of btrfs.5 clashes with section 8 page, but we
 	# want to keep the code generic
-	$(MV) $(DESTDIR)$(man5dir)/btrfs-man5.5.gz $(DESTDIR)$(man5dir)/btrfs.5.gz
-	$(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
-	$(LN_S) -f btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
+	$(MV) $(DESTDIR)$(man5dir)/btrfs-man5.5 $(DESTDIR)$(man5dir)/btrfs.5
+	$(INSTALL) -m 644 $(MAN8) $(DESTDIR)$(man8dir)
+	$(LN_S) -f btrfs-check.8 $(DESTDIR)$(man8dir)/btrfsck.8
 
 uninstall:
-	cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8.gz $(GZ_MAN8)
+	cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8 $(MAN8)
 	$(RMDIR) -p --ignore-fail-on-non-empty $(DESTDIR)$(man8dir)
 
 clean: