Message ID | 20190130145102.4708-9-nborisov@suse.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Improvements to fitrim | expand |
diff --git a/fs/btrfs/extent_io.h b/fs/btrfs/extent_io.h index d7beb2b3bc7d..af7e00a3678c 100644 --- a/fs/btrfs/extent_io.h +++ b/fs/btrfs/extent_io.h @@ -29,6 +29,10 @@ EXTENT_CLEAR_DATA_RESV) #define EXTENT_CTLBITS (EXTENT_DO_ACCOUNTING) + +/* Redefined bits above which are used only in the device allocation tree */ +#define CHUNK_ALLOCATED EXTENT_DIRTY + /* * flags for bio submission. The high bits indicate the compression * type for this bio
Rather than hijacking the existing defines let's just define new bits, with more descriptive names. Instead of using yet more (currently at 18) bits for the new flags, use the fact those flags will be specific to the device allocation tree so define them using existing EXTENT_* flags. Signed-off-by: Nikolay Borisov <nborisov@suse.com> --- fs/btrfs/extent_io.h | 4 ++++ 1 file changed, 4 insertions(+)