diff mbox series

[v4,5/7] btrfs: block-group: Rename write_one_cahce_group()

Message ID 20200504235825.4199-6-wqu@suse.com (mailing list archive)
State New, archived
Headers show
Series btrfs: Introduce new incompat feature SKINNY_BG_TREE to hugely reduce mount time | expand

Commit Message

Qu Wenruo May 4, 2020, 11:58 p.m. UTC
The name of this function contains the word "cache", which is left from
the era where btrfs_block_group is called btrfs_block_group_cache.

Now this "cache" doesn't match any thing, and we have better namings for
functions like read/insert/remove_block_group_item().

So rename this function to update_block_group_item().

Since we're here, also rename the local variables to be more like a
Chrismas tree, and rename @extent_root to @root for later reuse.

Signed-off-by: Qu Wenruo <wqu@suse.com>
---
 fs/btrfs/block-group.c | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)

Comments

Johannes Thumshirn May 5, 2020, 9:11 a.m. UTC | #1
Looks good on its own as well,
Reviewed-by: Johannes Thumshirn <johannes.thumshirn@wdc.com>

Btw, you have a type in the Subject line s/cahce/cache/
David Sterba May 11, 2020, 7:19 p.m. UTC | #2
On Tue, May 05, 2020 at 07:58:23AM +0800, Qu Wenruo wrote:
> The name of this function contains the word "cache", which is left from
> the era where btrfs_block_group is called btrfs_block_group_cache.
> 
> Now this "cache" doesn't match any thing, and we have better namings for
> functions like read/insert/remove_block_group_item().
> 
> So rename this function to update_block_group_item().
> 
> Since we're here, also rename the local variables to be more like a
> Chrismas tree, and rename @extent_root to @root for later reuse.

Please don't do that. The reverse chrismas tree is Somebody Else's
Coding Style and you introduce unrelated changes where only function
rename is expected. All reverted.
diff mbox series

Patch

diff --git a/fs/btrfs/block-group.c b/fs/btrfs/block-group.c
index 93e7835ca79d..46846749b631 100644
--- a/fs/btrfs/block-group.c
+++ b/fs/btrfs/block-group.c
@@ -2346,23 +2346,24 @@  void btrfs_dec_block_group_ro(struct btrfs_block_group *cache)
 	spin_unlock(&sinfo->lock);
 }
 
-static int write_one_cache_group(struct btrfs_trans_handle *trans,
-				 struct btrfs_path *path,
-				 struct btrfs_block_group *cache)
+static int update_block_group_item(struct btrfs_trans_handle *trans,
+				   struct btrfs_path *path,
+				   struct btrfs_block_group *cache)
 {
 	struct btrfs_fs_info *fs_info = trans->fs_info;
-	int ret;
-	struct btrfs_root *extent_root = fs_info->extent_root;
-	unsigned long bi;
-	struct extent_buffer *leaf;
 	struct btrfs_block_group_item bgi;
+	struct extent_buffer *leaf;
+	struct btrfs_root *root;
 	struct btrfs_key key;
+	unsigned long bi;
+	int ret;
 
 	key.objectid = cache->start;
 	key.type = BTRFS_BLOCK_GROUP_ITEM_KEY;
 	key.offset = cache->length;
+	root = fs_info->extent_root;
 
-	ret = btrfs_search_slot(trans, extent_root, &key, path, 0, 1);
+	ret = btrfs_search_slot(trans, root, &key, path, 0, 1);
 	if (ret) {
 		if (ret > 0)
 			ret = -ENOENT;
@@ -2674,7 +2675,7 @@  int btrfs_start_dirty_block_groups(struct btrfs_trans_handle *trans)
 			}
 		}
 		if (!ret) {
-			ret = write_one_cache_group(trans, path, cache);
+			ret = update_block_group_item(trans, path, cache);
 			/*
 			 * Our block group might still be attached to the list
 			 * of new block groups in the transaction handle of some
@@ -2823,7 +2824,7 @@  int btrfs_write_dirty_block_groups(struct btrfs_trans_handle *trans)
 			}
 		}
 		if (!ret) {
-			ret = write_one_cache_group(trans, path, cache);
+			ret = update_block_group_item(trans, path, cache);
 			/*
 			 * One of the free space endio workers might have
 			 * created a new block group while updating a free space
@@ -2840,7 +2841,7 @@  int btrfs_write_dirty_block_groups(struct btrfs_trans_handle *trans)
 			if (ret == -ENOENT) {
 				wait_event(cur_trans->writer_wait,
 				   atomic_read(&cur_trans->num_writers) == 1);
-				ret = write_one_cache_group(trans, path, cache);
+				ret = update_block_group_item(trans, path, cache);
 			}
 			if (ret)
 				btrfs_abort_transaction(trans, ret);