Message ID | 202211150914564821972@zte.com.cn (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [linux-next] btrfs: remove redundant ret variable in delete_v1_space_cache | expand |
On Tue, Nov 15, 2022 at 09:14:56AM +0800, guo.ziliang@zte.com.cn wrote: > From: guo ziliang <guo.ziliang@zte.com.cn> > Return value from delete_block_group_cache() directly instead of taking > this in another redundant variable. Have you found this manually or by some tool? I did a quick grep and found 14 other cases that could be simplified like that. I'm not sure if we really need it, but if you fix more than one case then lets do it.
diff --git a/fs/btrfs/relocation.c b/fs/btrfs/relocation.c index 56c8afa..d7f76cf 100644 --- a/fs/btrfs/relocation.c +++ b/fs/btrfs/relocation.c @@ -3374,7 +3374,6 @@ static int delete_v1_space_cache(struct extent_buffer *leaf, struct btrfs_key key; bool found = false; int i; - int ret; if (btrfs_header_owner(leaf) != BTRFS_ROOT_TREE_OBJECTID) return 0; @@ -3398,9 +3397,8 @@ static int delete_v1_space_cache(struct extent_buffer *leaf, } if (!found) return -ENOENT; - ret = delete_block_group_cache(leaf->fs_info, block_group, NULL, + return delete_block_group_cache(leaf->fs_info, block_group, NULL, space_cache_ino); - return ret; } /*