Message ID | 1574154146-8818-1-git-send-email-peng.fan@nxp.com (mailing list archive) |
---|---|
Headers | show |
Series | clk: imx: imx8m[x]: switch to clk_hw API | expand |
On 19-11-19 09:04:46, Peng Fan wrote: > From: Peng Fan <peng.fan@nxp.com> > > V3: > Rebased to linux-next to avoid conflict, not based on shawn's clk/imx > correct a few pll of imx8mn to imx_pll1443x_pll per Leonard's comments > add Abel's R-b tag > Adding the R-b tag again here: Reviewed-by: Abel Vesa <abel.vesa@nxp.com> > V2: > Add a new patch patch 1/4 to avoid build warning for arm64 > clk: imx: Remove __init for imx_obtain_fixed_clk_hw() API > https://patchwork.kernel.org/cover/11224933/ > > This patchset is to Switch i.MX8MN/M/Q clk driver to clk_hw > based API. > > Based on linux-next branch, with [1] applied. > > [1] clk: imx: switch to clk_hw based API > https://patchwork.kernel.org/cover/11217881/ > > Peng Fan (4): > clk: imx: Remove __init for imx_obtain_fixed_clk_hw() API > clk: imx: imx8mn: Switch to clk_hw based API > clk: imx: imx8mm: Switch to clk_hw based API > clk: imx: imx8mq: Switch to clk_hw based API > > drivers/clk/imx/clk-imx8mm.c | 550 +++++++++++++++++++++-------------------- > drivers/clk/imx/clk-imx8mn.c | 475 ++++++++++++++++++------------------ > drivers/clk/imx/clk-imx8mq.c | 569 ++++++++++++++++++++++--------------------- > drivers/clk/imx/clk.c | 4 +- > 4 files changed, 819 insertions(+), 779 deletions(-) > > -- > 2.16.4 >
On 2019-11-19 11:04 AM, Peng Fan wrote: > From: Peng Fan <peng.fan@nxp.com> > > V3: > Rebased to linux-next to avoid conflict, not based on shawn's clk/imx > correct a few pll of imx8mn to imx_pll1443x_pll per Leonard's comments > add Abel's R-b tag > > V2: > Add a new patch patch 1/4 to avoid build warning for arm64 > clk: imx: Remove __init for imx_obtain_fixed_clk_hw() API > https://patchwork.kernel.org/cover/11224933/ > > This patchset is to Switch i.MX8MN/M/Q clk driver to clk_hw > based API. > > Based on linux-next branch, with [1] applied. > > [1] clk: imx: switch to clk_hw based API > https://patchwork.kernel.org/cover/11217881/ For imx6/7 the big clks array was renamed to "hws" during the switch, maybe do this here as well as for consistency? Several non-imx drivers use the "hws" name as well. It would be nice to avoid another patch in the future that rewrites most of the file, that kind of stuff makes it difficult to read history. > Peng Fan (4): > clk: imx: Remove __init for imx_obtain_fixed_clk_hw() API > clk: imx: imx8mn: Switch to clk_hw based API > clk: imx: imx8mm: Switch to clk_hw based API > clk: imx: imx8mq: Switch to clk_hw based API > > drivers/clk/imx/clk-imx8mm.c | 550 +++++++++++++++++++++-------------------- > drivers/clk/imx/clk-imx8mn.c | 475 ++++++++++++++++++------------------ > drivers/clk/imx/clk-imx8mq.c | 569 ++++++++++++++++++++++--------------------- > drivers/clk/imx/clk.c | 4 +- > 4 files changed, 819 insertions(+), 779 deletions(-) >
From: Peng Fan <peng.fan@nxp.com> V3: Rebased to linux-next to avoid conflict, not based on shawn's clk/imx correct a few pll of imx8mn to imx_pll1443x_pll per Leonard's comments add Abel's R-b tag V2: Add a new patch patch 1/4 to avoid build warning for arm64 clk: imx: Remove __init for imx_obtain_fixed_clk_hw() API https://patchwork.kernel.org/cover/11224933/ This patchset is to Switch i.MX8MN/M/Q clk driver to clk_hw based API. Based on linux-next branch, with [1] applied. [1] clk: imx: switch to clk_hw based API https://patchwork.kernel.org/cover/11217881/ Peng Fan (4): clk: imx: Remove __init for imx_obtain_fixed_clk_hw() API clk: imx: imx8mn: Switch to clk_hw based API clk: imx: imx8mm: Switch to clk_hw based API clk: imx: imx8mq: Switch to clk_hw based API drivers/clk/imx/clk-imx8mm.c | 550 +++++++++++++++++++++-------------------- drivers/clk/imx/clk-imx8mn.c | 475 ++++++++++++++++++------------------ drivers/clk/imx/clk-imx8mq.c | 569 ++++++++++++++++++++++--------------------- drivers/clk/imx/clk.c | 4 +- 4 files changed, 819 insertions(+), 779 deletions(-)