Message ID | 20240430121443.30652-1-wsa+renesas@sang-engineering.com (mailing list archive) |
---|---|
Headers | show |
Series | crypto: use 'time_left' instead of 'timeout' with wait_for_*() functions | expand |
On Tue, Apr 30, 2024 at 02:14:41PM +0200, Wolfram Sang wrote: > [PATCH 0/1] crypto: use 'time_left' instead of 'timeout' with wait_for_*() functions 1-patch series should not have a cover letter. Just include the details in the patch itself. > There is a confusing pattern in the kernel to use a variable named 'timeout' to > store the result of wait_for_*() functions causing patterns like: > > timeout = wait_for_completion_timeout(...) > if (!timeout) return -ETIMEDOUT; > > with all kinds of permutations. Use 'time_left' as a variable to make the code > obvious and self explaining. I would understand it to be the remaining timeout, so I'm not sure the existing name is really that bad. But I agree that time_left is clearer. - Eric
On Tue, Apr 30, 2024 at 02:14:41PM +0200, Wolfram Sang wrote: > There is a confusing pattern in the kernel to use a variable named 'timeout' to > store the result of wait_for_*() functions causing patterns like: > > timeout = wait_for_completion_timeout(...) > if (!timeout) return -ETIMEDOUT; > > with all kinds of permutations. Use 'time_left' as a variable to make the code > obvious and self explaining. > > This is part of a tree-wide series. The rest of the patches can be found here > (some parts may still be WIP): > > git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git i2c/time_left > > Because these patches are generated, I audit them before sending. This is why I > will send series step by step. Build bot is happy with these patches, though. > No functional changes intended. > > Wolfram Sang (1): > crypto: api: use 'time_left' variable with > wait_for_completion_killable_timeout() > > crypto/api.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > -- > 2.43.0 All applied. Thanks.