mbox series

[v5,0/4] dma: sf-pdma: various sf-pdma updates for the mpfs platform

Message ID 20231208103856.3732998-1-shravan.chippa@microchip.com (mailing list archive)
Headers show
Series dma: sf-pdma: various sf-pdma updates for the mpfs platform | expand

Message

shravan chippa Dec. 8, 2023, 10:38 a.m. UTC
From: Shravan Chippa <shravan.chippa@microchip.com>

Changes from V4 -> V5:

Modified commit msg
Replaced the sf_pdma_of_xlate() function with 
of_dma_xlate_by_chan_id() 

Changes from V3 -> V4:

Removed unnecessary parentheses and extra space Added review tags

Changes from V2 -> V3:

Removed whitespace
Change naming convention of the macros (modified code as per new macros)
updated with new API device_get_match_data()
modified dt-bindings as per the commmets from v2
modified compatible name string for mpfs platform

Changes from V1 -> V2:

Removed internal review tags
Commit massages modified.
Added devicetree patch with new compatible name for mpfs platform
Added of_dma_controller_free() clenup call in sf_pdma_remove() function


V1:

This series does the following
1. Adds a PolarFire SoC specific compatible and code to support for
out-of-order dma transfers 

2. Adds generic device tree bindings support by using 
of_dma_controller_register()


Shravan Chippa (4):
  dmaengine: sf-pdma: Support of_dma_controller_register()
  dt-bindings: dma: sf-pdma: add new compatible name
  dmaengine: sf-pdma: add mpfs-pdma compatible name
  riscv: dts: microchip: add specific compatible for mpfs pdma

 .../bindings/dma/sifive,fu540-c000-pdma.yaml  |  1 +
 arch/riscv/boot/dts/microchip/mpfs.dtsi       |  2 +-
 drivers/dma/sf-pdma/sf-pdma.c                 | 44 +++++++++++++++++--
 drivers/dma/sf-pdma/sf-pdma.h                 |  8 +++-
 4 files changed, 50 insertions(+), 5 deletions(-)

Comments

Vinod Koul Dec. 11, 2023, 3:04 p.m. UTC | #1
On Fri, 08 Dec 2023 16:08:52 +0530, shravan chippa wrote:
> Changes from V4 -> V5:
> 
> Modified commit msg
> Replaced the sf_pdma_of_xlate() function with
> of_dma_xlate_by_chan_id()
> 
> Changes from V3 -> V4:
> 
> [...]

Applied, thanks!

[1/4] dmaengine: sf-pdma: Support of_dma_controller_register()
      commit: 8e578b47e6d92d5e43982ddc54045973dd4a7de5
[2/4] dt-bindings: dma: sf-pdma: add new compatible name
      commit: 72b22006ba78c2e3bf39b486a7b8155dc9020133
[3/4] dmaengine: sf-pdma: add mpfs-pdma compatible name
      commit: 58eea79a1cf285a62af886851b1a91ed5aceb401

Best regards,
Conor Dooley Feb. 6, 2024, 7:39 p.m. UTC | #2
From: Conor Dooley <conor.dooley@microchip.com>

On Fri, 08 Dec 2023 16:08:52 +0530, shravan chippa wrote:
> From: Shravan Chippa <shravan.chippa@microchip.com>
> 
> Changes from V4 -> V5:
> 
> Modified commit msg
> Replaced the sf_pdma_of_xlate() function with
> of_dma_xlate_by_chan_id()
> 
> [...]

Applied to riscv-dt-for-next, thanks!

[4/4] riscv: dts: microchip: add specific compatible for mpfs pdma
      https://git.kernel.org/conor/c/5669bb5a16a0

Thanks,
Conor.