diff mbox

[2/2] dmaengine: at_hdmac: Remove unnecessary 0x prefixes before %pad

Message ID 1509685942-12914-2-git-send-email-vinod.koul@intel.com (mailing list archive)
State Accepted
Headers show

Commit Message

Vinod Koul Nov. 3, 2017, 5:12 a.m. UTC
Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code
to special_hex_number()") %pad doesn't need 0x prefix so drop that.

Signed-off-by: Vinod Koul <vinod.koul@intel.com>
---
Cc: Nicolas Ferre <nicolas.ferre@atmel.com>
Cc: Joe Perches <joe@perches.com>

 drivers/dma/at_hdmac_regs.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Desroches Nov. 3, 2017, 7:14 a.m. UTC | #1
On Fri, Nov 03, 2017 at 10:42:22AM +0530, Vinod Koul wrote:
> Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code
> to special_hex_number()") %pad doesn't need 0x prefix so drop that.
> 
> Signed-off-by: Vinod Koul <vinod.koul@intel.com>
Acked-by: Ludovic Desroches <ludovic.desroches@microchip.com>

> ---
> Cc: Nicolas Ferre <nicolas.ferre@atmel.com>
> Cc: Joe Perches <joe@perches.com>
> 
>  drivers/dma/at_hdmac_regs.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/dma/at_hdmac_regs.h b/drivers/dma/at_hdmac_regs.h
> index 7f58f06157f6..ef3f227ce3e6 100644
> --- a/drivers/dma/at_hdmac_regs.h
> +++ b/drivers/dma/at_hdmac_regs.h
> @@ -385,7 +385,7 @@ static void vdbg_dump_regs(struct at_dma_chan *atchan) {}
>  static void atc_dump_lli(struct at_dma_chan *atchan, struct at_lli *lli)
>  {
>  	dev_crit(chan2dev(&atchan->chan_common),
> -		 "  desc: s%pad d%pad ctrl0x%x:0x%x l0x%pad\n",
> +		 "desc: s%pad d%pad ctrl0x%x:0x%x l%pad\n",
>  		 &lli->saddr, &lli->daddr,
>  		 lli->ctrla, lli->ctrlb, &lli->dscr);
>  }
> -- 
> 2.7.4
> 
> --
> To unsubscribe from this list: send the line "unsubscribe dmaengine" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe dmaengine" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Vinod Koul Nov. 8, 2017, 5:17 a.m. UTC | #2
On Fri, Nov 03, 2017 at 08:14:38AM +0100, Ludovic Desroches wrote:
> On Fri, Nov 03, 2017 at 10:42:22AM +0530, Vinod Koul wrote:
> > Since commit 3cab1e711297 ("lib/vsprintf: refactor duplicate code
> > to special_hex_number()") %pad doesn't need 0x prefix so drop that.
> > 
> > Signed-off-by: Vinod Koul <vinod.koul@intel.com>
> Acked-by: Ludovic Desroches <ludovic.desroches@microchip.com>

Thanks merged now
diff mbox

Patch

diff --git a/drivers/dma/at_hdmac_regs.h b/drivers/dma/at_hdmac_regs.h
index 7f58f06157f6..ef3f227ce3e6 100644
--- a/drivers/dma/at_hdmac_regs.h
+++ b/drivers/dma/at_hdmac_regs.h
@@ -385,7 +385,7 @@  static void vdbg_dump_regs(struct at_dma_chan *atchan) {}
 static void atc_dump_lli(struct at_dma_chan *atchan, struct at_lli *lli)
 {
 	dev_crit(chan2dev(&atchan->chan_common),
-		 "  desc: s%pad d%pad ctrl0x%x:0x%x l0x%pad\n",
+		 "desc: s%pad d%pad ctrl0x%x:0x%x l%pad\n",
 		 &lli->saddr, &lli->daddr,
 		 lli->ctrla, lli->ctrlb, &lli->dscr);
 }