diff mbox

[01/19] video: atmel_lcdfb: use dev_get_platdata()

Message ID 001101ceb363$b0f5b530$12e11f90$%han@samsung.com (mailing list archive)
State New, archived
Headers show

Commit Message

Jingoo Han Sept. 17, 2013, 5:06 a.m. UTC
Use the wrapper function for retrieving the platform data instead of
accessing dev->platform_data directly. This is a cosmetic change
to make the code simpler and enhance the readability.

Also, unnecessary casting from return value that is a void pointer
is removed.

Signed-off-by: Jingoo Han <jg1.han@samsung.com>
---
 drivers/video/atmel_lcdfb.c |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox

Patch

diff --git a/drivers/video/atmel_lcdfb.c b/drivers/video/atmel_lcdfb.c
index 088511a..df05550 100644
--- a/drivers/video/atmel_lcdfb.c
+++ b/drivers/video/atmel_lcdfb.c
@@ -935,8 +935,8 @@  static int __init atmel_lcdfb_probe(struct platform_device *pdev)
 
 	sinfo = info->par;
 
-	if (dev->platform_data) {
-		pdata_sinfo = (struct atmel_lcdfb_info *)dev->platform_data;
+	if (dev_get_platdata(dev)) {
+		pdata_sinfo = dev_get_platdata(dev);
 		sinfo->default_bpp = pdata_sinfo->default_bpp;
 		sinfo->default_dmacon = pdata_sinfo->default_dmacon;
 		sinfo->default_lcdcon2 = pdata_sinfo->default_lcdcon2;