Message ID | 1586424250-25897-1-git-send-email-oliver.graute@gmail.com (mailing list archive) |
---|---|
State | Superseded, archived |
Headers | show |
Series | [v1] staging: fbtft: fb_st7789v: enabled inversion | expand |
On Thu, Apr 09, 2020 at 11:24:05AM +0200, Oliver Graute wrote: > From: Oliver Graute <oliver.graute@kococonnector.com> > > Enable inversion mode > > Signed-off-by: Oliver Graute <oliver.graute@kococonnector.com> > --- > drivers/staging/fbtft/fb_st7789v.c | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/drivers/staging/fbtft/fb_st7789v.c b/drivers/staging/fbtft/fb_st7789v.c > index 3c3f387936e8..84c5af2dc9a0 100644 > --- a/drivers/staging/fbtft/fb_st7789v.c > +++ b/drivers/staging/fbtft/fb_st7789v.c > @@ -120,6 +120,10 @@ static int init_display(struct fbtft_par *par) > write_reg(par, PWCTRL1, 0xA4, 0xA1); > > write_reg(par, MIPI_DCS_SET_DISPLAY_ON); > + > + /* enable inversion mode */ > + write_reg(par, 0x21); Use the define and delete the comment. write_reg(par, MIPI_DCS_ENTER_INVERT_MODE); regards, dan carpenter
On Thu, Apr 09, 2020 at 11:24:05AM +0200, Oliver Graute wrote: > From: Oliver Graute <oliver.graute@kococonnector.com> > > Enable inversion mode What the heck is an inversion mode and why would you want it? regards, dasn carpenter
On 09/04/20, Dan Carpenter wrote: > On Thu, Apr 09, 2020 at 11:24:05AM +0200, Oliver Graute wrote: > > From: Oliver Graute <oliver.graute@kococonnector.com> > > > > Enable inversion mode > > What the heck is an inversion mode and why would you want it? Should I name it: Enable MIPI_DCS_ENTER_INVERT_MODE Best Regards, Oliver
On 09/04/20, Dan Carpenter wrote: > On Thu, Apr 09, 2020 at 11:24:05AM +0200, Oliver Graute wrote: > > From: Oliver Graute <oliver.graute@kococonnector.com> > > > > Enable inversion mode > > > > Signed-off-by: Oliver Graute <oliver.graute@kococonnector.com> > > --- > > drivers/staging/fbtft/fb_st7789v.c | 4 ++++ > > 1 file changed, 4 insertions(+) > > > > diff --git a/drivers/staging/fbtft/fb_st7789v.c b/drivers/staging/fbtft/fb_st7789v.c > > index 3c3f387936e8..84c5af2dc9a0 100644 > > --- a/drivers/staging/fbtft/fb_st7789v.c > > +++ b/drivers/staging/fbtft/fb_st7789v.c > > @@ -120,6 +120,10 @@ static int init_display(struct fbtft_par *par) > > write_reg(par, PWCTRL1, 0xA4, 0xA1); > > > > write_reg(par, MIPI_DCS_SET_DISPLAY_ON); > > + > > + /* enable inversion mode */ > > + write_reg(par, 0x21); > > Use the define and delete the comment. > > write_reg(par, MIPI_DCS_ENTER_INVERT_MODE); ok, I'll do on next version Best regards, Oliver
On Mon, Apr 27, 2020 at 10:29:39AM +0200, Oliver Graute wrote: > On 09/04/20, Dan Carpenter wrote: > > On Thu, Apr 09, 2020 at 11:24:05AM +0200, Oliver Graute wrote: > > > From: Oliver Graute <oliver.graute@kococonnector.com> > > > > > > Enable inversion mode > > > > What the heck is an inversion mode and why would you want it? > > > Should I name it: > > Enable MIPI_DCS_ENTER_INVERT_MODE > What I'm saying is the changelog should explain why would want to apply the patch. What does the inversion mode do? Is it inverting the color or flipping something upside down? Probably if I had a background in graphics I would know what "Enable inversion mode" means... But three words is not a proper and complete commit message normally. regards, dan carpenter
diff --git a/drivers/staging/fbtft/fb_st7789v.c b/drivers/staging/fbtft/fb_st7789v.c index 3c3f387936e8..84c5af2dc9a0 100644 --- a/drivers/staging/fbtft/fb_st7789v.c +++ b/drivers/staging/fbtft/fb_st7789v.c @@ -120,6 +120,10 @@ static int init_display(struct fbtft_par *par) write_reg(par, PWCTRL1, 0xA4, 0xA1); write_reg(par, MIPI_DCS_SET_DISPLAY_ON); + + /* enable inversion mode */ + write_reg(par, 0x21); + return 0; }