diff mbox series

[2/8] staging: sm750fb: rename gDviCtrlChipName

Message ID 20250417190302.13811-3-rubenru09@aol.com (mailing list archive)
State New
Headers show
Series staging: sm750fb: cleanup ddk750_sii164 | expand

Commit Message

Ruben Wauters April 17, 2025, 7:02 p.m. UTC
Renames gDviCtrlChipName to dvi_controller_chip_name
This fixes checkpatch.pl's camel case check.

Signed-off-by: Ruben Wauters <rubenru09@aol.com>

---

I changed the name to dvi_controller_chip_name as I
believe it is somewhat more descriptive than
g_dvi_ctrl_chip_name. If the second one is wanted instead
please let me know and I will change it
---
 drivers/staging/sm750fb/ddk750_sii164.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Greg Kroah-Hartman April 18, 2025, 10:36 a.m. UTC | #1
On Thu, Apr 17, 2025 at 08:02:50PM +0100, Ruben Wauters wrote:
> Renames gDviCtrlChipName to dvi_controller_chip_name
> This fixes checkpatch.pl's camel case check.
> 
> Signed-off-by: Ruben Wauters <rubenru09@aol.com>
> 
> ---
> 
> I changed the name to dvi_controller_chip_name as I
> believe it is somewhat more descriptive than
> g_dvi_ctrl_chip_name. If the second one is wanted instead
> please let me know and I will change it
> ---
>  drivers/staging/sm750fb/ddk750_sii164.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
> index dd7811b18bf6..d4309e0d807f 100644
> --- a/drivers/staging/sm750fb/ddk750_sii164.c
> +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> @@ -14,7 +14,7 @@
>  
>  #ifdef SII164_FULL_FUNCTIONS

This is never defined, so instead of papering over variable names that
are crazy, why not just remove all of the code in the blocks for this
define entirely?

thanks,

greg k-h
Ruben Wauters April 18, 2025, 11:45 a.m. UTC | #2
On Fri, 2025-04-18 at 12:36 +0200, Greg Kroah-Hartman wrote:
> On Thu, Apr 17, 2025 at 08:02:50PM +0100, Ruben Wauters wrote:
> > Renames gDviCtrlChipName to dvi_controller_chip_name
> > This fixes checkpatch.pl's camel case check.
> > 
> > Signed-off-by: Ruben Wauters <rubenru09@aol.com>
> > 
> > ---
> > 
> > I changed the name to dvi_controller_chip_name as I
> > believe it is somewhat more descriptive than
> > g_dvi_ctrl_chip_name. If the second one is wanted instead
> > please let me know and I will change it
> > ---
> >  drivers/staging/sm750fb/ddk750_sii164.c | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c
> > b/drivers/staging/sm750fb/ddk750_sii164.c
> > index dd7811b18bf6..d4309e0d807f 100644
> > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > @@ -14,7 +14,7 @@
> >  
> >  #ifdef SII164_FULL_FUNCTIONS
> 
> This is never defined, so instead of papering over variable names
> that
> are crazy, why not just remove all of the code in the blocks for this
> define entirely?

Given the amount of code that is never used and the time went into
writing this, it does make me wonder whether this code *should* be used
instead of being removed. I don't know exactly how it would be
integrated however, removal as of now might be the easiest option, but
I'm not entirely sure whether it would be the best option in terms of
functionality.

> thanks,
> 
> greg k-h
Greg Kroah-Hartman April 18, 2025, 12:09 p.m. UTC | #3
On Fri, Apr 18, 2025 at 12:45:28PM +0100, Ruben Wauters wrote:
> On Fri, 2025-04-18 at 12:36 +0200, Greg Kroah-Hartman wrote:
> > On Thu, Apr 17, 2025 at 08:02:50PM +0100, Ruben Wauters wrote:
> > > Renames gDviCtrlChipName to dvi_controller_chip_name
> > > This fixes checkpatch.pl's camel case check.
> > > 
> > > Signed-off-by: Ruben Wauters <rubenru09@aol.com>
> > > 
> > > ---
> > > 
> > > I changed the name to dvi_controller_chip_name as I
> > > believe it is somewhat more descriptive than
> > > g_dvi_ctrl_chip_name. If the second one is wanted instead
> > > please let me know and I will change it
> > > ---
> > >  drivers/staging/sm750fb/ddk750_sii164.c | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/drivers/staging/sm750fb/ddk750_sii164.c
> > > b/drivers/staging/sm750fb/ddk750_sii164.c
> > > index dd7811b18bf6..d4309e0d807f 100644
> > > --- a/drivers/staging/sm750fb/ddk750_sii164.c
> > > +++ b/drivers/staging/sm750fb/ddk750_sii164.c
> > > @@ -14,7 +14,7 @@
> > >  
> > >  #ifdef SII164_FULL_FUNCTIONS
> > 
> > This is never defined, so instead of papering over variable names
> > that
> > are crazy, why not just remove all of the code in the blocks for this
> > define entirely?
> 
> Given the amount of code that is never used and the time went into
> writing this, it does make me wonder whether this code *should* be used
> instead of being removed. I don't know exactly how it would be
> integrated however, removal as of now might be the easiest option, but
> I'm not entirely sure whether it would be the best option in terms of
> functionality.

Just remove it, odds are it was written a long time ago for other
hardware.  If someone needs it in the future, the git history has it
there for their use.

thanks,

greg k-h
diff mbox series

Patch

diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/drivers/staging/sm750fb/ddk750_sii164.c
index dd7811b18bf6..d4309e0d807f 100644
--- a/drivers/staging/sm750fb/ddk750_sii164.c
+++ b/drivers/staging/sm750fb/ddk750_sii164.c
@@ -14,7 +14,7 @@ 
 
 #ifdef SII164_FULL_FUNCTIONS
 /* Name of the DVI Controller chip */
-static char *gDviCtrlChipName = "Silicon Image SiI 164";
+static char *dvi_controller_chip_name = "Silicon Image SiI 164";
 #endif
 
 /*
@@ -254,7 +254,7 @@  void sii164_reset_chip(void)
  */
 char *sii164_get_chip_string(void)
 {
-	return gDviCtrlChipName;
+	return dvi_controller_chip_name;
 }
 
 /*