Message ID | 20201102184312.25926-1-willy@infradead.org (mailing list archive) |
---|---|
Headers | show |
Series | Refactor generic_file_buffered_read | expand |
On Mon, Nov 02, 2020 at 06:42:55PM +0000, Matthew Wilcox (Oracle) wrote: > This is a combination of Christoph's work to refactor > generic_file_buffered_read() and my THP support on top of Kent's patches > which are currently in -mm. I really like where this ended up. Nice patch series, I had a look at the results in your git tree and I really like where things ended up too. > > Christoph Hellwig (2): > mm/filemap: rename generic_file_buffered_read to filemap_read > mm: simplify generic_file_read_iter > > Matthew Wilcox (Oracle) (15): > mm/filemap: Rename generic_file_buffered_read subfunctions > mm/filemap: Use THPs in generic_file_buffered_read > mm/filemap: Pass a sleep state to put_and_wait_on_page_locked > mm/filemap: Support readpage splitting a page > mm/filemap: Inline __wait_on_page_locked_async into caller > mm/filemap: Don't call ->readpage if IOCB_WAITQ is set > mm/filemap: Change filemap_read_page calling conventions > mm/filemap: Change filemap_create_page arguments > mm/filemap: Convert filemap_update_page to return an errno > mm/filemap: Move the iocb checks into filemap_update_page > mm/filemap: Add filemap_range_uptodate > mm/filemap: Split filemap_readahead out of filemap_get_pages > mm/filemap: Remove parameters from filemap_update_page() > mm/filemap: Restructure filemap_get_pages > mm/filemap: Don't relock the page after calling readpage > > fs/btrfs/file.c | 2 +- > include/linux/fs.h | 4 +- > include/linux/pagemap.h | 3 +- > mm/filemap.c | 493 +++++++++++++++++++--------------------- > mm/huge_memory.c | 4 +- > mm/migrate.c | 4 +- > 6 files changed, 237 insertions(+), 273 deletions(-) > > -- > 2.28.0 >