mbox series

[0/8] mm: Remove PG_reclaim

Message ID 20250113093453.1932083-1-kirill.shutemov@linux.intel.com (mailing list archive)
Headers show
Series mm: Remove PG_reclaim | expand

Message

Kirill A. Shutemov Jan. 13, 2025, 9:34 a.m. UTC
Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.

After removing PG_relcaim, PG_readahead is exclusive user of the page
flag bit.

Kirill A. Shutemov (8):
  drm/i915/gem: Convert __shmem_writeback() to folios
  drm/i915/gem: Use PG_dropbehind instead of PG_reclaim
  mm/zswap: Use PG_dropbehind instead of PG_reclaim
  mm/swap: Use PG_dropbehind instead of PG_reclaim
  mm/vmscan: Use PG_dropbehind instead of PG_reclaim
  mm/vmscan: Use PG_dropbehind instead of PG_reclaim in
    shrink_folio_list()
  mm/mglru: Check PG_dropcache instead of PG_reclaim in
    lru_gen_folio_seq()
  mm: Remove PG_reclaim

 drivers/gpu/drm/i915/gem/i915_gem_shmem.c | 18 ++++-----
 fs/fuse/dev.c                             |  2 +-
 fs/proc/page.c                            |  2 +-
 include/linux/mm_inline.h                 |  4 +-
 include/linux/page-flags.h                | 15 +++-----
 include/trace/events/mmflags.h            |  2 +-
 include/uapi/linux/kernel-page-flags.h    |  2 +-
 mm/filemap.c                              | 12 ------
 mm/migrate.c                              | 10 +----
 mm/page-writeback.c                       | 16 +-------
 mm/page_io.c                              | 15 +++-----
 mm/swap.c                                 | 24 +-----------
 mm/vmscan.c                               | 46 ++++++-----------------
 mm/zswap.c                                |  4 +-
 tools/mm/page-types.c                     |  8 +---
 15 files changed, 41 insertions(+), 139 deletions(-)

Comments

Matthew Wilcox Jan. 13, 2025, 1:45 p.m. UTC | #1
On Mon, Jan 13, 2025 at 11:34:45AM +0200, Kirill A. Shutemov wrote:
> Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.

I was hoping we'd end up with the name PG_reclaim instead of the name
PG_dropbehind.  PG_reclaim is a better name for this functionality.
Kirill A. Shutemov Jan. 13, 2025, 2:07 p.m. UTC | #2
On Mon, Jan 13, 2025 at 01:45:48PM +0000, Matthew Wilcox wrote:
> On Mon, Jan 13, 2025 at 11:34:45AM +0200, Kirill A. Shutemov wrote:
> > Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.
> 
> I was hoping we'd end up with the name PG_reclaim instead of the name
> PG_dropbehind.  PG_reclaim is a better name for this functionality.

I got burned by re-using the name with MAX_ORDER redefinition.
I guess it is less risky as it is less used, but still...

Anyway, it can be done with a patch on top of the patchset. We must get
rid of current PG_reclaim first.