mbox series

[v2,0/2] optimize empty entry hint

Message ID PUZPR04MB63164ACED51074ACFA332BC181399@PUZPR04MB6316.apcprd04.prod.outlook.com (mailing list archive)
Headers show
Series optimize empty entry hint | expand

Message

Yuezhang.Mo@sony.com Nov. 2, 2022, 7:11 a.m. UTC
These commits reduce the number of directory entries traversed by
optimizing empty entry hint.

Changes for v2:
  - [1/2]
    - add exfat_reset_empty_hint()
    - rename exfat_hint_empty_entry() to exfat_set_empty_hint()
    - remove the condition `ei->hint_femp.count < num_entries`
  - [2/2]
    - Check the empty entries after unused entry in
      exfat_search_empty_slot()

Yuezhang Mo (2):
  exfat: simplify empty entry hint
  exfat: hint the empty entry which at the end of cluster chain

 fs/exfat/dir.c   | 76 +++++++++++++++++++++++++++++++-----------------
 fs/exfat/namei.c | 33 +++++++++++++--------
 2 files changed, 70 insertions(+), 39 deletions(-)