Message ID | 1473864486-30862-2-git-send-email-deepa.kernel@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Wed, 14 Sep 2016, Deepa Dinamani wrote: > +/** > + * current_time - Return FS time > + * @inode: inode. > + * > + * Return the current time truncated to the time granularity supported by > + * the fs. > + * > + * Note that inode and inode->sb cannot be NULL. > + * Otherwise, the function warns and returns time without truncation. > + */ > +struct timespec current_time(struct inode *inode) Just a nitpick. Can we please rename that to fs_current_time() or something similar which tells right away that this is a FS specific function. current_time() is pretty generic and used in many places as variable/argument name. Thanks, tglx -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
>> + * current_time - Return FS time >> + * @inode: inode. >> + * >> + * Return the current time truncated to the time granularity supported by >> + * the fs. >> + * >> + * Note that inode and inode->sb cannot be NULL. >> + * Otherwise, the function warns and returns time without truncation. >> + */ >> +struct timespec current_time(struct inode *inode) > > Just a nitpick. Can we please rename that to fs_current_time() or something > similar which tells right away that this is a FS specific > function. current_time() is pretty generic and used in many places as > variable/argument name. I proposed this as one of the names before: https://lkml.org/lkml/2016/6/14/613 . But, decided against it because of the inode argument. If this is preferred, I will change the patches. There are only about 30 (20, outside of staging) current_time references outside of Documentation/ -Deepa -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Wed, 14 Sep 2016, Deepa Dinamani wrote: > >> + * current_time - Return FS time > >> + * @inode: inode. > >> + * > >> + * Return the current time truncated to the time granularity supported by > >> + * the fs. > >> + * > >> + * Note that inode and inode->sb cannot be NULL. > >> + * Otherwise, the function warns and returns time without truncation. > >> + */ > >> +struct timespec current_time(struct inode *inode) > > > > Just a nitpick. Can we please rename that to fs_current_time() or something > > similar which tells right away that this is a FS specific > > function. current_time() is pretty generic and used in many places as > > variable/argument name. > > I proposed this as one of the names before: > https://lkml.org/lkml/2016/6/14/613 . > But, decided against it because of the inode argument. > If this is preferred, I will change the patches. > > There are only about 30 (20, outside of staging) current_time > references outside of Documentation/ It just occured to me and I can live with current_time() as well. Up to Al. Thanks, tglx -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/fs/inode.c b/fs/inode.c index fd604c0..a95e04e 100644 --- a/fs/inode.c +++ b/fs/inode.c @@ -2075,3 +2075,26 @@ void inode_nohighmem(struct inode *inode) mapping_set_gfp_mask(inode->i_mapping, GFP_USER); } EXPORT_SYMBOL(inode_nohighmem); + +/** + * current_time - Return FS time + * @inode: inode. + * + * Return the current time truncated to the time granularity supported by + * the fs. + * + * Note that inode and inode->sb cannot be NULL. + * Otherwise, the function warns and returns time without truncation. + */ +struct timespec current_time(struct inode *inode) +{ + struct timespec now = current_kernel_time(); + + if (unlikely(!inode->i_sb)) { + WARN(1, "current_time() called with uninitialized super_block in the inode"); + return now; + } + + return timespec_trunc(now, inode->i_sb->s_time_gran); +} +EXPORT_SYMBOL(current_time); diff --git a/include/linux/fs.h b/include/linux/fs.h index fde36d2..ab249e1 100644 --- a/include/linux/fs.h +++ b/include/linux/fs.h @@ -1471,6 +1471,7 @@ static inline void i_gid_write(struct inode *inode, gid_t gid) } extern struct timespec current_fs_time(struct super_block *sb); +extern struct timespec current_time(struct inode *inode); /* * Snapshotting support.