From patchwork Thu Feb 15 03:40:50 2018 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Matthew Wilcox X-Patchwork-Id: 10220317 Return-Path: Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org [172.30.200.125]) by pdx-korg-patchwork.web.codeaurora.org (Postfix) with ESMTP id A09EC601E7 for ; Thu, 15 Feb 2018 03:41:15 +0000 (UTC) Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 9340A274A3 for ; Thu, 15 Feb 2018 03:41:15 +0000 (UTC) Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486) id 87AC729042; Thu, 15 Feb 2018 03:41:15 +0000 (UTC) X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on pdx-wl-mail.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-4.1 required=2.0 tests=BAYES_00,DKIM_SIGNED, RCVD_IN_DNSWL_MED,T_DKIM_INVALID autolearn=ham version=3.3.1 Received: from mother.openwall.net (mother.openwall.net [195.42.179.200]) by mail.wl.linuxfoundation.org (Postfix) with SMTP id 9B908274A3 for ; Thu, 15 Feb 2018 03:41:13 +0000 (UTC) Received: (qmail 5742 invoked by uid 550); 15 Feb 2018 03:41:10 -0000 Mailing-List: contact kernel-hardening-help@lists.openwall.com; run by ezmlm Precedence: bulk List-Post: List-Help: List-Unsubscribe: List-Subscribe: List-ID: Delivered-To: mailing list kernel-hardening@lists.openwall.com Received: (qmail 5676 invoked from network); 15 Feb 2018 03:41:08 -0000 DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=bombadil.20170209; h=In-Reply-To:Content-Type:MIME-Version :References:Message-ID:Subject:Cc:To:From:Date:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description:Resent-Date: Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:List-Id: List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive; bh=stRn6TJ/p1dYHoUocpZSZiEZwxK20dsoTd0poZGjUHw=; b=JZrOpqwLU2eToVuAT7FqeyFXR 35yAeJCZKeUGkYF/2oAtTxI70joom4kFwpJd55cbhECW5nbMojuGCkjrP8Kzysj2JqijNZ6M4P2ok b35mkD0HTjEfzOTtAv8IoqtpRduR8tEBf/vPrqUHt/IjmJEAvO5ojJEg6lrSU4X967n+ESXJXfBg1 TBb8sBKl76UWOK0xfY+qPxvSpYp7pcvMXWkHP/dHUfNBl9vV72BrKZPxXJGBsBHhjd7N6eDdY8ckw pRsDZN+14bibPCqX12n+EEALnuETeQ6cscgryiAwbp3z3DCVSChsSsPUN92HknhviYUKeTamwuROa r9qZlln3w==; Date: Wed, 14 Feb 2018 19:40:50 -0800 From: Matthew Wilcox To: Andrew Morton Cc: Joe Perches , Matthew Wilcox , linux-mm@kvack.org, Kees Cook , linux-kernel@vger.kernel.org, kernel-hardening@lists.openwall.com Subject: Re: [PATCH v2 2/8] mm: Add kvmalloc_ab_c and kvzalloc_struct Message-ID: <20180215034050.GA5775@bombadil.infradead.org> References: <20180214201154.10186-1-willy@infradead.org> <20180214201154.10186-3-willy@infradead.org> <1518641152.3678.28.camel@perches.com> <20180214211203.GF20627@bombadil.infradead.org> <20180214155833.9f1563b87391f7ff79ca7ed0@linux-foundation.org> MIME-Version: 1.0 Content-Disposition: inline In-Reply-To: <20180214155833.9f1563b87391f7ff79ca7ed0@linux-foundation.org> User-Agent: Mutt/1.9.2 (2017-12-15) X-Virus-Scanned: ClamAV using ClamSMTP On Wed, Feb 14, 2018 at 03:58:33PM -0800, Andrew Morton wrote: > On Wed, 14 Feb 2018 13:12:03 -0800 Matthew Wilcox wrote: > > If C macros had decent introspection, I'd like it to be: > > > > sev = kvzalloc_struct(elems, GFP_KERNEL); > > > > and have the macro examine the structure pointed to by 'sev', check > > the last element was an array, calculate the size of the array element, > > and call kvzalloc_ab_c. But we don't live in that world, so I have to > > get the programmer to tell me the structure and the name of the last > > element in it. > > hm, bikeshedding fun. Heck, yeah! Fun! > struct foo { > whatevs; > struct bar[0]; > } > > > struct foo *a_foo; > > a_foo = kvzalloc_struct_buf(foo, bar, nr_bars); > > and macro magic will insert the `struct' keyword. This will help to > force a miscompile if inappropriate types are used for foo and bar. > > Problem is, foo may be a union(?) and bar may be a scalar type. So > > a_foo = kvzalloc_struct_buf(struct foo, struct bar, nr_bars); > > or, of course. > > a_foo = kvzalloc_struct_buf(typeof(*a_foo), typeof(a_foo->bar[0]), > nr_bars); > > or whatever. I think that's actually *less* checking than the option I presented here. My version has the compiler check: 1. You assigned the pointer to the allocated memory 2. ... to a pointer of compatible type with p 3. p is a pointer 4. member is a member of the type p points to 5. member is an array type Your version doesn't check point 4, and it'd be easy to get it wrong like this: struct quux { int n; struct foo foos[]; } *p = kvmalloc_struct(struct quux, struct foo *, n); or vice-versa: struct quux { int n; struct foo *foos[]; } *p = kvmalloc_struct(struct quux, struct foo, n); What is it that you don't like about my version? Is it passing the uninitialised pointer to a macro that looks like a function? Because we do this all the time: struct foo *p = kmalloc(sizeof(*p), GFP_KERNEL); > The basic idea is to use the wrapper macros to force compile errors if > these things are misused. Right. Although passing the pointer in lets us work this magic on an unnamed struct. Like this mess... > > +static inline __must_check > > +void *kvmalloc_ab_c(size_t n, size_t size, size_t c, gfp_t gfp) > > +{ > > + if (size != 0 && n > (SIZE_MAX - c) / size) > > + return NULL; > > + > > + return kvmalloc(n * size + c, gfp); > > +} > > Can we please avoid the single-char identifiers? > > void *kvmalloc_ab_c(size_t n_elems, size_t elem_size, size_t header_size, > gfp_t gfp); > > makes the code so much more readable. I was naming for consistency: static inline void *kvmalloc_array(size_t n, size_t size, gfp_t flags) { if (size != 0 && n > SIZE_MAX / size) return NULL; I'll happily change 'c' to 'hdr_size' though. diff --git a/arch/x86/events/intel/uncore.c b/arch/x86/events/intel/uncore.c index 7874c980d569..5cd3e127bea8 100644 --- a/arch/x86/events/intel/uncore.c +++ b/arch/x86/events/intel/uncore.c @@ -792,7 +792,7 @@ static void uncore_type_exit(struct intel_uncore_type *type) kfree(type->pmus); type->pmus = NULL; } - kfree(type->events_group); + kvfree(type->events_group); type->events_group = NULL; } @@ -805,8 +805,6 @@ static void uncore_types_exit(struct intel_uncore_type **types) static int __init uncore_type_init(struct intel_uncore_type *type, bool setid) { struct intel_uncore_pmu *pmus; - struct attribute_group *attr_group; - struct attribute **attrs; size_t size; int i, j; @@ -831,21 +829,24 @@ static int __init uncore_type_init(struct intel_uncore_type *type, bool setid) 0, type->num_counters, 0, 0); if (type->event_descs) { + struct { + struct attribute_group group; + struct attribute *attrs[]; + } *attr_group; for (i = 0; type->event_descs[i].attr.attr.name; i++); - attr_group = kzalloc(sizeof(struct attribute *) * (i + 1) + - sizeof(*attr_group), GFP_KERNEL); + attr_group = kvzalloc_struct(attr_group, attrs, i + 1, + GFP_KERNEL); if (!attr_group) goto err; - attrs = (struct attribute **)(attr_group + 1); - attr_group->name = "events"; - attr_group->attrs = attrs; + attr_group->group.name = "events"; + attr_group->group.attrs = attr_group->attrs; for (j = 0; j < i; j++) - attrs[j] = &type->event_descs[j].attr.attr; + attr_group->attrs[j] = &type->event_descs[j].attr.attr; - type->events_group = attr_group; + type->events_group = &attr_group->group; } type->pmu_group = &uncore_pmu_attr_group;