Message ID | 20190807065706.11411-4-yanaijie@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | implement KASLR for powerpc/fsl_booke/32 | expand |
Jason Yan <yanaijie@huawei.com> writes: > Now the kernel base is a fixed value - KERNELBASE. To support KASLR, we > need a variable to store the kernel base. > > Signed-off-by: Jason Yan <yanaijie@huawei.com> > Cc: Diana Craciun <diana.craciun@nxp.com> > Cc: Michael Ellerman <mpe@ellerman.id.au> > Cc: Christophe Leroy <christophe.leroy@c-s.fr> > Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org> > Cc: Paul Mackerras <paulus@samba.org> > Cc: Nicholas Piggin <npiggin@gmail.com> > Cc: Kees Cook <keescook@chromium.org> > Reviewed-by: Christophe Leroy <christophe.leroy@c-s.fr> > Reviewed-by: Diana Craciun <diana.craciun@nxp.com> > Tested-by: Diana Craciun <diana.craciun@nxp.com> > --- > arch/powerpc/include/asm/page.h | 2 ++ > arch/powerpc/mm/init-common.c | 2 ++ > 2 files changed, 4 insertions(+) > > diff --git a/arch/powerpc/include/asm/page.h b/arch/powerpc/include/asm/page.h > index 0d52f57fca04..60a68d3a54b1 100644 > --- a/arch/powerpc/include/asm/page.h > +++ b/arch/powerpc/include/asm/page.h > @@ -315,6 +315,8 @@ void arch_free_page(struct page *page, int order); > > struct vm_area_struct; > > +extern unsigned long kimage_vaddr; > + > #include <asm-generic/memory_model.h> > #endif /* __ASSEMBLY__ */ > #include <asm/slice.h> > diff --git a/arch/powerpc/mm/init-common.c b/arch/powerpc/mm/init-common.c > index 152ae0d21435..d4801ce48dc5 100644 > --- a/arch/powerpc/mm/init-common.c > +++ b/arch/powerpc/mm/init-common.c > @@ -25,6 +25,8 @@ phys_addr_t memstart_addr = (phys_addr_t)~0ull; > EXPORT_SYMBOL_GPL(memstart_addr); > phys_addr_t kernstart_addr; > EXPORT_SYMBOL_GPL(kernstart_addr); > +unsigned long kimage_vaddr = KERNELBASE; > +EXPORT_SYMBOL_GPL(kimage_vaddr); The names of the #defines and variables we use for these values are not very consistent already, but using kimage_vaddr makes it worse I think. Isn't this going to have the same value as kernstart_addr, but the virtual rather than physical address? If so kernstart_virt_addr would seem better. cheers
On 2019/8/7 21:03, Michael Ellerman wrote: > Jason Yan <yanaijie@huawei.com> writes: >> Now the kernel base is a fixed value - KERNELBASE. To support KASLR, we >> need a variable to store the kernel base. >> >> Signed-off-by: Jason Yan <yanaijie@huawei.com> >> Cc: Diana Craciun <diana.craciun@nxp.com> >> Cc: Michael Ellerman <mpe@ellerman.id.au> >> Cc: Christophe Leroy <christophe.leroy@c-s.fr> >> Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org> >> Cc: Paul Mackerras <paulus@samba.org> >> Cc: Nicholas Piggin <npiggin@gmail.com> >> Cc: Kees Cook <keescook@chromium.org> >> Reviewed-by: Christophe Leroy <christophe.leroy@c-s.fr> >> Reviewed-by: Diana Craciun <diana.craciun@nxp.com> >> Tested-by: Diana Craciun <diana.craciun@nxp.com> >> --- >> arch/powerpc/include/asm/page.h | 2 ++ >> arch/powerpc/mm/init-common.c | 2 ++ >> 2 files changed, 4 insertions(+) >> >> diff --git a/arch/powerpc/include/asm/page.h b/arch/powerpc/include/asm/page.h >> index 0d52f57fca04..60a68d3a54b1 100644 >> --- a/arch/powerpc/include/asm/page.h >> +++ b/arch/powerpc/include/asm/page.h >> @@ -315,6 +315,8 @@ void arch_free_page(struct page *page, int order); >> >> struct vm_area_struct; >> >> +extern unsigned long kimage_vaddr; >> + >> #include <asm-generic/memory_model.h> >> #endif /* __ASSEMBLY__ */ >> #include <asm/slice.h> >> diff --git a/arch/powerpc/mm/init-common.c b/arch/powerpc/mm/init-common.c >> index 152ae0d21435..d4801ce48dc5 100644 >> --- a/arch/powerpc/mm/init-common.c >> +++ b/arch/powerpc/mm/init-common.c >> @@ -25,6 +25,8 @@ phys_addr_t memstart_addr = (phys_addr_t)~0ull; >> EXPORT_SYMBOL_GPL(memstart_addr); >> phys_addr_t kernstart_addr; >> EXPORT_SYMBOL_GPL(kernstart_addr); >> +unsigned long kimage_vaddr = KERNELBASE; >> +EXPORT_SYMBOL_GPL(kimage_vaddr); > > The names of the #defines and variables we use for these values are not > very consistent already, but using kimage_vaddr makes it worse I think. > > Isn't this going to have the same value as kernstart_addr, but the > virtual rather than physical address? > Yes, that's true. > If so kernstart_virt_addr would seem better. > OK, I will take kernstart_virt_addr if no better name appears. > cheers > > . >
diff --git a/arch/powerpc/include/asm/page.h b/arch/powerpc/include/asm/page.h index 0d52f57fca04..60a68d3a54b1 100644 --- a/arch/powerpc/include/asm/page.h +++ b/arch/powerpc/include/asm/page.h @@ -315,6 +315,8 @@ void arch_free_page(struct page *page, int order); struct vm_area_struct; +extern unsigned long kimage_vaddr; + #include <asm-generic/memory_model.h> #endif /* __ASSEMBLY__ */ #include <asm/slice.h> diff --git a/arch/powerpc/mm/init-common.c b/arch/powerpc/mm/init-common.c index 152ae0d21435..d4801ce48dc5 100644 --- a/arch/powerpc/mm/init-common.c +++ b/arch/powerpc/mm/init-common.c @@ -25,6 +25,8 @@ phys_addr_t memstart_addr = (phys_addr_t)~0ull; EXPORT_SYMBOL_GPL(memstart_addr); phys_addr_t kernstart_addr; EXPORT_SYMBOL_GPL(kernstart_addr); +unsigned long kimage_vaddr = KERNELBASE; +EXPORT_SYMBOL_GPL(kimage_vaddr); static bool disable_kuep = !IS_ENABLED(CONFIG_PPC_KUEP); static bool disable_kuap = !IS_ENABLED(CONFIG_PPC_KUAP);