Message ID | 20210919094630.30668-1-len.baker@gmx.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | writeback: prefer struct_size over open coded arithmetic | expand |
On 9/19/21 04:46, Len Baker wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > In this case this is not actually dynamic size: all the operands > involved in the calculation are constant values. However it is best to > refactor this anyway, just to keep the open-coded math idiom out of > code. > > So, use the struct_size() helper to do the arithmetic instead of the > argument "size + count * size" in the kzalloc() function. > > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > > Signed-off-by: Len Baker <len.baker@gmx.com> > --- > fs/fs-writeback.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/fs/fs-writeback.c b/fs/fs-writeback.c > index 81ec192ce067..f7abff31e026 100644 > --- a/fs/fs-writeback.c > +++ b/fs/fs-writeback.c > @@ -624,8 +624,8 @@ bool cleanup_offline_cgwb(struct bdi_writeback *wb) > int nr; > bool restart = false; > > - isw = kzalloc(sizeof(*isw) + WB_MAX_INODES_PER_ISW * > - sizeof(struct inode *), GFP_KERNEL); > + isw = kzalloc(struct_size(isw, inodes, WB_MAX_INODES_PER_ISW), > + GFP_KERNEL); There is another instance at: 569 isw = kzalloc(sizeof(*isw) + 2 * sizeof(struct inode *), GFP_ATOMIC); 570 if (!isw) 571 return; If you are finding these with the help of Coccinelle, please mention it in the changelog text. :) Thanks -- Gustavo > if (!isw) > return restart; > > -- > 2.25.1 >
diff --git a/fs/fs-writeback.c b/fs/fs-writeback.c index 81ec192ce067..f7abff31e026 100644 --- a/fs/fs-writeback.c +++ b/fs/fs-writeback.c @@ -624,8 +624,8 @@ bool cleanup_offline_cgwb(struct bdi_writeback *wb) int nr; bool restart = false; - isw = kzalloc(sizeof(*isw) + WB_MAX_INODES_PER_ISW * - sizeof(struct inode *), GFP_KERNEL); + isw = kzalloc(struct_size(isw, inodes, WB_MAX_INODES_PER_ISW), + GFP_KERNEL); if (!isw) return restart;
As noted in the "Deprecated Interfaces, Language Features, Attributes, and Conventions" documentation [1], size calculations (especially multiplication) should not be performed in memory allocator (or similar) function arguments due to the risk of them overflowing. This could lead to values wrapping around and a smaller allocation being made than the caller was expecting. Using those allocations could lead to linear overflows of heap memory and other misbehaviors. In this case this is not actually dynamic size: all the operands involved in the calculation are constant values. However it is best to refactor this anyway, just to keep the open-coded math idiom out of code. So, use the struct_size() helper to do the arithmetic instead of the argument "size + count * size" in the kzalloc() function. [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments Signed-off-by: Len Baker <len.baker@gmx.com> --- fs/fs-writeback.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) -- 2.25.1